Help With Octoprint Set Up

Hey all, I’m finally getting back to trying to set up my Raspberry Pi with Octoprint. I am new to RiPi and Octoprint.

A quick update on my previous attempt to set up Octoprint onto my new Raspberry Pi. I previously tried to get octoprint set up and it seams something was going wrong with writing the octoprint image to the SD card. Maybe Im doing something wrong when formatting the card or it is getting corrupted when writing the image. I tried many many times with the same results, major issues with network function. SO To make sure it was not a hardware issue with the RPi itself I had the company i bought it from send me a new SD card with the standard OS preinstalled on it. Everything is fine with the hardware. I can boot the RPi normally, get to the GUI, get on the internet, etc. so all is fine.

Here is the previous thread.
https://forum.lulzbot.com/t/help-with-raspberry-pi-octoprint-set-up/1711/1

Question is
Can I install Ocotprint on to this existing SD card with out screwing everything up and getting Ocotprint up and running?

http://mirror.tsone.net.uk/octopi/2015-07-02_2015-05-05-octopi-wheezy-0.12.0.zip

Just worked for me. Unpacked the image, wrote to SD using the “dd” utility, ran “sync”. After that, connected the Ethernet port, plugged in power, and then both SSH and HTTP services were available. IIRC HTTPS was already available out of the box, though the certificates should be regenerated for real security.

If you are concerned about keeping the usable data that shipped with your SD card, simply use “dd” to back up an image.

I was able to get the RiPi set up with Octoprint and get it all up and running. Im good to go, now just need to learn Octopi.

https://raw.githubusercontent.com/mirage335/LulzBotTaz_Softload/master/LulzBotTazConfig/.octoprint/config.yaml

You may want to try that configuration, and install the command manager plugin.