Help with Raspberry Pi / Octoprint set up

I got a Raspberry Pi to set up and use Octoprint. Hit a snag In the set up. I would have went to the Rasspberry Pi forum to post this but I wonder if they might not know about Octoprint set up issues. So here I am. Hopefully I won’t get booted out of here. Hope you guys can help. Thanks.

I have the Octopi image written to the SD card and installed on the RPi. The RPI boots up normally, but I have not booted to the GUI only to the black dos text looking screen. Where I am stuck is going on to my PC and typing in my browser (Firefox) Octopi.local to connect the RPI to the network. I get a page or address not found error in my browser. Now I forget exactly what it said. But basically I can not log onto the Octopi on line interface.

This is the video I’m using for instruction.

At first I did not realize the printer (Taz 5 ) was suppose to be plugged in. Tom did not instruct to do so. So I shut down the RPi and plugged the printers cable in, turned on the printer, and the rebooted the RPi. Same results can not log into the Octoprint web interface.

In the set up I did not set up wifi I want to set up the RPi via wired connection.

The RPi dose not show up on my computers network? Shouldn’t it be there?
Am I suppose to be booted up to the GUI on the RPi?

Log in to your router and look in attached devices. You should see an entry named octopi.

Try typing that IP address into your browser. Octopi.local only works if you have bonjour installed on the windows PC.

Nopick thanks for the input.

There is no Octopi entry in my network list of devices.

To double check, you’re using an ethernet cable and not WiFi?

If you have the pi hooked up to a monitor/keyboard you could type into the console ifconfig and you’d get its IP:

(It would probably be under eth0 if you’re using ethernet)

This is what I get when typing in ifconfig.

And I am only connected via either net cable. I do not want to set up thr RPi with wifi.

Your pi isn’t pulling an ip address via dhcp for some reason.

Have you tried writing the img to the SD card again?

No i haven’t

You should be seeing an entry for eth0 in the output of iconfig (thats the wired ethernet interface on the pi). Try running sudo ifup eth0 and let us know what happens.

Before I saw this last post I thought I would try to log In to the GUI so I typed startx at the text screen. It seamed like it was logimg into the GUI but never got that far. The screen is blank?? The RPi is still on.

I don’t want to screw things up, I read by not shouting down properly it can curupt the SD card.

So with my screen blank how do I shut down, OR. Reboot properly???

Then I will sudo ifup eth0

I ended up just unplugging the RPi and restart it. Then ran the ‘sudo ifup eth0’ and this is what I get.

Now I see the Octopi on my network. I was able to get bonjour installed as well. But not out of the woods yet, still could not log into Octopi.local I will try again tomorrow. Maybe rebooting computer will do it.

I always like a static IP address for my servers… predictable. :slight_smile:

So I start up my computer today and type in ocopi.local in firefox with the same issue. I get a server not found error.

IS the ocopi or Taz 5 suppost to show up in the list of printers in the Bonjour print wizard?

Another thing is I type in startx on the text screen and is seams to start booting into the GUI BUT never gets there, screen goes blank and nothing happens??

Look in your router’s attached devices list. You should see octopi there. I don’t personally rely on bonjour… not a fan. You should be able to assign an IP to the Pi’s MAC in your router so it always pulls the same address via DHCP. Then you can bookmark that IP and easily go back to the web interface.

You shouldn’t need to startx. That will load the GUI for Linux. If you are using the octopi pre-built image, the octoprint server will start automatically on boot up of the Pi.

You aren’t required to use bonjour, its just a convenience. From the last line of output from the ifup eth0 command, we can see that your pi has the ip Load that IP with firefox (put it in the address bar) and you should be good to go!

Hey Guys I really appreciate the help but I’m kind lost now. Isn’t the next step to log into the ocotopi web interface and get that working? SO I can communicate with the Printer?

As I said in another post octopi IS now in the network list of devices on my router.
Based on the info provided dose it looks like my Ethernet connection is working correctly now??

I typed in the IP address that is assigned to the RPi into my command line in firefox and I get the same Unable to connect error. IS this what I should be getting? IF NOT what should I be getting?

Nopick, Your talking about assigning the IP to the Pis MAC I have only a very slight clue of what your saying, I would need a step by step instruction on how to do this.

Also again when typing in the octopi.local i get the unable to connect error.

Im un sure what the next step is based on your guys input. In the video Im watching Tom shows as the next step is to log into the ocopi.local interface??.
Screen Shot 3.jpg

What happens when you try the ping connectivity test from the router? If that’s successful, try pinging the IP address from your Windows command line.

As another test, power down the Pi and try pings from the windows command line again. Make sure no response, if there is a response then something else on your network is answering to the same IP address.

From your PC, type That should bring up the octoprint web interface. If it works bookmark the page.

If directly on the raspberry pi, in the browser try Should get you to the octoprint web interface.

Test is successful when I ping the Octopi / Pi on my router interface.

When I type in ping192.168.1.22 in my command line I get (server not found) error Is there suppose to be a space between Ping and 192?? Never done this??

When I type in ping (WITH a space between ping & 192) I get the search results shown in the screen shot attached.

When I type in http//: in my command line I get (unable to connect) error

When I power down the Pi it is no longer in the device list on my router, and I do not see any other devices using the same IP address.

I have no idea how to get to the Pis browser as I said before I can not get the Pi GUI it never boots all the way to the GUI.

After I posted this I rebooted my computer & the Pi to see if that would fix the problem. Now after reboot the Octopi is NOT in the device list in my router.

It looks like you are trying to ping from the address bar on your web browser. That will not work.

You need to find the program cmd if you are running windows. That is the windows command processor. You ping from there.

First, verify you are attempting to connect to the correct IP address by rebooting your Pi and checking the attached devices list on your router for the current IP associated with octopi. Once you have the IP, go to the command prompt and use the ping command: ping 192.168.1.XXX

Replace the xxx with your actual IP address. You should get a reply something like this:
Reply from bytes=32 time=222ms TTL=47
Reply from bytes=32 time=156ms TTL=47
Reply from bytes=32 time=179ms TTL=47
Reply from bytes=32 time=191ms TTL=47

If you get a response from the IP address, type the same address in the address bar of your browser. Let us know what happens.

Another thing to try:

boot your RPi with screen/keyboard attached. when you get to a command prompt, type in

sudo apt-get update

This is the equivalent of using Windows Update and downloads and installs the newest libraries/drivers/etc, and I have had to do it in the past when using the OctoPi image. Then reboot and try again.

If you can’t type in startx and get to the GUI, you have other issues with your RPi and image. If you can load the browser in the GUI and go to any website, you know you are connected to the network and it is working.

Ok so now I know you ping from the cmd prompt, you guys were telling me to ping from my browser in the other posts??

Ive rebooted the Pi several times and it is NOT in my routers device list now? So its obviously not connected to the network.

I tried the sudo apt-get update witch would not work anyways without internet.

I am also on the Raspberry Pi forum and this is what one of the fellas told me to do, But he tells me Just open an LXTerminal and copy’n’paste the stuff I posted. HOW am I suppose to copy and past on the Pi?

I also tried typing this in exactly but when I type the " I get the @ character??? are you suppost to type the qoutes" ’ ??

I also tried typing it with out the quotes and i get access denied

by DougieLawson » Sun May 03, 2015 2:26 pm
sudo sh -c ‘echo “nameserver” >> /etc/resolv.conf’ # will fix it.