Inventor Scaling

Most people probably aren’t using Inventor, but I use it at work so I am most comfortable with it right now. So far I’ve just been modeling parts in inches and I change the units over to mm before I export as an .stl. I noticed the models look very small in Slic3r so I used Netfabb to measure the parts and dimensions that were 38 mm showed as being 3.8mm. I scaled everything by 1000 in Slic3r but they still seem to be off a bit. Is there a better way to get accurate parts?

If you select a milimeter based project from the begininning, the parts will output correctly. You can convert them after the fact by scaling the model using 1 inch = 25.4 mm, but i’ve noticed the same thing that it doesn’t seem to scale correctly. I was able to overcome that behavior by converting the size of the exported stl file outside of inventor using netfabb and then dropping it back in. Far easier to start with the correct mm part setting from the beginning though.

I would be a bit careful about using 1 inch = 24.5mm.

Over here 1 inch = 25.4mm

It was a typo.

Seems to be working now, even if I export the STL in inches. I do bring the part in to Netfabb first usually to rotate it, then to Slic3r where I scale by 1000 then in to Pronterface and dimensions are looking pretty good. Thanks!

Hey I wanted to give you a little help.
My company uses Inventor as well and before we got our TAZ4 I would make a lot of STL files to get SLA’s quoted.
Your problem is likely happening when Inventor makes the STL.

I’m working with Inventor Pro 2014 but I don’t think the path has changed much over the different revs.
I (top left) > Save as > Save copy as

So here you select STL files from the “save as type” drop box and then if you look directly below the box you should see options. Click it. This is where you see where you select the units that the STL will be exported as. Make sure it is the right units you want. All you have to do is change it once and Inventor will remember from now on.

Please note even if you use a mm ipt or change to mm in doc settings it will not change the units the STL is exported as

Also while you are in here, if you are having trouble with resolution on your parts. It might not be just a problem with layer size but also the resolution size Inventor is making the STL. I print a lot of smaller parts and use the medium resolution.

Hope it saves you some time!!