problems using slic3r on first print with new TAZ

I am setting up my new TAZ and wanted to print a plastic part I designed. I sliced the STL file and then imported the gcode file into pronterface. It only shows the print as a circle consisting of 2 layers. I then scaled it up 1000% and it showed the piece represented as it was designed but the dimensions are way off and still too small. I created the 3d file in cubify invent(because it is super easy to use and I initially thought I was going to by a cubify printer). It was created in inches scale rather than millimeters. I used cubify invent to export to STL. It seems the exported stl file has made the design too small to be read by proterface. I downloaded Kisslicer and tried to slice with that and it says “could not slice with current settings most likely the walls are thinner than the extrusion width.” I changed the setting under “All Model” and selected “inch->Millimeter” and it sliced it but when I opened it in pronterface, It placed the print centered at the printer’s home. I am attaching a screenshot to show that. At this point I’m not sure what to do to get it printed. Any help would be appreciated.

can you post the stl?

I tried to upload the stl file as an attachment but tells me the stl extension is not allowed

I could email it though.

try repetier host. I think you can scale parts, and I know you can place them where you want.

us 25.4 to convert inch to metric (or 1/25.4 for the other way around)

Zip the stl, I believe the forum accepts .zip archives.

Obviously your model was not scaled correctly by Cubify Invent. Unless it was really 7/8" x 25/32" x 13/32" high?

I strongly recommend you learn to model directly in metric units (millimeters) to avoid this kind of problem.

Personally I am so sick of that retrograde and illogical imperial/US system. And I have to work with it everyday.

I’m using Slic3r to generate gcode and so far it has worked well. There is a setting for the bed size and the print center. Maybe check Kisslicer settings for something similar?

BTW with Slic3r you can download config files made by Lulzbot specifically for the TAZ.

Here is the stl file zipped. I would welcome any feedback on success in slicing it for printing using slic3r or other programs. I am probably screwing the thing up somehow. I am completely new to CAD, 3d printing, and using all the different programs involved. I appreciate the help.
clip diameter medium with wings and band (1.15 MB)

I found and used a program called netfabb to analyze and repair the cubify invent stl file. It seems to have worked. Any better repair programs out there? It now slices with slic3r and shows up in printrun looking correct. I did have to scale up by 25.4 like was suggested (thanks!) Now if my filament would just arrive I could test print. Thanks for the suggestions and help from everyone.

As a side note, we’ve added .stl to the list of file formats that can be uploaded.