Issue using a Taz5 w/ Octoprint on Pi.

I am very new to this all and could use some guidance. I have purchased a Taz 5, Raspberry Pi, and installed Octoprint.

For the life of me I cannot get it to communicate with the fork of Cura because it only wants a serial port which are amazingly absent from both.

Has anyone managed to get this combo working? I want to use the Pi due to lack of spare PC’s for the purpose and it’s location. Seems a networking module for the Taz 5 would make things a bit easier but…

Thanks.

There may be a different way of using Octoprint in conjunction with Cura. But my workflow is to slice the project, save the gcode file then upload the file to Octoprint (drag and drop) over the network.

I think OctoPi uses Cura 15.04 so you would set up the Cura on the Pi with the profile you want to use/slice with. Drag/Drop the STL file into the OctoPrints’ Web page and wait for the Pi to slice it. Then print it out using the web page for the OctoPrint application on the Pi. YMMV with this approach though.

That isn’t my current issue. Currently it only wants a serial connection, which the Pi has none. I have the pleasure of learning both a new technology type, new operating system type, and pretty much new everything else. Kind of like when I first starting getting into networking, it’s entirely an alien environment and just trying to find the logic to the madness.

The control board in the printer connects via a USB to serial bridge. To the computer connecting to it, it looks like a serial port. You see this on a PC as well, Windows uses COM ports, Linux/OSX use /dev/tty* devices, etc… I haven’t set up a Pi to control my Mini yet, but that’s the basic idea.

There is usually an option to auto-detect the serial port, that should find the printer. If not, try to find it the long way…

Log into the command line on the Pi using SSH or whatever.

With the printer disconnected, do “ls /dev/tty*”. There will be a lot, but you can scroll up in the terminal window if on SSH. If you are using the Pi connected to a monitor/keyboard Shift-PgUp should work.

Now plug the printer in again, wait a bit, maybe even use “lsusb” to make sure the system sees it and has a chance to set it up. Now do the same “ls /dev/tty*” again. Look for a new entry. It’s probably /dev/tty.usbmodem with some extra stuff on the end. That’s your serial port.

You can also plug the printer in and do “dmesg”. Look toward the end, there should be a log entry for the printer attaching. It might not show the device name though. It depends on how the logging was done for that driver.

Universal
Serial
Bus

The Pi should have several USerialB ports on it.

So you plug in the printer into the Pi using a USB cable/port. IF you have and it still does not see the printer then you may have a problem with Octoprint.

@kmanley57 You do realize that a universal serial bus and a legacy serial connection are not exactly the same, correct? Over the legacy serial, you can do ssh or telnet, use it as a null modem, etc. Typically all using a fairly low baud rate. Over USB, that really isn’t an option. Plus, USB can also carry IDE, SATA, Parallel, and even SCSI, all of which have nothing to do with legacy serial related communication. Thanks for the input though.

@ttabbal That make sense. I had not realized the printer controller itself was the emulated serial port over usb. I may need to look at uploading a driver of some kind to the Pi.

Thanks!

You shouldn’t need any drivers added, the kernel USB serial driver is universal.

You usually use legacy serial for SLOW dumb terminals and REALLY OLD printers/meters, and SSH/telnet over the network interface. :nerd:

The Pi is the network device you connect the Taz 5 to and then talk to it by network protocols for printing. The Pi sees the printer as a serial device just like it is a ‘legacy serial’ device. No needed drivers or anything like that.

My setup as of right now.
Screen Shot 2015-12-18 at 7.57.04 PM.png

Are you trying to connect Cura to the Pi (Octoprint)… if that’s the case, you’re doing it wrong.

Just plug the printer into the Pi via USB. Connect to Octoprint through the web interface: http://octopi.local. Drag and drop your .gcode files saved from Cura.