Taz 6 will not communicate to Win 10/ worked prev

I’m stuck! I was running on OctoPi Print for the last year/s and I purchased a new Pi but in the process I am attempting to return straight to Cura (latest 3.6.31), Marlin Firmware (1.1.9.34) and USB control. However, I can no longer communicate nor see the Rambo board despite re-installing Cura again and the drivers. What can be wrong? As I stated I cannot even see the Rambo in Device Manager and all of this recently worked even on the USB as I just recently installed a Dual 3 Dual extruder. I also switched USB Printer cables twice to eliminate obvious simple problems. Now my computer will not communicate at all on my Windows 10 system. Any assistance would be appreciated…thanks in advance.

Did you get rid of the OctoPi or are you still using that. I wasn’t sure if you mentioned changing to CuraLE but still using OctoPi … or if OctoPi is out of the picture and you’re connecting Windows 10 to the printer directly.

I normally print everything through OctoPi and am familiar with how to set that up … but I don’t normally use Windows.

Hi,
No the OctoPi is turned off and no longer works. I bought a new one for the upgrade. I am starting completely over so I am trying to use the latest Cura through my Windows desktop computer. I reinstalled Cura and drivers but I don’t the TAZ 6 is not communicating with the PC. I have looked at Device Manager and I don’t see the TAZ. I replaced the USB cables but no luck. The TAZ worked fine up to this point with the old Pi. I have the latest firmware uploaded using for a Dual V3.

I normally use macOS as my daily machine (I have a Windows machine but rarely use it). So I’m probably not the best for advice on how to solve the issue of the printer not showing up.

But if you have the new Pi … grab Raspberry Pi Imager: Raspberry Pi OS – Raspberry Pi

After installing it, launch it, and in the “Operating System” pull-down menu navigate to:

Other specific-purpose OS -> 3D Printing -> OctoPi -> OctoPi (stable)

You can choose your storage target (microSD card)

Click the gear icon and you can pre-fill your WiFi network name & password. Then click “Write” and it’ll do the whole thing for you. Put it in your Pi, boot it, connect and define the printer and you’re back in business.

In OctoPi, don’t forget to go into the configuration settings and click the ‘API’ section, copy the API key and paste that to Cura LE. In Cura that’s found in:

Preferences -> Printers -> pick your printer -> Connect OctoPrint

On Windows 10, I use USB Device Tree Viewer. I believe it is easier to find my USB devices like my TAZ 6. Here is what it looks like on my Windows 10 system:

=========================== USB Port3 ===========================

Connection Status        : 0x01 (Device is connected)
Port Chain               : 2-3-3-3
Properties               : 0x01
 IsUserConnectable       : yes
 PortIsDebugCapable      : no
 PortHasMultiCompanions  : no
 PortConnectorIsTypeC    : no

      ======================== USB Device ========================

        +++++++++++++++++ Device Information ++++++++++++++++++
Friendly Name            : RAMBo (COM5)
Device Description       : RAMBo
Device Path              : \\?\usb#vid_27b1&pid_0001#75530313231351f06051#{a5dcbf10-6530-11d2-901f-00c04fb951ed}
Device ID                : USB\VID_27B1&PID_0001\75530313231351F06051
Hardware IDs             : USB\VID_27B1&PID_0001&REV_0001 USB\VID_27B1&PID_0001
Driver KeyName           : {4d36e978-e325-11ce-bfc1-08002be10318}\0002 (GUID_DEVCLASS_PORTS)
Driver                   : \SystemRoot\System32\drivers\usbser.sys (Version: 10.0.18362.1  Date: 2019-03-18)
Driver Inf               : C:\WINDOWS\inf\oem3.inf
Legacy BusType           : PNPBus
Class                    : Ports
Class GUID               : {4d36e978-e325-11ce-bfc1-08002be10318} (GUID_DEVCLASS_PORTS)
Interface GUID           : {a5dcbf10-6530-11d2-901f-00c04fb951ed} (GUID_DEVINTERFACE_USB_DEVICE)
Service                  : usbser
Enumerator               : USB
Location Info            : Port_#0003.Hub_#0010
Location IDs             : PCIROOT(0)#PCI(1C07)#PCI(0000)#USBROOT(0)#USB(3)#USB(3)#USB(3), ACPI(_SB_)#ACPI(PCI0)#ACPI(PEX7)#PCI(0000)#USBROOT(0)#USB(3)#USB(3)#USB(3)
Container ID             : {1599e2ca-58fa-5ad9-bf84-1c5b1bb4fb7c}
Manufacturer Info        : MatterHackers, Inc. (www.matterhackers.com)
Capabilities             : 0x94 (Removable, UniqueID, SurpriseRemovalOK)
Status                   : 0x0180600A (DN_DRIVER_LOADED, DN_STARTED, DN_DISABLEABLE, DN_REMOVABLE, DN_NT_ENUMERATOR, DN_NT_DRIVER)
Problem Code             : 0
Power State              : D0 (supported: D0, D2, D3, wake from D0, wake from D2)
COM-Port                 : COM5 (\Device\USBPDO-20)

I normally have my TAZ 6 connected to OctoPi / OctoPrint on a Raspberry Pi 3B but I have a USB switch so I can move it to Windows 10 when necessary.

Connecting to my TAZ 6 with CuraLE 3.6.31:

< [07:12:13] Correct response for auto-baudrate detection received.
< [07:12:13] Correct response for auto-baudrate detection received.
< [07:12:13] Correct response for auto-baudrate detection received.
< [07:12:13] Missing firmware_toolhead_name in profile. Skipping check.
< [07:12:13] Expected that FIRMWARE_VERSION was 2.0.9.0.8, but got 2.0.9.0.9 instead
< [07:12:13] Installed firmware is outdated
< [07:12:13] Printer connection listen thread started for COM5
< [07:12:13] Established printer connection on port COM5
< [07:12:17] Requesting temperature auto-update

Looks like caused more grief mentioning that once had my system connected to my Pi. :frowning: I am not trying to connect to Octopi. I am trying to connect directly to my USB on Windows 10.

I have checked the following:

USB port works on Win 10 desktop

Cable works with other printer

Port dings and shows other devices when connected and appear in Device Manager

TAZ 6 does not appear in Device Manager and now USB Tree View

System worked just fine until I was forced to change to a Pi 4 which I have not done yet.

System should work straight to newly loaded Cura. Same Cura version as before system stopped working

image0.jpeg

Is this screen shot of Cura?

My computer for whatever reason does not recognize the Rambo board. The USB lights on TAZ works. I’m not sure why it won’t communicate.

Can’t make out what is being reported on that port you highlighted but it doesn’t appear to be a “RAMBo” and it doesn’t appear to have a serial port assignment. When you click on a line on the left side (tree view) of the USB Device Tree Viewer, the right side contains text which you can select, copy, and paste (using the </> button).

I understand that OctoPi / OctoPrint has nothing to do with this Windows 10 issue. Everything I posted was from my Windows 10 system on which my TAZ 6 is successfully seen by USB Tree Viewer and CuraLE. The first text block is from USB Tree Viewer and the second text block is from CuraLE Monitor when I selected COM5 and clicked Connect.

Assuming that your CuraLE install is good, the USB port is good, and the USB cable is good then the only conclusion I can come to is the controller board in the TAZ 6 is broken.

I’m sorry but there’s not much else I can think of to try.

Yeah that is something I deleted to try to eliminate any confusion on port 3. I’m not where to go from here. Last night I mentioned I had tried a second laptop PC. Do ypu think the firmware that once communicated to the Octopi could be the problem? I was thinking of trying to load the firmware through the SD card. Can I do that? I’t be like starting completely over.

I’ve never had a problem with any version of TAZ 6 firmware communicating with either OctoPrint on a Raspberry Pi or CuraLE on Windows 10.

I’m unaware of any way to load the firmware through the SD card.

Hi,
It’s me again, does your 3D printer led work? Even when idle if it is connect via the USB to USB?

I didn’t even know there was an LED!

There appears to be light around the USB plug. Not sure what that circle above the lettering is supposed to be.

I took the side cover off and the hole above the USB connector is for the reset switch.

There are two small LEDs on the board (mine is a 1.3L) labled LED1 and LED7. LED7 (Power?) is solid green when the power is on. LED1 (Status?) is off.

This should be the manual and schematics.

Thank you mine does that too. Everything else regarding the board works LCD, motors, heater controls, etc. Not sure what has happened. If I was going to get another board would you upgrade to a 32bit Archim?

I think I have answered the upgrade question. I will just stick with the Rambo 1.3. Looks like way too much hassle to fiddle with Drunken Octopus and Archim 2.