Issue with Marlin_TAZ6_Universal_2.

I updated my Taz6 with the Marlin_TAZ6_Universal_2. firmware and decided to test a print. The bed leveling is off somehow. I have a crappy video but somewhat large to display the behavior. After the wipe, there are a few seconds of pause then the tool head moves to the back left side to touch down. That looks okay, then the front touches but is towards the back of the metal disk but that’s okay. Next the tool head goes to the front right and is completly off the metal disk and ends up touching the side of the disk (meaning the nozzle is below the disk and the contact point is not the bottom of the nozzle but the tapered side.) I stopped the print at that point since it might damage the bed when printing. Is there some adjustment I can make to get the touch locations to be more centered on the metal disks? I didn’t see this behavior with the previous hex file. 2.0.6Processing: Taz6_Marlin_2.0.9.mp4…

I didn’t upload the video here but I can if you need to see it. (290mb or so)

@iguanaman Have you selected the “Standard” Tool Head via Tool Heads menu option? It looks as iff the M206 Y5 gcode is not being applied correctly. If you have selected the correct Tool Head, me next best suggestion would be to loosen the 8 bolts connecting to the extrusion on the Y axis assembly, then home the Z axis and right before it touches the home button, shut the machine off. Adjust the bed to center the nozzle to the button. Once it is centered, tighten the bolts that connect to the extrusion on the Y axis assembly and then the nozzle should have no issue probing.

I didn’t select anything from the tool head menu. I am simply flashing the firmware remotely via Octoprint.

If you push the lcd button and move down to the Tool Heads option on the printer after you flash firmware, select the “Standard” option. Moving forward with firmware, there is only one universal firmware and Tool Heads are selected via this option on the printer which adjusts the stepper current, E-steps, PID values and position.

I did reflash back to the previous 2.0.6 which worked correctly with no changes other than the firmware. I will try the option on the LCD screen with the 2.0.9 and see how that affects things.

I did reflash to 2.0.9 and set to the Standard Toolhead. This time the touchdowns were on the metal pads as expected. I will need to remember to make that adjustment whenever updating the firmware in the future.

Thanks for the assistance!

I am glad we got you printing again with our latest version of firmware!

Happy printing!

The standard tool head has a unique e-step value (printed on the back). Remember to set this value whenever you change tool heads back to the standard tool head on the menu.

Where is that set in the LCD menu? I wasn’t able to find the setting for the e-step. My value appears to be 833 e-Steps. I found an example that indicated to go to Configuration > Motion > ESteps but I don’t see these options under configuration in the 2.0.9 menus.