Lulzbot Mini 2 - Homing Failed Please Reset

I’ve been having some issues with probing the bed - often when probing each corner, my mini 2 will press way too hard into a corner, resulting in a loud clicking noise, and then reset and usually into an endless loop of bed probing failures.

When looking up that issue, a fix is to clean the nozzle well so I heat up the nozzle, scrub it clean, and often it will fix itself for a print, but I’m finding that I’m having to do that after nearly every print, and even then it’ll only successfully probe the bed 1 out of 5 times. I have to turn on/off the printer and try again and hope it decides that it’ll probe fine.

(If anyone has any feedback on that issue, that’d be GREAT)

However, one time after cleaning the nozzle, the printer will not auto home, level X axis from the LCD menu or start a print. It doesn’t move at all and after 5 seconds or so I get the “Homing Failed PRINTER HALTED Please Reset” error.

After tinkering around a bit, I identified a switch on top the upper left X axis that when pressed, it seems to function fine. It looks like it’s supposed to be pressed up against the upper left corner of the chassis maybe? In any case, I hold that down and it works great but obviously that is not a real fix.

I’ve also tried issuing the M914 X2 command:

[07:54:09] M914
< [07:54:11] X homing sensitivity: 2
< [07:54:11] Y homing sensitivity: 4

and the M121 (disable endstops) command to no avail.

What should I be looking at? Has anyone else encountered either problem? I’ve found a couple posts but the solutions so far have not worked for me.

Thanks!

Just to add to this, when the button is pressed down I can not get any movement at all from the Z axis. Using Cura or otherwise, but X and Y are able to move.

To get reliable probing you need a good electrical circuit from the nozzle through the corner washers and the spacers below to the bed plate. I’d recommend taking a scotch-brite scrub pad and clean the top surface of the bed corner washers well. If that doesn’t help the probing, remove the washers and clean the bottom sides too, and the top and bottom surfaces of the cylindrical spacers below the washers. Then look down the holes in the black bed corners and make sure the metal of the bed plate in the bottom of the hole is clean. You don’t want anything to preventing good solid contact of all the metal surfaces.

Another thing to check is that the ground wires are connected well under the bed plate. There should be two wires with ring terminals connected to a screw on the bottom of the bed plate. Make sure the nut holding those two ring terminals is tight.

As for the homing problem that’s harder to diagnose. The switch you found on the upper left of the X axis is actually for detecting homing of the Z axis. It should touch the top of the frame when the X axis goes all the way to the top. The M914 command does not affect Z homing because Z homing uses this switch. Homing the X and Y is done by detecting the increased current through the X and Y motors when they bump into the ends of their travel. The M914 adusts the sensitivity of how much increase is necessary to detect that the X or Y axis has bumped into the end of travel. Setting it lower makes it more sensitive. Usually both are set to either 4 or 3. Typically what would happen is if the X or Y reaches the end of travel and instead of stopping continues to try to push with a buzzing sound you would change it from 4 to 3. If you set it down to 2, it’s possible that it will be to sensitive and stop before it actually reaches the home position. But if you have no movement at all, sensitivity is not your current problem.

If this happened after cleaning the nozzle, the question is, did you clean it with a wire brush? I haven’t done it, but I’ve heard in other threads here that cleaning with a wire brush can cause a short between the heater block and the connections to the heater and/or thermistor. This can blow a fuse on the circuit board inside the control box, if you do it with the power on. Even if you didn’t use a wire brush, I think the fuses are the first thing to check.

1 Like

I cleaned the nozzle with one of the supplied pads, while the unit was on. (won’t be doing that anymore)

I just took a look at the 3 fuses and none of them are blown.

I’ll go ahead and reset the X sensitivity settings.

Also thank you for the in depth response to the bed probing. I’ll make sure those contacts are clean and the ground wires are secure.

The scotch-brite pads supplied should not be electrically conductive, so it should be OK to use them to wipe the nozzle with the power on. I do it all the time and have never caused a problem.

1 Like

I do find it odd that X/Y won’t move unless I press the Z homing switch. I think there’s something there I just don’t know what.

EDIT: scratch - X/Y will home via Cura.

I believe that if you are doing an auto home it tries to home the Z axis first and won’t home the X or Y until it sees the Z axis hit that switch on top of the frame. When you press the switch you are fooling it into thinking it has succeeded in homing the Z and it continues on to homing the X and Y. That shows that the switch is actually working. We just need to figure out why the Z axis isn’t moving. Once you’ve fooled it by pressing the Z home switch you should be able to go into the movement menu and move each axis manually in the menu. You could try moving the Z up and down there to see if it does anything.

I just removed the tool head to inspect it, everything seems fine in there - I was worried that the extruder heating cables might be the cause of it, since they sit so close to where I was cleaning.

I also tried moving the Y axis via the LCD menu to no avail - X and Y move fine (with the Z switch pressed). I really hope the rambo isn’t fried because of this. Any idea what I should look for?

Really appreciate your help thus far.

Do you mean you have to hold down the Z switch to get the X and Y to move? If so that’s kind of strange, as I figured you were just clicking it once to fool it into thinking it had homed the Z properly. I don’t know why you would have to hold it to get X and Y to move.

I guess one thing you could try is unplugging the motor wires from the rambo, and plug each Z motor cable into one of the working outputs like the X or Y, and see if you can make the Z motors move from the X or Y output. That would indicate if the Z motors and cables are still good.

After working with support we tried a few things:

1 - Verified continuity:

First, as an easy test, can you please flash your printers firmware in Cura to bring everything back to a factory setting.
Do you have a multimeter available for testing by change?
If so, you can go ahead and turn the printer on and home it.
Once homed, you can take your multimeter and set to to Ohm “Ω” and prove the tool head to the corners.
First, I would touch the metal tensioner screw on the front of the tool head to the corner and you should get some resistance
This will fluctuate a little bit but getting some resistance will show continuity.
If you do get that continuity, you will want to move to the nozzle.
Touch one probe to a bed corner, the other to the nozzle and see if you are getting the continuity there.
If you are not, there is a disconnect between the thumb screw and nozzle.

This all checked out.

2 - We then moved the Z cable to E0 on the board, heated up the nozzle to 150*, and extruded either direction (but in actuality we were trying to get a signal to the motor, not the motor on the actual print head.) pinout below:

image

Didn’t get any Z movement on either motor when doing that.

3 - Then bypassed each Z cable from the z brake board, directly into E0:

and I got movement from both motors separately!

So, looks like the Z Brake Board is bad and will have to be replaced.

Just wanted to update this thread in case anyone else runs into a similar issue.

So if the Z brake board is actually bad, you could verify that in another way. You can actually take both the motor cables that plug into the Z brake board and plug them directly into the two Z connectors on the Einsy Retro board. You should be able to power the printer on and get movement of the Z motors. Not sure why I didn’t think of that before.

The purpose of the Z brake board is to try and hold the Z motors in position when the printer is powered off, and I don’t believe it actually does much when the printer is powered on. The side effect of bypassing the Z brake board is that when you power the machine off the X axis might droop down on one or both ends.

So if you plug the Z motor cables directly into the controller and it homes everything correctly, the printer should be able to operate normally until powered off again.

Great call. When I do that and auto home, the Z axis hits the top of the chassis and grinds until it halts.

Wonder if this part that I’m not sure where it goes has something to do with it? :slight_smile:

It feels like the switch isn’t being pressed so it keeps going up.

Any idea where it goes?

That looks like the bracket that holds the LCD ribbon cables to the left side plate of the frame, above where they come out of the control box cable hole. Not sure why it isn’t in your printer. :slight_smile:
See the OHAI assembly instruction page for Mini 2 final electrical assembly, step 15, to see where it goes and how to install it.

So if your Z axis is grinding against the top then the problem is that the Z axis switch isn’t working or for some other reason it is not able to reach the top and hit the top frame plate before something else is stopping the Z axis from going up higher. I think from your previous messages that the switch itself is working, but you could test that again by just manually pressing the switch as it starts to move up and it should stop moving up. You might have to press it a second time quick to make it think it has homed because I think it normally does a little double bump against the top when homing. You can’t operate the printer normally after doing this because it’s not properly homed, but that will tell you that the switch is working.

If you find the switch is still working you will have to try and watch the left X axis end piece when it moves up and try to see what is preventing it from reaching the top. And the moment I can’t think of how to give you more help with figuring that out without me being able to actually look at the printer.

I tinkered a bit more with this and got it going. I manually pushed the Z all the way to the top, and while it still struggles from time to time, it’s good enough for now. I feel like the bushings might need some cleaning. The right side tends to “push” down and looks uneven when I level the X axis as well, but it still prints “ok” (could still use some tuning).

In general my lulzbot needs some maintenance - I have over 53 days of print time without doing any major maintenance on it so I’m going to run through the maintenance documentation and do that. I also ordered a new .5 nozzle along with the z brake board.

That part was removed because I mounted my octoprint pi to the side of the case - the screws go into the same holes as the rogue bracket I found. Surprised I still have it around years later!