Lulzbot Mini Gen 1 Stalling with Print


I have reached out to Lulzbot about this issue and I can’t seem to find a fix. I have tried Cura for Lulzbot edition 3.6.20, 3.6.21, and the newest version and I’m having the same issue every single time.

Also, I have replaced the heater cartridge as per Lulzbot’s recommendation. It did nothing. Whenever I hit “print” the printer will say “printing” but nothing will actually occur. It will heat up to some arbitrary number, slightly below the print temperature, and never execute the print. I can get the printer to heat to any degree I want if I set the temperature myself, and to extrude filament, but as soon as I execute a print, it does nothing.

I see others having various issues with this, and I really need help. The firmware is also up to date, and I’ve tried clearing the cache and it works occasionally (for maybe one print), and then goes right back to the issue once again.

Thank you so much…

To clear up a few things… this almost certainly has nothing to do with your computer or Cura.

The reason the printer says “Printing…” is because at the start of the job there’s g-code in the print job that sets that message (M117 is the gcode for ‘Set LCD message’). You can make it say anything.

There are other g-codes – such as M109 and M190 – which tell the printer to wait until a temperature is reached. It will not continue to process g-codes until that condition is true. M109 waits for the hot-end temperature to be reached. M190 waits until the bed temperature is reached.

Go into the “Monitor” panel in Cura LulzBot Edition and check the requested hot-end and build-plate temperature… vs. the actual temperature to see if it is actually reaching the desired temperature.

Thank you for your response! The GCodes appear to match the desired temperature. It seems to only go to the first M109 temperature and M190 temp (when it is preparing to print), and then doesnt reach the second set of temperatures to initiate the print despite them being correct. Is there anything else I can do? Thank you again.

As the heaters and extruder are working fine I suspect something Cura. I have had issues with Cura also off and on. I recommend doing a print with printrun / pronterface. You can slice a small test print using Cura and load the g-code into printrun. If that works, Cura is your problem.

Cura just generates the g-codes.

M104 sets the hot-end temperature but the printer is allowed to keep processing commands (it does not have to wait until the hot-end reaches that temperature). M109 says it has to wait until the temperature is reached before it can go any further.

Similarly there is M140 and M190 for the bed temperature. M140 sets the temp. M190 tells it to “wait” for the bed temp.

Typically the printer gets an M104 and M109 to start things warming up, then does an M140 to “wait” for the printer to reach “softening” temperature so that it’s safe to retract a bit of filament (it wouldn’t be safe to assume it has reached softening temp just because the M104 was issued). At that point it retracts a little filament, then issues an M109 to drop to the “wiping” temp, then another M109 to drop to the “probe” temp (and meanwhile the bed is still heating up with that M109 command).

After the probe temp is reached, it’ll do a bed level.

After the bed level is completed it’ll issue another M140 to raise the hot-end temp to the printing temperature and will issue an M190 to reach the bed temp … all before laying down the filament at the start of the print.

The print head may go to a start position and re-prime the filament and sometimes there’s an M400 code which tells the printer to wait for the re-prime to complete and any other moves to complete before going any farther.

The Marlin G-codes are documented here:

You can look up codes if you want to know what they do. Generally the “G” codes execute moves (G is thought of as a “GO” command). But these are temporal codes in that once they’ve been executed there is no memory of the fact that they were ever done. The “M” codes are modal in that whatever they change sticks … until it’s changed again. That’s why temperature changes are done with “M” codes. With that said… there are some oddball exceptions. For example you can put the machine in “absolute” or “relative” position mode. In “absolute” mode, Telling the printer to do a G0 X10 would move the X-axis to 10 “units” (usually millimeters) from the 0-position (typically the end-stop). But in “relative” mode that would just move the printer +10 units from wherever it is now. So you’d think that would be a “modal” change because once you change the mode, all subsequent commands are interpreted in that mode (the printer “remembers” what mode it is in). The same is true of the units… you can set it to work in millimeters or inches and that’s done with a “G” code even though it’s really a modal change.

But most g-codes live in the moment… once the command is processed there is nothing that “sticks” (no modes were changed). And most “M” commands are modal changes (but an argument could be made that some are not).

The semi-colon ; is a comment delimiter… anything after a semicolon is ignored until the end of the line.

Other things to consider is whether the thermistor is working.

The heat-block on your hot-end has a heater cartridge (which you replaced) and a thermistor. A thermistor is a “thermal resistor” – a resistor which changes based on temperature and this is how the printer determines the heat-block temperature. If the thermistor isn’t working properly, the hot-end could be well-beyond the desired temperature but the control board wouldn’t know it.

I’ve only ever had one thermistor fail… when that happened I noticed that if I watched the LCD panel while the printer heats up, the temperature would jump around a bit … instead of progressively getting warmer as you would expect. Also, once it reported reaching the intended temperature, I noticed the print quality was poor… as if I set a temperature much too high (because it was too high … the thermistor wasn’t reporting the correct temp). Watch your LCD display as the printer heats up. You should see it progressively getting warmer with a roughly linear increase in temperature over time. If it jumps around or seems to pause and then jump temperature changes in clumps… then your thermistor may need to be replaced (it’s a cheap part and easily swapped.)

I had a similar sounding problem with my mini. After much time and expense, it turned out to be broken bed heater wire. It was intermittently making and breaking contact.
Simple check, open the electronics housing, pull the bed heater connector from the RamBo and check continuity while moving the bed in and out.

Thanks everyone. It is still having major issues. I got two prints out of it yesterday by lowering the bed plate temperature. So now, it will print occasionally if I change up the temperature. Today, it seems like something with the hot bed is stuck. The thermistor on the nozzle works, when I took apart and replaced the heater cartridge and I resoldered the thermistor. If I manually request the printer to do a temperature, it has no problem getting there but it does seem to stall a bit with reading the bed plate temperature. I assume there is a second thermistor there? I have not taken apart the bed plate yet. It’s doing the same issue as before, only with initializing prints. However, now, I might have an issue now with the bed plate. I’ll update later once I have a change to take the bed plate apart. I am having issues finding more diagram information on Lulzbot about looking at the wiring connected to the bed plate. I think there is something with the tension on the belt now on top of everything else, but I can’t find a diagram to troubleshoot it. I think @lrd might be spot on that there is an issue with the bed heater connector. But again, will keep everyone updated. Thank you all for your assistance, I only sporadically hear from Lulzbot and I’ve been unable to print PPE components regularly for 2 weeks now. I appreciate the timeliness of the replies as well.