LulzBot Mini Quality Advice

My family purchased a LulzBot Mini last night. It’s our first 3D printer, and so far I’m very pleased with it, but being relatively new to 3D printing, I was hoping someone could advise me with regards to some of the results I’m getting. I looked through the pictorial troubleshooting guide, but am still not certain which suggestions apply to me.

The Rocktapus printed with the included HIPS flawlessly. When it was complete, I switched to eSUN PLA with “for LulzBot” stickers on it. I then tried printing a few objects from Thingiverse. The primary issue I’m seeing is extremely rough top-side on some objects. In the below images you can see a pony charm that I printed for my daughter and an octopus attacking the Space Needle. In both cases, the top-facing flat surfaces and extremely rough. During the prints you could see the print head shaking as if moved across previous layers that were bumpy. It essential ruins the detail in the charm, and makes the water section of the octopus model look terrible. I understand that 3D printed objects tend to need finishing, but this is far rougher than Items I’ve seen roll off the printer at other locations and with other units.

Lastly, I printed a name plate. While the top-facing surface of the name-plate is fine, the rear surface it splitting at the individual line level. I’m assuming this is because the model had a bevel on the read and was printed with that side down. Would adding supports help? Other suggestions?

Note that I’m using the included Cura LulzBot Edition software in beginner mode. Aside from the pony charm (which I printed in “High Detail” mode), all objects were printed in “Standard” mode. I assume Cura sets proper temps for the PLA in beginner mode, but if I need to tweak those settings for a more reliable finish, please advise. Likewise, if there is a superior software that will make it easier for the family to produce reliable results, I’m open to that as well. The printer is mainly to be used as an educational tool, and for fun, so exact measurement accuracy isn’t critical, just reasonable looking result.

As always, forgive my relative ignorance, and thank you very much for taking the time to read this post.




In the first pic, you have sagging lines due to bridging. Try to avoid bridging as long as you have not gained some experience and your printer is well calibrated. In this later step, you might also think about changing from cura to another slicer, cura is quite bad if it comes to bridging…

The other two pics may have on or even two problems:
.) The distance of your nozzle to the print bed might be too close, which may influece your top layers on this thin parts.
.) And / or you have havy over-extrusion.

To know witch one is your problem, print a test cube or something simmilar with at least 10mm height and make a picture of the top surface and also from the sides. If your cube has a nice top surface, but you get an “elephant-food” (squished layers at the bottom), your nozzle is too close to the print bed. If your bottom layers are nice, but your top surface is very rough, you are over extruding. Or you might have both…

Thanks for your insight Sebastian. I’m on the road at the moment, but when I get back in tonight, I’ll generate the cube as you suggest and see what happens. Since the Mini auto-calibrates, I’m not sure what’s to be done about being too close to the print bed. For the possibility of over-extrusion, I’m assuming a temperature change is the order of the day?

If you are over extruding, you probably need to measure your filament diameter and enter that value in the slicing software. That is the most likely culprit on a new Mini. I believe you need to switch to expert settings in Cura to adjust the filament diameter.

As the auto-calibration is not done on the print bed itself, you only get a reference plane, and it is assumed to be the same as the print bed plane. Because of tolerances, this might not be true fore every printer. Read this thread for further information: https://forum.lulzbot.com/t/material-squeezing-out-bottom-of-part/2550/1
Short version: There is a z-offset option in every slicer, where you can compensate for such issues.

You should measure your filament diameter on multiple spots with a caliper and enter this value in cura. As stated by nopick, this might only be possible in the “expert” mode. The second important value is the value for esteps (how many step the extruder has to do to extrude 1mm of filament). You can set this value over the printer interface of cura.
See this howto regarding esteps calibration: http://reprap.org/wiki/Triffid_Hunter’s_Calibration_Guide#Measure
Use the command “M92 E820” to set the esteps to 820 or any other value you need. Don’t forget to do a “M500” when you are done, or your printer will forget your calibrated esteps value when you switch it off! You might also do a M503 to display you current values.

The esteps “should” be good to go on a new printer from Lulzbot. Check your filament diameter before you mess with esteps. :smiley:

Filament diameter is only available in expert mode. Click the Expert menu, click Switch to Full Settings and click yes on the profile copy dialog box to move your current quick print selection into full settings mode. Filament settings will be at the bottom of the basic tab in expert mode.

I am with nopick, leave things alone if it is working with one filament and not with another its not your esteps and Cura was designed for the TAZ printers so don’t go off looking for the magic fix. The Mini works just fine with the Basic settings, perhaps measuring the filament would be in order. I would contact Tech Support with your questions and photos they might have an easy fix.

The automatic leveling works fine on the Mini don’t mess with any settings until you make that phone call to Tech support. You do need to make sure the nozzle is wiped clean on the pad, and I always pre-cleaned mine with a scotchbrite pad after the nozzle was heated up and primed.

It does take time and practice to get the 3D printing skill learned, a few months from now you will be the one answering questions. :smiley:

PS FYI a lot of Things on ThingVerse do not print correctly. Some of the problem, you have 3D designers who have never used a 3D printer and they are clueless.

Firstly, I want to thank everyone for their insight, advice, and words of encouragement. It’s much appreciated. Here’s a quick update. As suggested, a unspooled a couple feet of filament and measure it. While we did hit 3mm in some spots, it was a pretty consistent variant between 2.80mm and 2.90mm. So perhaps that’s the issue. Before I began fiddling with anything though, I wanted to run the test cube as recommended by Sabastian. I grabbed a 20mm test cube off thingiverse and printed it while I tended to some other matters around the house. Unfortunately, this cube was designed hollow and didn’t print with a fill. This means the top was bridging, and is unsuitable for the intended test, but I snapped pictures anyway so you might judge the lower layers.

As you can see, the lower layers do extend slightly beyond the walls. It’s noticeable to the touch as well as the eye, though it’s may not show up as well in the photos. Ironically, the top looks a bit nicer this time around, though you can still see the light gouging where the extruder tip cut across layers.

I’m printing a secondary test cube now, and will post back when it’s complete.






And here’s the second cube with the default fill (20% I believe). It actually printed out very similar on the top. But the bottom layers don’t extend beyond the walls much at all this time around. So, with the variance I’m seeing in the filament, should I put in a 2.85 average, or switch to a different spool (I have one I haven’t opened yet, though it’s the same brand)? I ordered some eSUN HIPS material from LulzBot last night, so hopefully it’s more consistent than this PLA. If anyone has recommendations for especially good material, I’m all ears.



Try setting filament diameter to 2.85mm, based on your measurements. Also lower first layer height and width. The defaults are over size to help with bed adhesion. I found that with ABS and HIPS, it wasn’t needed on my mini. I set them both to 100% and got better results and still had to adjust the Z offset as they stuck too well.

With nylon, I needed to remove the Z offset and use 110% first layer height. And coat the bed with a glue stick, just to keep the part on the bed.

I haven’t used PLA. But hopefully that gives you some things to try. I have read that PLA is supposed to be easier to work with then ABS but generally print with similar settings.

All of the esun I have used runs around 2.85. It I a good idea to only change one thing at a time. Adjust the filament diameter and print the test piece. You will probably find that fixes 95% of the problem.

It looks like it’s been printing at 2.85mm diameter this whole time. When I switched to “Full” view earlier to check the settings, it had already defaulted to 2.85mm. So presumably that isn’t the issue.

If it’s not the diameter, check your esteps. It’s true, your Mini should come calibrated, but they can also do mistakes. Mine came with around 850 steps/mm, I had to take it down to 801…
At last, your pictures look like you are overextruding a little bit. You also have a little squish at the first layers as expected. Best method for this is to measure the height of a single layer loop with a caliper. You can also use the prime perimeter that is printed before the real part for this. Compare your 1st layer height setting in cura to your measured value. If it’s off by more than 0.02mm, adjust your z offset in Machine->Machine settings.

The OP stated The Rocktapus printed with the included HIPS flawlessly

Why would you have him change the esteps (a semi- permanent change to the firmware ) if it worked fine before he changed filament? When troubleshooting an issue you make one change at a time and if that does not work, put that change back where it was and go on to the next adjustment.

Since the filament diameter is correct, I would reduce the extrusion multiplier in your slicer 3 or 4 percent and give it another shot. It just looks like you are over extruding a little. PLA is a different beast. It expands a little when it is heated so, reducing the flow of plastic might be necessary.

And he can easily make that change in the Cura software and adjust as needed.

Thanks for the suggestions. I’m in the middle of a print, and have family holiday stuff going this afternoon, but will try these steps as advised and see what happens. Theoretically my HIPS filament should be in tomorrow, so I may wait and see how that performs before making any major changes.

I also had the same issues as you when I first started printing. I received a ton of excellent suggestions from Lulzbot tech support, but nothing really seemed to correct the problem I was seeing with the topmost horizontal plane.

I have a roll of blue PLA from Lulzbot, ESUN, Batch No: 2015-10-29-1
I have measured it many times, and get 2.95mm every time.
I believe the default for PLA is 2.85mm, and changing that to 2.95 seemed to make a difference in my prints.
I also played around with the flow percent and found small changes seemed to have a decent effect. Like 98% or 99%.
I have a test rectangle that I print, and I have printed that dang thing numerous times, trying all sorts of changes.

Note: only make one change at a time
Note: keep a notebook with screenshots of your settings (I use MS word)
Note: switching back to the quickprint settings (expert>quickprint)will change back to HIPS, and you may miss that
Note: switching over to full settings (expert>full settings) I found that you DON’T want to allow it to copy the settings, especially if you’ve made changes that work.

I downloaded Lulzbot’s ini files from their website: https://www.lulzbot.com/mini-cura-profiles

Make changes, and save a copy as you make incremental changes so you can come back to something that worked.

I found that changing the initial layer thickness to 0.28 (was 0.425) makes a big difference in the elephant foot effect, as does the Initial layer line width (%) - I used 100% instead of 125% default.

It’s nice if you keep the ini file from Lulzbot unchanged, and then compare with your changes side-by-side. I open the ini files with wordpad (right-click>open with… from windows explorer).

After making changes, I had a lot of trouble with it not printing much of a skirt, if any. Sometimes it would be one or two rounds into the main print before it started laying down anything. This seems to be related to the initial layer thickness. The manual says 0.0 is equal to the other layers <-- This is NOT true from what I’ve found. 0.0 makes the nozzle drag on the PEI, or 0.0mm, i.e., no thickness!

Lulzbot support suggested I try Cura v18, but I can’t get it to run on my PC for some reason.

Have fun with your new machine, and spend a lot of time making adjustments to simple to print items. That will build your confidence and quality as you apply those settings to larger prints. I’ve had successes and failures. Luckily filament is about 25 cents a meter, so all you lose is time if it screws up.

Pay close attention to the auto-leveling! If it presses down and moves the bed, it will not print right, and may ruin your PEI bed! I do a power switch abort, then restart it all over again. Use Home-Z to pull the nozzle away from your part after you re-power the mini.

I hope this helps a little.

I also keep various copies of my configuration files.

You should try Notepad++ for your comparisons. It has a fantastic comparison plug in that highlights changed, missing and new rows.

Awesome! Thanks nopick!
I had to download the plugin for compare, but that was pretty easy. It took me about 5 minutes to figure out how to put the docs side by side, but now that I know how, I really like it!
I appreciate it! :ugeek: