Lulzbot Mini Wipe Setting

Hello all.

I’ve been creeping for a while, and decided to make an account in hopes of seeking some help.

I’ve owned my Mini for about 2-3 months now and it’s absolutely amazing. However, I find that my mini cleans rather aggressively. The guiding rods and bed frame actually bend slightly when it cleans. Lately I’ve been printing single objects (many times over) to avoid stringing from object to object when the printer goes through each layer. And I find I’m doing far more wiping cycles then I need to be. I fear I’m putting more stress on the printer than it needs. I always preheat my printer and manually clean the printhead anyways.

So my question is: Has anyone modified their gcode to skip this step entirely? I don’t mind the auto levelling phase, I found that thread. I just want to get rid of the wipe phase. I am new to gcode and how it works. It seems fairly easy to read and the steps in the code are straightforward. Now, I’m not saying coding it is, merely saying I can just read haha. I thought about just removing the wiping section, but wasn’t sure if that would just corrupt everything.

Anyways, really new to gcode, would love to see if anyone has figured this out and would really appreciate any and all help in the matter. Thanks in advance!

Edit:
Video of a clean cycle. This cycle isn’t as bad as some others I’ve had.
https://youtu.be/STtYHV57twI

T

If you prefer manually cleaning, there’s no reason you can’t eliminate the wiping movements from the start gcode.

Alternately, if it is pushing down too hard on the wiper pad during cleaning, just change the z coordinate in the start gcode. And looking at your video, it is pushing down too hard. Across different firmware versions and different sub-models of the mini, the correct height for the wiper does vary by 1-2mm, but it’s easy to change in the start script. Just look for the Z values, and add 0.5 or 1.00 to them - then run another print and monitor the new wipe sequence.

Thank you ScottW. I wasn’t entirely sure if that was valid and was too worried I’d corrupt the whole code. Would I have to rename the other stages? Like, rename the G stages for the other operations if I do remove the cleaning ones?

Thanks once again, really appreciate the help!

You would just need to comment out (using semi-colon at start of line) or delete the lines which perform the wipe. Then always standby with a folded paper towel or green “no scratch” kitchen scotchbrite pad to manually clean the nozzle as it heads down towards the bed. The remaining (non-wipe) code would stay the same.

I don’t know which version of Cura and Firmware you are using, and the start gcode differs a bit between versions. But here’s an example of a Mini start script (taken from Cura 2.6.67) with the “wiping” code removed that should give you the idea:

;This G-Code has been generated specifically for the LulzBot Mini with standard extruder
G26 ; clear potential 'probe fail' condition
G21 ; set units to Millimeters
M107 ; disable fans
G90 ; absolute positioning
M82 ; set extruder to absolute mode
G92 E0 ; set extruder position to 0
M140 S{material_bed_temperature} ; start bed heating up
G28 ; home all axes
G0 X0 Y187 Z156 F200 ; move away from endstops
M109 R{material_soften_temperature} ;  soften material for retraction
G1 E-30 F75 ; retract filament
M109 R{material_wipe_temperature} ; wait for extruder to reach wiping temp
G1 Z20 ; move towards bed  (*** MANUALLY CLEAN NOZZLE ON THE WAY DOWN!! ***)
M109 R{material_probe_temperature} ; wait for extruder to reach probe temp
M204 S300 ; set probing acceleration
G29 ; start auto-leveling sequence
M204 S2000 ; restore standard acceleration
G28 X0 Y0 ; re-home to account for build variance of earlier mini builds
G0 X0 Y187 F200 ; move away from endstops
G0 Y152 F4000 ; move in front of wiper pad
G4 S1 ; pause
M400 ; wait for moves to finish
M117 Heating... ; progress indicator message on LCD
M109 R{material_print_temperature} ; wait for extruder to reach printing temp
M190 S{material_bed_temperature_layer_0} ; wait for bed to reach printing temp
G1 Z2 E0 F75 ; prime tiny bit of filament into the nozzle
M117 Mini Printing... ; progress indicator message on LCD

Alternately, if you want to keep the wiping but make it not press down as hard – you can just change the Z coordinates in the lines that do the wiping. Again, using the code from Cura 2.6.67, here are the lines that need to be changed:

...
G1 Z0 F1200 ; push nozzle into wiper
G1 X42 Y173 Z-.5 F4000             ; wiping
G1 X52 Y171 Z-.5 F4000             ; wiping
G1 X42 Y173 Z0 F4000               ; wiping
...
G1 X112 Y171 Z-0.5 F1000           ; wiping

For example, to make those 1mm higher so it doesn’t press so far into the wiper, just add 1 to the Z coordinate value in each of those lines (0 becomes 1, -0.5 becomes 0.5) – like this:

...
G1 Z1 F1200 ; push nozzle into wiper
G1 X42 Y173 Z0.5 F4000             ; wiping
G1 X52 Y171 Z0.5 F4000             ; wiping
G1 X42 Y173 Z1 F4000               ; wiping
...
G1 X112 Y171 Z0.5 F1000           ; wiping

Adjust another 0.5 up/down as needed after you run a test.

Hope that helps.

One other thought here… Does the print profile you are using have Retraction enabled? That can make a huge difference in stringing between parts (or islands within the same part). That might be able to get you back to printing multiple objects and reduce the need for individual print cycles.

ScottW, this is absolutely amazing! Thank you very much for the very detailed explanations.

I always preheat my printer and wipe the nozzle with a scotchbrite pad, I find it to be very effective. Also the current version of Cura I’m using is V2.6.66. As far as firmware, I’m unsure, but I did do a check today and updated it. Before today’s update, the last time was maybe 5 days or a week ago.

Modifying the gcode definitely seems to be the route I’ll have to take. I’ve been getting some funky prints lately, (if you’re looking at the front of the printer) the south west corner always seems to have uneven walls whenever I print something with a curve in it. So at the moment I’m trying to get that resolved with tech support. I was told changing the gcode will void my warranty so I’m just waiting to fix that before adding (or removing rather) this gem you have provided me. I’m unsure if they will get the wipe function fixed for me or not, but we’ll see. I honestly can’t wait, it pains me to watch a wipe cycle.

I also seemed to have found a glitch or just timed things horribly. I had to cancel a print just as it started. Unfortunately I hit cancel when the nozzle was coming down for a wipe. It seems it takes the PC a few moments to send commands through to the Mini. The command went through as the mini was half way done the wipe cycle. It paused, then commenced on traveling to the right, it seemed as though it was trying to travel past the wipe pad holder/guard. Well, the nozzle rammed right into that holder. It started to make some loud click sounds so I manually shut it down. Im guessing the gear was jumping the belt? All the teeth seem to be fine. All that seems to have been damaged was the pad holder, it obviously melted. But I don’t care for it much so that’s fine. Seems the timing for canceling a print was rather poor on my end.

Cant wait to fix/remove this wipe feature. I love this printer so it pains me to see these things happen. Sadly I can’t stop printing since I have deadlines to meet.

I’m experiencing the same issue. According to the release notes, they changed the wiping height in 2.6.66.

I have installed the areosturder head on my mini and it seams to be plunging the print head a little to deep in the wiper. i am trying to figure out how to change the depth settings. i understand the following code does that.
G1 X42 Y173 Z0.5 F4000 ; wiping
G1 X52 Y171 Z0.5 F4000 ; wiping
G1 X42 Y173 Z1 F4000 ; wiping

G1 X112 Y171 Z0.5 F1000 ; wiping

but i’m not sure what to actually enter. for example i know if i type M851 into the console it gives me
back echo:Z offset : -1.18
then i put in M851 Z-1.19 enter
then M500 to save the setting for example.
and if i type M851 again i will get the echo:Z Offset : -1.19 showing it has set.

first is there a code so i can see what my current wiper setting are and then what is the steps for changing it.

Thanks for any help
Steve

@smchecter:

There is no firmware command similar to z-offset to specify the Z location of the wiper pad. The G1 commands in the startup script have the wiper location statically coded. For example, the first three wiping commands you listed were:
G1 X42 Y173 Z0.5 F4000 ; wiping
G1 X52 Y171 Z0.5 F4000 ; wiping
G1 X42 Y173 Z1 F4000 ; wiping

Just increase the Z values as desired in those commands (and all the other “wiping” commands). For example, using “Z1.5” and “Z2” would make the wiping occur 1mm higher than it does with them at “Z0.5” and “Z1”.

That will take care of the wiping done directly via the startup script. However, bear in mind there is also a “re-wipe” routine in the firmware itself, and the location values (x, y and z) for that re-wipe can only be changed by editing the firmware source and rebuilding it. So while you can control the initial wipe locations by editing the startup script, when/if there is a wipe failure (i.e., dirty nozzle) then the firmware’s hard-coded internal values will still be used for the “rewipe” process.

Thank you Scott that help