Lulzbot Taz 6 with SL 0.25mm head working with OctoPi


I just purchased and set up my new tool head and completed my first successful print! I had OctoPi setup with my printer when I had the single extruder v2.1 setup and it worked perfectly. I tried to connect OctoPi with the new tool head and the printer gave a kill command and octopi gave an error saying “Your printer’s firmware reported an error. Due to that OctoPrint will disconnect. Reported error: Printer halted. kill() called!” Any help would be greatly appreciated!

I think you need to give more details (i.e. step by step) on how you got to this error. Is it repeatable?

I have a TAZ 6 with multiple tool heads connected to OctoPi / OctoPrint and I can switch between them including the required firmware flashing without any problems. I do get the occasional error from the firmware switching from a dual extruder to a single extruder if I do the tool head switch before flashing the firmware but these errors are my fault and easily corrected.