Taz6 and Octoprint issues - Printed Halted, Kill Called

I am having issues connecting my Taz 6 printers to my Octoprint. I am running RPI 3+ on 4 Taz 6 machines. 3 of them will never connect. Every time I attempt to connect my printer to the PI within about 5 seconds I get an error “Printer Halted, Kill Called” and in Octoprint I get a popup that says your printer’s firmware returned an error. The 4th machine will connect and allow printing about 1 in 4 attempts. But usually gives me the same error. I have updated all firmware on my machines, several times. Octoprint I believe is up to date and I have tried connects with baudrate set to Auto and 250000. Anyone have any ideas?

Is this one single Pi 3B+ controlling all four printers – or is this one Pi per printer?

If it is all four, what happens if you disconnect three and just try to drive one printer?

What sort of USB cables are you using and how long are they?

Hey Tim,

I have a separate PI for each printer.

Jon Carlisle


Have you tried moving the working RPi with cable to a printer that isn’t working? This can help isolate whether its a communication issue between the Octoprint and the printer. If it does help, then try the original USB cable.

I don’t own a TAZ 6 (I have a Workhorse & Pro). Technically my Workhorse uses a RAMBo v1.4 board. Your TAZ 6 probably came with a RAMBo v1.3 board (although the v1.4 is a direct replacement). So I don’t know if the board could play any role here. I doubt it is an issue, but thought I’d mention it since my printers have been solid (no connection issues to the Raspberry Pi).

Is the connection from the Pi to the printer just one single simple cable (there isn’t a USB hub in the mix?) I’ve found some hubs (actually I’ve found many hubs) create problems. Mot hubs seem to be garbage and very few have been solid for me. I doubt you’d be using a hub… but I thought I’d ask “just in case”. If you are using a hub… get rid of it.

I am also wondering about the USB cable. Is it a particularly long cable (could it be delivering poor signal quality … or long enough that it’s absorbing interference?)

Each of my cables isn’t particularly long and they each have a magnetic ferrite on each end (the bulky black “collar” clamped around the cable near each end). Although it was my understanding that a ferrite collar was more about the cable not emitting RFI than absorbing it (but maybe I’m wrong). In any case, I have no communications issues with my printers.

I don’t know if any of this is helpful… but these are the things I’d try.