M175 tool head firmware issue and z axis leveling

I’ve recently bought an M175 tool head for my Mini2 and it was kind f rough to get it going so I figured I’d share some info. After installation and updating the firmware make sure you select the tool head on the printer monitor. If you don’t the probe will invariably miss the washers during bed leveling. Also if you level the X-Axis from the cura command the nozzle will crash into the print bed. The work around is to level the axis (Called z leveling in Marlin V2.0.6.7) using the printer monitor which worked well.

All my octopusRev06 @ 75% test prints came out awful. The first couple layers were fine, then the nozzle seemed to be dragging into the layers. Tool head travel seemed to accelerate quite a bit while printing the tentacle. I couldn’t figure out if it was the jerk or a z axis leveling issue. However above a certain height the print quality was relatively fine.

Turns out it is a firmware bug. Lulzbot support told me to load the prior marlin version which not only solve the printing problem, it also solved an X axis leveling issue I was having since buying the Mini2, leveling basically was unreliable and I had to constantly adjust the Z offset.

To roll back your firmware, in cura go to “manage printer”, then “update firmware”. Not sure where to find the previous firmware download on Lulzbot, customer support sent me a file called lulzbot_hibiscus_lutefisk.hex

Here is the latest M175v1 firmware cura/resources/firmware/Marlin_Mini2_M175_2. · master · LulzBot 3D / Cura-LE / Cura Binary Data · GitLab . We have identified an issue with the original M175 (v1) in firmware versions 2.0.0.X+ which lead to a new M175 revision (v2) which changes some of the printable parts on the tool head. The M175v2 parts are here v2-0 · master · LulzBot 3D / Tool Heads / Lutefisk · GitLab