Many print issues with moarstruder

Hi all,

I used the moarstruder printing a prototype for an IPhone mounted scanning device and the result and speed was very good with clean prints.

Yesterday we printed a much bigger prototype for a client project and were quite shocked by the print issues.

We two days ago did many vase prints all with success with perfect surfaces which makes me not think that this is an alignment issue.

I used the default print settings with lultzbot cura.

We noticed that there were
1 layer misalignments
2 massive gabs between print layer start and end
3 Print lines not sticking to lower level or floating in space where in the cad model nothing should be printed
4 overall vertical layer quality ranging from smooth to rough which is not good and exceeds acceptable variations

Layer misalignment: ignore Elefant foot but notice the layer jiggle - the edges are straight vertical !

Star end gabs: plus pay attention to the overlay vertical layer quality - so many issues

Layers not sticking or printing where nothing is in the model - corners are convex round with an edge fillet:

We also tried to print a flat sheet vertical and stoped it after seeing the edges being a disaster:

Any insight would be great to hear what could have caused this.
The prints are borderline non usable for representation.

Could you post the base models you are having issues with in .stl format? More often than not if something occurs consistently on the same model but the printer works okay otherwise it means that there is an issue with the base model that is causing Cura to have difficulty slicing it.

Hey Galadriel

Attached are two STL files.

Look specifically at the flap file.

Printing horizontal is fine - printing vertical is shockingly bad with the side edges exhibiting an insane amount of misalignment.
I don’t think my STL files are the issue it printed fine on a much cheaper printer afterwards but I am curious if Cura slicer here makes the mistake. (613 KB)

Here are images of the iPhone mounted scanner holder where the moarstruder worked fast and well.

The usual start end issue is I’m imally present but as you can see the rest is printed very well!
Good vertical walls
Clean rounded corners
Correct wall thickness and vertical ends

I looked over the Flap model that you attached and it had quite a lot of errors that were most likely the source of your difficulty, it had something over 9000 errors in the original model entirely around the edges where your problems were manifesting. I did my best to repair it, I got it down to like 160 errors and when I got it loaded up into Cura it seemed to slice okay. When I loaded the model into Cura it was tiny though, so small it didn’t want to slice until I enlarged the model. This may be an issue with the software you were exporting from and the one I imported into having different ways of calculating unit of measurements. I wasn’t sure how large the model was intended to be originally so I just left it as is, you will need to resize it once you load the model it into Cura to suit your needs.(Sorry about that!)
I am attaching the repaired model that you can try.
Flap (Repair).stl (14.7 KB)

My Moarstruder is my favourite toolhead… I use it for most things I make… at a .2mm print height is melts everything together and makes a seriously tough product.
need any help with a re-draw i’d be happy to do it - like Galadriel mentioned - a length and width in mm would let someone get it right.

The model was designed in Fusion 360 from Autodesk.
The same model printed flawless on other 3D printers.

We did another MOARstruder test today

the vase mode worked well besides a single x/y shift issue.

printing a 2.4 mm shelled model resulted into pathetic surfaces again.

This was modeled with Blender 3D and shows very basic geometry.

At this point I am starting to blame this either onto the Cura version used slicing badly or the refurbished Taz 6 and moarstruder print head.

Some print quality issues based on the nozzle size can be expected but this is beyond ok.

If somebody has a tip I would love to hear about how to fix this. (4.72 KB)

Since you have the same printer head I would be curious about to see if you could print the model and show me your result if you dont mind.

I am close to give up on the moarstruder.

I attached the file here (4.72 KB)

I did an update (cura) and flashed the Taz 6.

But the print issues mainly remain.

Also the print issues between the shells on the left are the same while both are done with two different Cura versions.

The image on the right shows much better results when using the standard layer thickness setting.

less blobs holes and such

It seems like the print quality issues you are seeing may be related to the Z-Seam, the Z-Seam is essentially where each layer starts and ends. This start/end point can cause a slight visible mark particularly if they all coalesce in one area. I would try checking to see what your Z-Seam is set to currently and try setting it to Random if it isn’t already, your Z-Seam setting is found in the Shell drop down menu found by switching from Recommended to Custom. Adjusting Combing to off might also help with this, Combing can be found in your Travel settings.

Also it looks like your first layer is printing too close to the build platform, the can happen if your autoleveling is not completing properly. Your printers automatic bed leveling procedure is done by electrical contact. The most common way this will fail is due to a dirty nozzle that prevents this contact until the filament is “pushed” to the sides and electrical contact is made. This will cause your printer to think the bed is lower than it actually is, and can create a lower than intended initial layer. Please ensure your wiper pad is clean, and that you do not have any filament accumulated on the nozzle or corner washers. If you do see a deflection during the probing sequence, please turn off the printer and restart the print.

If you don’t see a deflection your first layer you can adjust the z-offset for you printer. The z-offset is the distance from the top of the leveling washer to the top of the PEI print surface and affects how tall your first layer is.
This can be done through the LCD menu by clicking the LCD knob in once to bring up the main menu then navigating to:

Configuration --> Advanced Settings --> Z-Offset

Then, you can make your first layer more squished by turning the knob counter-clockwise. You can make your first layer less squished by turning the knob clockwise.
Once you have found a good setting for the z-offset, make sure to back up a screen and Store Settings.
The typical z-offset is a number somewhere close to -1.35mm. If you change the z-offset from -1.35 mm to -1.45mm this will make your first layer more squished. If you change the z-offset from -1.35 to -1.25 this will make your first layer less squished.

My z-offset is at -1.2 but I can play with this setting more.

I remove before doing a new print any filament leftover.

We have another moarstruder at work and I will test the model there today to see if it is the model or the printer I bought refurbished.

Any other suggestion? Estep?

I would start with those adjustments and see how things go before jumping into looking for other potential causes. In answer to your question I don’t think this will relate to your E-Steps because your E-Steps control the overall extrusion of the toolhead and if this was off I would expect to see poor surface quality across the board not just on specific areas of prints. I will keep an eye out for updates once you have tried out a different MOARStruder!

Here some more tests with Z-seam alignment

Fast print:


From all modes best still exhibiting a lot flaws such as lines not building upon each other correctly.


this is probably the worst print ever with even thick gabs and some of the hexagon like vertical corners are rounded

one can also see that from the front the lines are aligned but on the opposite side the lines are off like along the y axis there is an increasing offset


pretty bad result

This is a standard print speed

issues are present such as horizontal lines
it seems the printer still has trouble with printing each layer correctly where it should showing some small horizontal stepping issues - also here start end artifacts are still present

for the vase mode also CURA shows a layer issue that is visible in the prints too

I attached the raw cad files too (52.3 KB)