blobby prints on TAZ6

We workplace has a TAZ6 for general use, and it apparently prints OK for most people, but I’ve been getting blobs on my prints.

I observed the printer printing a blobby print and the printhead would pause for a second and then keep moving. Extrusion continued during the pause and that would lead to a blob. In fact, the print looks as if the material that was supposed to be spread along a layer of the print got stuck together into the blob and a gap was left where that material was supposed to go. Another observation is that the bottom part of the print, which has a very shallow curve, is totally blob-free. I’ve had this blob problem with various different tweaks of this model. I also saw another person who printed little trophies suffer from the same problem. I tried changing the circular parts at the top to hexagons and the blobs decreased, but did not entirely go away.

Since it seems like this problem has to do with the pattern of print head movement it seems like it’s a control problem or a problem with my model rather than a problem with the filament or the environment, or other types of settings. But the particular print below was done using Cura, and the settings were all default except that I changed the support percentage to 10% and turned on the raft.

Does anybody have any thoughts? My model is in openscad, and I could post that or I could post the stl here if appropriate.

Go ahead and post the .scad and .stl files.

How is the .gcode being delivered to the printer? Are you printing from the SD card? If you are printing via USB, what type of system is attached to the printer? What type of filament?

If we can isolate and correct the pauses you are seeing, then I think the blobs will go away.

I’m printing using Verbatim PLA. Printing is done using Cura connected to the TAZ6 by USB with a computer running Windows 10. I’m told that the SD card slot in the printer never worked, so I presumably can’t try printing that way. The computer is a Dell Optiplex 9020. I haven’t been able to get on it today to check its exact stats (or Cura version), but it is most likely an i7-4790 with 8 GB RAM.

My OpenSCAD and STL files are attached. I had to rename the OpenSCAD file to .txt because .scad is not a recognized file type. Note that it takes about 12 minutes to run the preview of my OpenSCAD file on my computer, so it just hangs for a long time when I open the file. (This is due to the minkowski operation at the end. You can speed it up by putting ‘!’ in front of the reference to thing() in line 88 if you want a quick load to get an idea of the model.)
crok6.stl (4.01 MB)
crok6.scad.txt (2.23 KB)

I was having the same issues as you are. Made a few tweaks and had it working well but I am back to square one after switching back to ABS from PLA (I found the PLA was tougher to get to stick to the bed, feel free to tell me that’s crazy)

My old thread is below:

Also, a video of the stuttering that is occurring below:

I took a look at your video and the pause at 12 s is similar to what I’m observing. And I can see a blob form on your model at that pause.

Someone on your thread suggested changing the extrusion rate. What good is that going to do if the print head pauses? You get a smaller blob?

Did you notice any effect from changing to a faster computer? I checked CPU utilization during one of my prints and it was only 6% which doesn’t support the theory that it’s a lagging CPU.

I had problems with my PLA model not adhering to the bed and solved them by turning on the raft. But my model has a very small contact area (as you can see from the picture).

Quick update: printed through SD card, worked like an absolute charm

Going to try to print from a newer machine and I will circle back. But for now, SD card it is
My theory is that it’s not so much the computers resources but perhaps something happening with windows trying to autoupdate?

I’d recommend spending about $60 on a Raspberry Pi 3B or 3B+, power supply, and case. Connect the printer to the Pi and install OctoPi / OctoPrint. This will connect the printer to your LAN (either wireless or wired) and allow the printer to be controlled from a browser. The users will slice their parts on their own machines and then transfer the .gcode files over the network to be printed.

You don’t have to worry about is this attached desktop / laptop powerful enough to drive the printer without pauses and you don’t have to worry about doing other things on the attached desktop / laptop that might interfere with a successful print. You can also keep your desktop / laptop in your office and not have to hover around the printer (unless you want to).

This is how I have my TAZ 6 setup. There’s no monitor, keyboard, or mouse connected to the Pi and it sits quietly next to the printer taking up very little space.

Maybe I should see if the talk about the sdcard slot being broken is correct. Do you generate gcode with cura and then put it on the sdcard?

I’m not sure that I can get permission to connect a different computer to the company printer. The computer that is connected to the printer is a dedicated computer used only to run the printer. That doesn’t mean it’s not trying to do windows updates or something. But I checked during my latest print testing and CPU utilization during the print was about 2% with GPU utilization at 15%. This doesn’t make it seem like the computer is a choke point. Would there be any benefit of using something other than cura to send the gcode to the printer?

I did some test prints where I tried to print subsets of my original model to find a test case that would be faster to print. Of course, my initial print (center in the picture) came out perfect. It looks very smooth and beautiful. I then tried printing a different subset where the circles cross. That one is shown at the right. It prints perfectly up to about 7mm high, then the middle section is rough textured over all, with a few big blobs, and finally the top 6mm or so is smooth and perfect again. For my next test I printed the first model again. It is not quite as perfect as the first time. I turned on the brim, because I had experienced problems with the start of the print before. But this one shows a rough texture for the circular base part of the print, and is smooth thereafter, but not quite as smooth. There is rougher texture around the edges. Not sure what to make of that.

Why did my picture vanish?

The software being used for this forum has a nasty habit (i.e. bug) of removing all but one attachment when you preview / edit a post. It is annoying so I’ve just learned to put multiple attachments in multiple posts.

A dedicated computer is acceptable as long as its not ancient. Minimize other activities (like slicing or browsing the internet) while the printer is active. Windows Updates etc. are scheduled to happen in the middle of the night. If they interfere with overnight prints, just disable the network interface (or disconnect the cable) during those overnight runs.

While there are other applications that can send gcode and monitor the printer’s progress, CuraLE is probably just as good as any other one.

I wanted to chime in here and mention that when I opened the original file you were having difficulty with in Blender and looked it over for errors that could cause issues with slicing there was quite a few small errors that could coalesce into poor print quality due to slicing errors. Since you were able to print the one model successfully and another one came out looking rough my immediate thought is that this is probably due to issues with slicing. You can always try printing a good ol’ reliable rocktopus to see if these issues manifest on that print as well. Then you would know for certain that this wasn’t file related.
Rocktopus.stl (2.31 MB)

Weird bug. It also lied to me about which picture was removed, so I reposted the wrong one.

So here’s the missing picture:

The behavior definitely appears to be model dependent. Another guy who has been having this problem recently printed a model and it had a larger spherical part and two cylinders with a smaller radius. The large sphere had just a few blobs on it, whereas the cylinders were densely covered with blobs. On my model the very gently curved portion is blob free. Are the problems with my model something that is fixable? I wonder why OpenSCAD would produce output that wasn’t well formed.

I decided to investigate printing from the SD card, despite having been informed that the SD card reader didn’t work. It worked fine. And the prints I made came out clean and blob free. So it appears that printing this way may have solved the problem. The model has a linear artifact and some support issues, but those are not related to the blobbing problem. I will post pics of these results later.

Note that the computer is dedicated to this printer, so nothing else is going on during the prints.

Based on the various reports of similar behavior, all remedied by the use of either Octoprint or the SD card, I’d wager that there’s a buffering or overrun problem in the latest Cura software, something that only shows up when printing particular types or sequences of gcode. Perhaps if the good folks at Lulzbot could take a look at the various photos, and see if they can figure out what they have in common, and review the Cura source, that might resolve this issue.

Serial port weirdness was one reason (and a minor one, to be honest) that I reverted to the old Cura 21.08 for both my Mini and Taz 6… the old version works just fine for me, but I do realize that I should upgrade to a supported, current version at some point. It’d just be nice if that current supported version worked, too. :smiley:

I finally took the picture of my model. The blobs are gone. The finish is mostly smooth except for a mysterious vertical line in the print (that you can see) and some sagging due to inadequate support structures (which it’s not obvious how to fix unless I define the support structures directly myself).

What does it mean that the “board attachment quota has been reached”? Is that a personal limit for me or something about the whole forum?

Heyo, sorry about that! We have some limits on the attachments allowed to prevent our server getting filled up immediately. We went ahead and doubled user permissions, along with board quota. We will see how this change goes, and if issues are still popping up we will dig a little deeper into them.

Please let us know how it goes!

Ok, so here’s the picture showing the line artifact I mentioned, but otherwise looking pretty good. (No blobs.)

I think that you should be able to resolve the line issue by changing your “Z seam alignment” setting to random and for the support structure have you tried adjusting the angle of support? At an angle of 0 degrees all overhand will be supported on your model so that should resolve this, I have personally never had to adjust it past around 20 degrees to get good support.

Z seam alignment sounds promising.

For the support problem I haven’t tried really anything. I set the support to 10% and otherwise took all the Cura defaults. It looked like I got sagging at certain places because the support structure just wasn’t there. I was nervous about a dense support structure because I thought I might have trouble removing it from the narrow channel at the bottom (7mm wide). So I think the support structure I got was confined to the space underneath the model and just gapped at the areas where the cylinders meet, which lead to sagging extrusions there.

What does the “angle of support” setting do? Is that just what angle of overhang requires support? If so, that wouldn’t fix anything. I need to either change the type of support or increase the support density.