Mini 1.0.3 repair

I received a Mini for repair from our local library SN KT0035NA-05769. Never worked with a 3D printer before but have a lot of electronic design and debug experience. The Rambo board needed to be replaced after it stopped responding to USB commands. The printer came with a new v 1.3a board in a static protected bag. After much searching I found the documentation for a 1.0.3 that I needed to remove all the cables and get them back where they should be. I rang out all the limit switches and the thermistors and the connection to the nozzle and ground for Z min. After a couple of misplaced cables I got it working pretty well. I could not find any information on which Z motor driver connector goes with which Z motor. I assume it matters? I am using Cura 2.5.62 which loaded FW ver into the board. The auto leveling works but the first 20s or so of printing often doesn’t print anything. Is there a cal procedure I need to go through?

Heat the nozzle up to temperature and try to push filament through with your hand manually.

What temperature are you using? If the previous owner used a higher temp filament you could just not be heating it up enough to purge the previous material.

If you can extrude manually, check that the teeth aren’t grinding the filament down causing the filament to not feed. If it’s tensioned properly and not grinding, then the problem is likely the z-offset (the head is just too low to the bed and it obstructs the nozzle and the filament can’t come out).

Nozzle temp is 195C. Bed temp is 45C. Both PIDs controlling nicely. I looked at the Z measurement from the inside of the frame to the top of the front guide on each Z axis truck and there is about a 1/32" difference left to right (ie along the X axis). Is that important? Back to my question about which motor is Z0 and which is Z1 does the printer adjust for difference in height left to right. The material came with the machine is LulzBot green PLA and the board settings are in the attachment. All defaults as far as I can tell. There seems to be a bit too much plastic being extruded which sometimes gums up the part.

Yeah, different Z levels will affect the first layer. If the Z axis sides are off you can turn the couplers down by the steppers and then remeasure. It helped get things level on my Mini. The printer can adjust via the automatic bed leveling (not sure how much it can account for, probably not that much), but if you help it out and start with a level Z axis you’ll have much better results.

Too much filament could be due to bad ESTEPS, or could be due to the z-offset being too low (and blocking the nozzle).

You never said if you can push filament through by hand and get it to come out. Can you?

UPDATE: Guide for adjusting Z level on the Taz, but mostly applicable to the Mini.

I have no problem pushing filament through at 195C. I ran a single layer square pattern with a skirt. The skirt doesn’t print for the first go around then looks ok. The square looks ok to me but I don’t have an experienced eye. I was surprised to see the Z level measurement done to the top rail and not the bed.

It’s normal for the skirt to take a bit to start. The start gcode does a retraction before cleaning and it takes awhile to get it primed again.

It looks good to me. The height is good?

That is a good question about the Z plugs. Thinking about it though I don’t think it matters. They are split off the same driver. That is why Minis fry the Z driver on the board, like mine just did. It does not adjust the Z steppers to make the X carriage match the bed. Also no way to do it in the Y direction anyway. I think it maps the 4 corners and adjust Z height as it is printing. It would still run both Z motors at the same time to adjust Z height. I believe you square the X rails to the frame and not the bed because you want to keep the X rails perpendicular to the Z rails so they don’t bind. Then the auto level takes care of any bed misalignment. Might still be nice to have some leveling nuts to keep the bed “close” to level manually.

That explains the pathetically tiny heat sink on one motor driver IC. Sounds like a bad idea to drive two steppers from one controller. I leveled the Z axis as best I could measuring both sides to the top frame with a ruler. Seems to be working ok. I did see a lockup one time while printing which I chalk up to the Mac Cura app crashing ( I am not using the latest version). I have learned a lot about 3D printers by doing this repair.

When I took mine apart to replace the board there was no heat sink to be found. Even a pathetically small one would be better than nothing! Almost the first item in the build Ohai is to install the heat sink.

I found this after my other post. It does specify the left and right stepper plugs.

I put a bigger heat sink on the new board (from an arduino stepper driver). It hangs over the chip a good ways but didn’t short out anything else on the board. I do feel partially responsible for the heat issue though. I have been printing in an enclosure that houses the entire printer (electronics and all). I didn’t think it would be an issue having seen pictures of Lulzbot’s print farm. The printers appeared to be fully enclosed and I thought I read somewhere they kept the temp. at 90c ambient to prevent ABS warping. The first prints off my repaired Mini are some parts to duct outside air in (and back out) of the electronics housing. I am adding fans outside the enclosure that will hopefully cool the electronics without cooling the enclosure. We will see.

I did not see a date on this post but from what I see you are way behind on firmware and that is just one of your problems.

Regarding the board,
I just upgraded my TAZ5 from a RAMBO 1.3L to a 1.4. My TAZ5 is 3 years old as of May 2020 and it was a “sale” item as Lulzbot was upgrading the TAZ5 at the time so they were getting rid of the old model.

The first thing I recommend you do is to check out this link if you have not already found it and match your board to your connections.

If you get stumped contact UltiMachine and they can help you out as they did me. They make the boards. I purchased my 1.4 RAMBO board from them directly.

It took me a bit but I finally doped it out.

Regarding the firmware, You should be using Marlin. You can download a copy from the Lulzbot site via the last version of Lulzbot Cura. It does not sound as though you did that. The “latest” version of Cura from Lulzbot (Lulzbot/downloads) is version 3.6. This is the safe method, but when I found the firmware on Lulzbot downloads and was able to read it via ARDUINO or Visual Studio Code it was ancient (more than a year old) and Lulzbot did not update it before they went belly up and sold out to FARGO 3D. While it was supposedly released in spring of 2019 it is much older than that based on the comments of the person who coded it.

The risky method and the most time consuming is to go to GitHub and download the latest version of Marlin as of February 20, 2020. It is version 2.05. If you code in C++ this will look familiar to you. Again you will have to download Arduino if you have not already done so but I find editing with VSCode much easier. You will have to download the configuration file from GitHub then recompile the firmware using Arduino after editing. This has messed up a lot of people from what I have read in the Facebook 3D print section. If you don’t get it right or if you accidentally misplace a comment the machine won’t work. On the other hand if you are using ARDUINO it will not compile if you get the code wrong.

You need to know that there is an Arduino debugger but to be honest I did not figure out how to use it. I ultimately found an “expert” who fixed the code for me and I say that with some reservation because I have not as yet flashed it. I am adding a BLTouch sensor to my machine and I need to print parts as well as run the connections.

As for not printing you did not say if the print head was moving or not. 3D printers aren’t Star Trek replicators. They are a bit slow. The process is for the printer to warm up to temperature before printing. Just in case you did not see it there is a means of warming the print head before printing. You will note that in the firmware. If you are completely level and you have the correct distance from the board the printer will usually run a circuit when printing the first layer. You may not see anything at first. Be sure you are using the right temperature for the filament you are using and be sure you “cold pull” the nozzle with nylon before printing in order to clean it out.

Calibrations are a big deal. Ideally you should calibrate for each new spool of filament you receive. There are several types of calibrations and among those is calibrating the Z axis. There is also calibration for stringing when you print and… well search print calibration. You are going to hate me. Libraries who do not have print technicians available are lucky that they print anything at all.

Marlin is beautifully commented especially if you read it in VSCode. You should be able to make the necessary adjustments if as you said you have this experience but I have been working with Computers since DOS 2.0 and this was new territory for me. It’s actually robotics.

The easiest thing is to just install a copy of Lulzbot Cura then download and flash the old Marlin version 1.1.35 or you will be as old as I am before you return the machine to the library.

I sincerely hope this helps and I have not insulted your intelligence by telling you things you have already figured out.

Oh and regarding what “defuzz” said about grinding. Set the tensioner to about 5mm using a caliper and if your z offset is correct at “auto home” it will be about 0.18 mm from the print bed or just enough to cause a slight and I mean very slight drag on a piece of paper under the nozzle if you manually level.

Best of luck.