Noob gifted inoperable Lulzbot Mini: Need Help!

Hello all,

My roommate’s coworker gave me their lulzbot mini that was collecting cobwebs in their garage after I expressed interest in 3d printing. However, it is in need of some TLC, and I have so little knowledge on 3d printing I dont even know where to begin.

I downloaded Cura Lulzbot Edition (3.6.20) and attempted to connect the printer to my computer, however, it could not be found. The previous owner mentioned this would happen, and suggested “the Arduino may have gone bad”. Personally, I have no idea what this is, but my roommate mentioned it is a fairly common electronic part, or at least thats what I understood of what he said. Unfortunately, the screws are rusted in place and a few of them are completely stripped, so at the moment, the case is stuck in place.

Im not gonna lie yall, I feel a bit overwhelmed, and a little over my head. haha, any help is appreciated!

I don’t know what the costs would be but I would look into having the machine refurbished.

I would contact and see what they suggest.

You could also try and get their recommendation as well.

Almost looks like usb port is pried off the board? That would definitely cause the issue. If you arent comfortable I’d do what others suggested. If you are why not drill out those bad screws. That way you could get to and see if you just have to repair that usb.

As of now, Im locked out of the case. I tried to use an screw extractor, but frankly the screws are so tightly seized, the extractor only made the stripped screw heads worse. My next step is to go buy the proper sized drill bit and try to just drill the screws out completely, without damaging the housing case.

Thank you for the links, those are always super helpful! If all else fails, I fill fall back on this. I figured I received the printer for free, If I have to spend a little to get it fixed up by someone that knows what they are actually doing, its still a good deal for me.

The board might be fine other than damage to the USB port (you might be able to repair that). It may just be a blown fuse.

An “Arduino” is a simple computer commonly used in electronics projects. They are typically flashed to run just one program. They do not support multi-tasking, etc. But they do have a general purpose I/O interface and this can be used to control robots or other electronics projects.

While an actual Arduino is cheap, the printer doesn’t use a simple Arduino. It uses a Mini RAMBo board. RAMBo = RepRap Arduino-compatible Mother Board. Basically it’s a special Arduino that is integrated with everything necessary to control the 3D printer. As such, they do cost more than just a plain Arduino.

I’m not sure which generation of Mini 1 you have. You’d need to know the serial number (they were produced in batches. Visit this page and scroll to the bottom where you’ll see the serial number ranges and you’ll be able to work out which Mini 1 you have.

You can find the installation instructions for the Mini RAMBo v1.3 board here:

You might not need to replace the board. Before doing anything drastic, check the fuses on the board and make sure you don’t just have a blown fuse.

If you do actually have to replace the board (hopefully not), then you’ll also need to flash the board with the latest firmware.

IT-Works 3D sells replacement boards (either new or refurbished). See:

Thank you so much! This was a huge help. The links are especially appreciated.

Also, it seems I have a mini1 model “Daffodil” - KT-PR0035-XXXX - The first production batch of 1000 machines.

If you need any specific help let me know. I just finished totally rebuilding a mini and upgraded it to a 1.04. I also have a spare Mini Rambo board if you need one as well!

Well, I was able to get the stuck screws out of the case with the help of a drill bit. The insides, other than being dusty, seems to be in pretty good shape. The only thing remarkable I can see, is the USB-a port, which is lifted from the board and will need to be soldered, as well as an unconnected wire attached to the fan.

Does anyone see anything in the pictures that Im not aware of that may be a further problem?

Looking at the way that USB jack is pulled up, I’d say you need a new part (and not just re-solder). The pins have stayed on the Rambo which means they likely pulled apart inside the jack itself. They can be found at your local electronics shop, or online via retailers Aliexpress, or Banggood (these take a long time to ship). If you are in the US, you can get one faster from As for the fan, that’s easy. You can see the Fan 2 connector in the middle of the board (also shown on your pic). Just plug the case fan back in there. Be mindful of polarity as well.

This looks like the older Rambo board. If you’re inclined and have $100 to spare, you can replace the board with the newer miniRambo which will allow you to add an LCD and SD card reader down the road. The mini is an awesome printer and you will definitely enjoy using this one it is repaired!

Thank you all!!!
I decided to take yalls advice and buy an updated board. It should arrive in the next few days. It seems that this purchase will almost certainly fix the issue, so Im feeling optimistic, albeit a bit nervous, lol.

No need to feel nervous, The group on these forums have a huge wealth of information and have been invaluable to me as I got started.

If the new Rambo doesn’t fix it, then it’s likely that you have a broken wire(s), probably in the build plate harness.

Hello All,

Great news! The mini-rambo 1.3a arrived last night, and I was able to install it. I updated the firmware using Cura-lulzbot 3.6.20, and the printer turned on and connected to the computer without any issues!

Problem though, I tried printing the rocktopus STL, and it did not work. The printer had full range of motion, acting as if it were printing, however no filament actually left the nozzle.

I have done the following trouble shooting:

  • cleaned the build plate and nozzle with IPA

  • purged the Hot End @ 290 degrees C

  • Removing blue corrosion near the heat-break, on the heater block of the Hot End

  • adjusted tension on the filament retention clip

  • Extruded multiple sections of clean white filament (previous owner used black filament)

Despite my troubleshooting, filament still will not flow while printing. I am confused by this, as it will extrude when I press “Extrude” on Cura, however, anytime I attempt to print, its as if there is a clog. Initially I was concerned some minor rust on the Idler bearings might be causing the problem, but with the corrosion on the Hot End, and it being covered in old filament from the previous owner, I’m not too sure what the actual problem is.

I wouldnt mind buying a new Hot End (if I could actually find one in stock somewhere, lol) but im concerned about having to buy an entire new Tool Head assembly.

any advice?

Regarding the corrosion… you can see the assembly instructions for the hot-end here:

Scroll through that page and look at the photos… if it’s that blue stuff you see in those photos, that’s normal and not corrosion.

But… brass is soft and those extruder nozzles do wear over time and occasionally have to be swapped for a fresh nozzle (a replacement nozzle is about $10).

You may want to clean up your heater block. You wont get it to look shiny new… but you should be able to get all the obvious clumps of filament build-up off.

You can clean up the heater block by just getting it hot (hot enough to melt the filament). I use tweezers to pull away any good. You can use a putty knife (careful not to touch any wires … you may wan’t to get it “hot” and then switch off the power so you can clean near the wires without a risk of shock and blowing a fuse) as it gently cools down. You can also use a scotch-brite pad. (LulzBot supplies red scotch-brite pads for cleaning the nozzles in the accessory toolkit that comes with new printers.)

Regarding it not extruding when actually printing a part… it’s possible the nozzle is too close to the bed.

See this page:

Particularly, check step 7 … setting the Z-offset. Initially they show how to set it to -0.8. That should be too high … but at that height the nozzle will definitely not be touching the bed so the filament should not be blocked … it should flow easily (although the part will probably look awful because the filament is basically “falling” onto the bed.). They want you to bump the z-offset down another -0.1mm at a time until you get a good nozzle height.

My “guess” is that you’ll find a decent z-offset is probably somewhere in the neighborhood of -1.2.

You can measure it … assuming the filament is flowing, let Cura create a part and lay down a “skirt” around the part to get the filament flowing. Once the skirt is finished, abort the print … pull it off the bed, and grab some calipers and measure the thickness of the skirt at several points all the way around the print. You want to make sure one side isn’t significantly thicker or thiner than the other. And you want to confirm that it’s very close to the first-layer height that you set in Cura (e.g. if you tell it to 0.25mm layer heigh but the first layer height is 0.35mm then you want the readings to be close to 0.35mm with your calipers. Again… measure lots of different spots because you’ll find it will vary.

If you get a lot of variance, your nozzle may not have been clean when it probed for level (or it could mean a washer is a little loose).

I believe you are correct about the ‘corrosion’. Mine was in far worse condition, but I do see the resemblance.

As for your other advice, I’m afraid I don’t quite understand enough of the process to actually follow the instructions.

  • what is Octoprint?, and how do I open the octoprint dialog box?

lol Im sure this is a very rookie question, but frankly, I have no idea what I’m doing. hahaha

The reference to ‘OctoPrint’ was in LulzBot’s documentation. You don’t actually need it. What they really want you to do is open a Console / Terminal window to type those commands.

OctoPrint is a network print server and most of the time people run it on a tiny little Raspberry Pi single-board computer (it’s a tiny low-cost computer roughly the size of a deck of playing cards). The idea is that instead of connecting your expensive computer to the printer … you connect the cheap Raspberry Pi (OctoPrint) server to the printer and Cura (which has an OctoPrint plug-in installed) knows how to send your print jobs across the network to OctoPrint and OctoPrint takes care of spooling the job to the printer for you. Check out: “OctoPrint” is the server software, but a Raspberry Pi needs an operating system (it runs on a microSD card) so they have this pre-built OS image called “OctoPi” … and if you copy that image to the microSD card, it has everything necessary pre-installed. The first time it boots it asks a few questions, but once configured it becomes your print-server.

BUT… OctoPrint’s user interface runs in a web-browser (you don’t actually connect a screen, mouse, keyboard, etc.) and it has a “Terminal” tab that lets you type direct Marlin G-Code commands to the printer and see it’s responses. You can do the same thing in Cura (no OctoPrint needed). In Cura, there’s a “Prepare” side … where you get a job ready to print, and a “Monitor” side where you watch the job in progress. In the “Monitor” side, there’s a “Console” button. This opens the interactive terminal where you can type in the Marlin G-code commands.

Your printer speaks a language called “G-Codes” (because most of them start with the letter G. You can find the full documentation here:

I wrote a primer on the topic that you can find here: Demystifying G-codes & Why you might care

When you bring a part into Cura and have it generate a “g-code” file… it’s a list of human-readable text full of those commands. It tells the print head where to move and how fast, how to heat up, etc. Literally everything the printer does is based on those codes.

It turns out the printer has some non-volatile memory so configuration changes like z-axis offsets, etc. are all stored via g-code commands. Printers that have a display (like the Mini 2) would also let you do this via the display on the printer (no terminal needed …it has menus). But the Mini 1 can only be controlled via a computer.


That was exactly the issue! I was able to open the command box, and paste in the line. I gave the print another go, and while the first few layers were a little rough, it quickly found its groove. It seems to be working fine now!

I will follow your advice in future tests to dial in a more accurate z-axis offset.

Thank you again!

1 Like

If the first few layers were “a little rough” it might need a tiny bit more adjustment on the z-offset. But at least you now know how to tweak the z-offset.

The printer probes to the top of the metal washers on the corner of the bed. The washers are 1.5mm thick so the glass surface. Usually a z-offset will be down around -1.2.

It turns out it can vary by filament type. It helps for PLA to get a tiny bit of “squish” on the bed … not too much, just a little. If you were to print using PETG filament (which likes to stick to EVERYTHING) then the filament should be more gently laid on the bed (not squished much at all). So I tend to print my PLA with a Z-offset just a tiny bit lower than when I print PETG.

My z-offset is probably around -1.25 for PLA and around -1.15 for PETG.