Mini not self-levelling

I have been using the Taz3D for ages and it works well (particularly after I built a temperature controlled enclosure).

I have just received my mini and gone through the quick start guide and printed the octopus, no problem.

When I draw something up in inventor and save it as an STL, the mini doesn’t go through the bed levelling routine, it just starts to print about 3mm of the bed.

I reloaded Cura and made sure that I use the mini profile.

I even used slic3r to create g-code and loaded that into cura, but no bed levelling.

What is the quintessential thing you need to do to engage bed levelling?


A couple of questions and related suggestions.

Which version of Cura are you using?

Did you switch to “Full Settings” under the Expert tab? If so, you will need to load a profile for the material and resolution you want:

You may also need to do this in Slic3r (I don’t use and can’t remember the specifics from other threads).

The Rocktopus printed OK as it loads everything it needs the first time you start Cura.

If you downloaded the Cura set up for the TAZ your Mini should print out of the box, no changes needed. Does it print the samples ok? I would contact support before making any changes or adjustments.

Thanks for the suggestions.

I loaded cura and profiles from the USB drive that came with the mini.

The samples on the USB drive printed fine.

Are you meant to load STL files to Cura or GCode files, or does it do both?

So if the Samples printed ok, then the printer is ok. I think there is a newer version of Cura than what comes on the USB. I would download that and set it up for the Mini and reprint at least one of the samples.

You need to take your STL file into Cura and let it process it with the defaults for whatever filament your using. It will do the slicing and prepare the gcode which you really don’t need to mess with for now. The created code has the wiping and leveling routine already in the script. I use the machine control to preheat the extruder hot end and get my filament started and feeding correctly then use the print button and the machine should cool down the hotend, wipe on the pad and do the self leveling. I always keep a spare Scotchbrite pad around to wipe the nozzle off when needed.

After it does the self level it will go to Home and wait for the bed and hotend to heat to the set points in the gcode.

FYI Not all STL files are printable, just because they load and process in Cura does not mean they will print correctly!
With Simplify 3D it will not prepare a faulty file, and if it does it will show up in the Preview mode and you can see the defects.

IF your importing gcode into Cura already processed, It might not have the wipe and leveling code.

The most important thing when troubleshooting a problem is only make one change at a time and keep it simple.

Was the gcode file created by Cura with the Lulzbot start/end gcode? The wiping and leveling procedure is contained in the start gcode that is prepended to the toolpath Cura generates in the Cura Lulzbot Edition.

If you load a gcode file into Cura that was made without the wiping/leveling start gcode specific to a the mini, that might be the cause of the problem. It isn’t clear to me whether Cura would just act as a platform to transmit the pre-built gcode, or whether it would prepend the usual start/end gcode.

You could test out if this is the problem by opening the gcode file in a text editor, and manually adding the start and end gcode to the start and end of the file, load it into cura, and see if it prints right.

You can get this start/end gcode by opening expert settings and importing a profile (or in Cura v17, copying over the quickprint profile when switching from quick to expert), then going to the start/end tab, and copy pasting. Make sure the filament profile matches the filament you are using because there are differences in the start/end gcode for different filaments.

I am having or had issue that may be relate. My first mini had an issue and Amazon sent me a new one and I wanted to make sure the software was re-installed fresh. Uninstalled Cura, deleted all the folders and expected the new machine to start from the beginning fresh. It didn’t, it remembered all my old settings that were changed while troubleshooting the old mini. Tried over and over trying every trick I could. I finally had a friend bring over his laptop to get Cura to start fresh.

There has to be a hidden file somewhere and looking through the forums has not helped. You may be running into the same issue with the the mini looking at an old taz file. I will be interested if somone could solve this…


So, I have worked it out. Thanks.

You led me to the solution. I had the Mini profiles loaded, but had not loaded the filament profiles. It would appear that the filament profiles contain the self levelling gcode.

All, good now, but this alloy 910 is an interesting beast. I’ll load my issues with that in the filament forum.

Thank’s again for leading me in the right direction.

It will depend on your OS. Quit Cura first.

In OSX, if you go to your user’s Library/Application Support folder, you will find a cura folder that holds the personalized settings. Delete that folder (or rename it) and restart – it’ll be come up totally fresh.

In Linux, there is a hidden folder in the user’s home directory named “.cura” (the prepended dot is what makes it hidden). Same thing – delete that (or rename it) and the personal settings get nuked, and Cura starts up like has never been started before.

Windows – I don’t know the answer. I would guess it would be in whatever folder Windows stores personal settings, but what that is, I have no idea.

me: taz-5 for over a year. ’ just purchased a taz-mini for use on the road…

I skipped the beginning, went right to expert/advanced and the nozzle skipped any leveling I had just read about and began “printing” 5 mm above the pei-surface just as you described… I fixed the trouble - but I will have to guess at the causes: the following is a guess:

– when brand new, the Cura/taz-mini lacks the leveling routine in the advanced/expert modes -
– run, first in the “expert/quickprint” mode - print something small (the octopus ?)
– without shutting down, switch to “expert/switch to full settings” –
– -- you will be prompted to copy the quickprint settings into full settings -
– SAY, “YES” — you may immediately change any advanced setting you wish.
– but now, the leveling routine has been copied into the full settings arena and the machine will work just fine, first doing the leveling and re-heating, then printing at 0 mm.

That’s how it (seemed to) work for me.