mini - y axis endstop and thwap thwap thwap

I’ve been using my mini now for a few months and I really enjoy.

Today while doing the preprint gcode it started going thwap thwap thwap. This was happening at the y-axis seek, where the bed was furthest to the rear (head at the front). It would do this for a while making quite a racket, then would proceed. I canceled the print and tried again a few times, and it would do the same each time.
I let it print after four or five times and the print seems normal.

I didn’t change the gcode or anything else related to the settings.

anything I should do to adjust or fix this problem? I searched the forums and didn’t find another thread with this problem.

Check that your endstop sensors are still connected and that your belt is still tight. Also make sure the motor pulley sets crews are still tight.

I powered off and checked the sensors are connected. I can manually switch them mechanically with my fingers placed on them and there doesn’t seem to be any debris. The stepper shaft still seems tight.


When I powered back on and manually control, the endstop works as expected. I don’t know of another way to test.

Unfortunately, the problem is still occurring, with the harsh sound of the stepper motor grating at the same position as described above during the presequence. I am not going to attempt additional prints until I can resolve.

Sounds to me like the motor is driving the Y axis to far in one direction. After the Home routine it should keep track of its position and its not. Either the belt is too loose or the pulley on the motor is slipping. When you look at the motor pulley the set screw should be lined up with the flat on the motor shaft. As already suggested that setscrew can be loose, use the proper allen wrench to check.

Or you could have idler bearing problems or other, but above is the more likely. A call to Lulzbot support might be in order.

It may have a cable/connector catching underneath the bed table that is keeping the carridge from hitting the end stop. So then it will cause the motor to slip until it gives up trying.

Look at the bottom of the bed while it is all the way back and make sure nothing is close to hitting. I have seen several that the cable chain was getting hit by the heat bed connector when the bed was traveling to the back end stop.

make sure the switch is being activated mechanically by the printer first. to check that the switch is activated you can send an M119 you should see the end-stop status of each end-stop. manually actuate the switch and send another M119 while still holding the y min switch (the one at back of the machine). you should see the end-stop switch triggered. If you don’t see the status change, that would be why it seems like the motor is skipping. the auto home routine drives the y axis until the y min switch is activated. if the y min switch is not activated, then the machine will drive the stepper for a set length of time. If the switch status does not change when you activate the switch, then I would contact Lulzbot(best support in the industry). You may have a broken wire or switch. i hope that helps. please let me know how it goes.

Thanks for all the replies. I have been away, but I have been unable to determine the cause of my issue.

I will contact support tomorrow

I had this problem show up about a month in. The wires where broken internally, stretched enough that the metal wire inside broke but the insulation was ok. I pulled the wires out of the printer, cut out the bad sections, spliced in some good wire with heat shrink. They where tight as hell. Not sure if it was just wear from bending in the harness pulling on it till it broke or if they got snagged on something under the carriage.
It was also intermittent, you mentioned it worked when you tried it manually so I would put money on it being your problem.

That is what the RMA found. I took it in today (since I live nearby) and had it fully diagnosed, fixed, and returned in under three hours.

I contacted support, and worked with them to try to further root cause the problem, covering multiple steps. It was pointing to a problem with the switching on the rear Y-stop.

I got an RMA, and in under three hours Aleph Objects had taken in the RMA Mini, diagnosed the problem, repaired my Mini, and had it ready for my pick-up. I was informed that my Mini’s problem was the wiring in the cabling chain under the print bed, and the wiring was replaced.

It performs prints as before with no problems now!

Did I say that Lulzbot support is the best?!? Lulzbot support is the best!

I have this same problem right now. I’ve determined that the source of the problem is the red cable leading from the switch to the motherboard. Somewhere in there it is not continuous. Now that I know this, how would I fix it?

Hi Katriddle

as you have found the culprit already, chances are good that you can find the position it failed.
Most of the cases this type of cables fails either because of rubbing on a sharp (metal) edge or because of continuous (sharp) bending in one position.
If you follow the cable way you should find the position it got damaged.

then you can either crimp or solder a short peace of wire in and protect it with some heat shrink or electric tape.

All the best
Frank