New hotend in Mini1 - Compiled new firmware - but can't seem to figure out G29/bed_leveling?

I seem to have most things configured to my liking in my configuration.h file - but the bed leveling I stole from the drunken octopus version of the mini1 doesn’t hit the mark for the bed leveling.

They suggest using:
#define NOZZLE_TO_PROBE_OFFSET { 0, 0, -1.375 }
//#define PROBING_MARGIN 0

Meaning to disable the margins and use the extremities - but as you can see in the picture attached - it’s basically still at least 4-5mm from the edge of the washer. I can use G0 X or Y to move it over the washer so I COULD figure out the coordinates - but am unsure how (or why even) I should do that - I’d rather find the recommended method.

I haven’t even gotten to the cleaning/wiping strip yet - since I cannot get G29 to work. :slight_smile:

Anyone have any ideas how I can properly set the configuration.h file with the values needed to get the nozzle to hit the washer during G29, and not my glass bed?

Whole code here: mini_configuration.h -

You can manually adjust the coordinates with the M206 command.

It looks roughly 6mm off in the Y to me, so add to your startup gcode before the probing sequence:
M206 Y-6 ; adjust home offset (+X ~ nozzle moves left)(+Y ~ nozzle moves forward)(+Z ~ nozzle moves down)

If it’s also missing the wiping pad, you’d want the command before the wipe command(s). If it is hitting the wiping pad and missing the washer, make sure to reset to
M206 X0 Y0 Z0 ; reset home offset (+X ~ nozzle moves left)(+Y ~ nozzle moves forward)(+Z ~ nozzle moves down)
before the wipe command (G12). It’s probably best to have the reset command in your end GCODE.

I ran into this initially too and it was related to the backoff after homing.

Check out my repo where I upgraded to einsy retro with LCD and universal tool heads

1 Like

Are you referring to this (from your code):


  #define Z_SAFE_HOMING_X_POINT -3  // X point for Z homing
  #define Z_SAFE_HOMING_Y_POINT 163  // Y point for Z homing


#define HOMING_BUMP_MM { 0, 0, 2 } // (linear=mm, rotational=°) Backoff from endstops after first bump
#define HOMING_BUMP_DIVISOR { 2, 2, 4 } // Re-Bump Speed Divisor (Divides the Homing Feedrate)

#define HOMING_BACKOFF_POST_MM { 0, 0, 0 } // (linear=mm, rotational=°) Backoff from endstops after homing

Anyway check my config and config_adv. There’s quite a few goodies in there

While combing through your config and adv files - why do you have the wipe_sequence disabled, and what are the two wipe sequences pre and post commands for? Do you specify the wipe command elsewhere perhaps? Good stuff in here!

// Require a minimum hotend temperature for cleaning
#define NOZZLE_CLEAN_HEATUP // Heat up the nozzle instead of skipping wipe
#define WIPE_SEQUENCE_PRE_COMMANDS “G0 Z10 F2000\nM107”
#define WIPE_SEQUENCE_POST_COMMANDS “G0 Z10 F2000\nG28 X Y\nM106”
// Explicit wipe G-code script applies to a G12 with no arguments.
//#define WIPE_SEQUENCE_COMMANDS “G1 X-17 Y25 Z10 F4000\nG1 Z1\nM114\nG1 X-17 Y25\nG1 X-17 Y95\nG1 X-17 Y25\nG1 X-17 Y95\nG1 X-17 Y25\nG1 X-17 Y95\nG1 X-17 Y25\nG1 X-17 Y95\nG1 X-17 Y25\nG1 X-17 Y95\nG1 X-17 Y25\nG1 X-17 Y95\nG1 Z15\nM400\nG0 X-10.0 Y-9.0”

I am using the G12 pattern generator, so not using the explicit command.

The pre and post sequence commands definition is going into marlin mainline at some point I hope. It’s waiting on my pull. They basically ensure the printer doesn’t park on the wiper pad and turns the fan off/on (should be M106 F255, I guess I don’t have the latest pull on gitlab)
If you have your fan on while probing, the nozzle freezes up a bit and it doesn’t ooze onto the target discs as much