New Mini LCD not working

I bought a new LCD for my mini, but I cannot get it to work. Here’s what I have done.

  • Checked the board version Mini Rambo 1.3a
  • Flashed to current firmware with LCD checked multiple times using cura 3.6.20 and 3.6.21
  • Removed LCD and tested on another Mini to make sure it’s working
  • Checked continuity on cable ribbons
  • Reversed ribbons

A few things to note, the printer works fine uploads and prints 100%. When the LCD is connected via both ribbon cables, the USB connection does not work. If I unplug one ribbon, it does work and I can connect octoprint.

Any other ideas? I’ve been searching online and can’t get through to support to see if they have any other ideas.

*Edit: my post got marked as spam for some reason so I’m adding this to unlock it.

Can you post the link to the the LCD you bought?

That’s odd, if any LCD worked I’d expect it to be that one. I think you already did this when you flashed the new firmware, but you could try resetting the EEPROM. If you have any settings like your Z Offset, be sure to write that down first. Just use these two commands and it will reset the EEPROM…

M502 ; reset! 
M500 ; saved!! 

…then restart your printer.

I can’t connect to the printer when the LCD is plugged into the board.

Is the SD Card plugged into the lcd by any chance?

Yeah, I’ve tried both inserted and not, with the same results.

I finally figured out this issue! After trying literally everything I could I finally broke down a new board. When I got it I was till getting the same error. $95 later and now having two Rambo boards later I was no where close to solving the problem.

Since I had plugged in the new LCD to my other printer and it worked, I know there was something wrong. Using a Rambo board with loaded firmware and nothing but power and the LCD attached I went to trouble shoot again.

I had tested continuity on the ribbon cables, but I suspected they were the issue. After searching for pictures of the ribbon cables I saw that the ends of 1 of the two ribbon cables didn’t match up. I took the end connectors apart and reversed the ribbon direction. Sure enough, that was the problem! The LCD was working great.

So the problem was just a badly wired cable from the factory. At least I have a spare rambo board. Maybe I’ll make a new printer just for it so it doesn’t go to waste.