New Mini not extruding at start of prints

Hi guys,
My Mini is about a week old, and I’ve gotten some pretty awesome prints out of it. One consistent issue I have though is that, regardless of material I use (I’ve tried ABS, PLA and wood-fill PLA) it does not seem to want to start extruding at the start of a print. Often times it will finally get going while it is still printing the skirt/perimeter type thing it does and it’s not a big deal. Sometimes it doesn’t, which is obviously a problem (it won’t actually start extruding until midway through what is supposed to be the first layer).

Any ideas what is going on here? The problem seems to be worse when printing on high quality, meaning the nozzle is closer to the build platform. Do I need to maybe adjust the nozzle offset?

I tried setting the “//suck up 30mm of filament” bit of gcode so it doesn’t suck up any.

I’m using Simplify3D now but had this issue with Cura as well.

Thanks for any suggestions!

Hi wermy

I observed the same “issue” on my Mini and played a little:
In the start GCode you found already the retracting of filament for bed leveling.
After the leveling the filament get fed back all the way it was retracted before thus what ever value you give for retracting will be used to feed back.

Here the line doing that:
G1 Z2 E0 F75 ; extrude filament back into nozzle

What you might not have seen is that at the end of the print when Z is raising the filament gets (very slowly) retracted as well.
This probably is done to prevent dripping while the machine is cooling down. In any case, this retraction is not counted when feeding back after bed leveling.

In the case I am printing small peaces where the skirt might be not enough to get the filament flowing I am adding a couple mm to the feed back after bed leveling. That worked out for me :wink:

All the best

Hi Frank,
Thanks for the reply! Would you mid sharing what the modified line looks like when you make it extrude a little after leveling?

Something like this to make it extrude 5mm?

G1 Z2 E5 F75 ; extrude filament back into nozzle

I’m still new to all this, just want to make sure. :slight_smile: Thanks again!

Hi wermy

I am new to it as well, just can’t stop myself playing around and tinker on almost every screw I can find :smiley:

Yes it is exactly how you mentioned. Only that 5mm is a lot :wink:
I have used there max 2mm. I try to have it just enough that the skirt can do the rest. To much and you end up with some curled filament hanging on the hot end when you actually start the print. Murphy will do the rest and make sure this “pile” will end up disturbing your print.

All the Best

Alright, thanks!

Try a quick experiment, set the z-offset to .2 in S3D (GCODE tab).

If this helps, then the nozzle or the probe contacts are dirty and causing the autolevel process to fail. Heat to extrusion temp and clean the nozzle. Scrub the touch points and make sure any filament is removed. Change the wiper pad… or flip it over.

When the nozzle or any of the touchpoints are dirty, it affects the conduction which tells the software its touched the bed. This will cause the nozzle to drive further than necessary into the bed, causing the wrong print plane to be calculated… one that’s too low. Hence the initial nozzle height is too low and impedes the extrusion of the first layer.

I had this problem as well. I’m pretty sure mine was caused by me setting the first layer at less than the default.
I just added more rounds of skirt at the start since I liked the results I was getting from a thinner first layer.
I too played around with more extrusion at the start and couldn’t get much satisfaction there.

I took a slightly different approach. Lots of times you can see the nozzle is still dirty (for whatever reason) after cleaning but there’s no time or physical clearance to wipe it off with a rag before it goes into the auto leveling sequence so I added a couple lines in the startup gcode to raise the Z and pause for a few seconds.

M109 S140                    ; set to probing temp
G1 X5 Y15 Z163 F5000         ; DS - raise Z for additional cleanup if needed
G4 S5                        ; DS - dwell for 5 seconds then resume
M204 S300                    ; Set probing acceleration

I’ve also gone as far as to open the idler latch and shove the filament back down into the nozzle after the probing is done and it is waiting for the nozzle/bed to heat up the rest of the way. Usually results in a small blob of filament before the head moves but I’m ready with the tweezers and grab it.