Nozzle Offset > Measure Automatically Feature


I am working with a Lulzbot TAZ Pro. I have made about 5 successful prints with the machine. However, on my most recent print, I noticed during the initial leveling process, the nozzle head was offset about 1 cm too far to the right (so it wasn’t hitting the cleaning pad or the metal corner discs).

I found this article which explains how to run the automatic calibration process and followed the steps (updating firmwater, unloading filament). However, when I go in the Lulzbot menu options to Menu → Advanced Settings → Nozzle Offset, the Nozzle Offset button is greyed out and I cannot select it. I am trying to select it to choose the Measure Automatically feature, but I am unable to get past the Nozzle Offset button.

I have tried doing this with the printer connected via USB to my computer and without, with filament loaded and without, but the Nozzle Offset button is always greyed out and I cannot select it. I realize I can manually bump the X-axis on my printer, but I would love to know how to run the automatic calibration process.

What am I doing wrong?



Something might be interfering with the tool head’s motion, and since the pro uses sensorless homing, that resistance is getting interpreted as it hitting the end stop. With the machine off, slowly push the tool head to the left side and see if there’s some resistance before it reaches the left limit.

If you can post video of the attempted homing sequence, it would help.

Nozzle offset is fair the dual print head only.

Thank you for the info about the nozzle offset being for the dual print head only! I knew it had to be some simple explanation like that.

I tried what you suggested to test the left limit, and it seems fine–I didn’t notice any resistance before it hit the left limit housing. What I just tried is using the “Nudge Nozzle” options as the printer was beginning its leveling sequence at the start of the print, and by nudging the nozzle’s x axis -7.0mm, I was able to line the head up with the cleaner pad and it also hit all four of the corner plates and started the print job which seems to be going well. When I exited the “Nudge Nozzle” menu it asked if I wanted to save the setting as default and I hit “yes.”

What I’m wondering is…is it okay to use the nudge nozzle to line it up? Or should I be concerned that something is out of alignment and I’m just compensating for it by nudging it?

I can certainly post a video. As I understand it, the homing sequence is what it does when you hit “Auto Home” and the x y an z axis return back to their “home” position. Is that correct, and the thing that would be good for me to record? Or is it the sequence the printer goes through when it is starting a print that I should record? Or both?

Thanks for your help, I’m a total newbie.


Record both. I think the only part of nudging the nozzle that sticks is the z offset, but I haven’t ever used it for x/y movements.

Here is a video of the homing sequence. One thing I hadn’t noticed before is that the X-axis backs all the way to the left housing, then jumps about 8mm to the right (about 00:13 in the video). The Y axis jumps about the same amount at the same time. I tried to Zoom in to show the resulting gap on the X, is that normal? That’s about the same amount that the nozzle is too far to the right when it tries to print.

Here is a video of the leveling sequence at the beginning of the print. This is how it runs naturally without any nozzle nudging. If I hit MenuNudge Nozzle during this sequence and bump the X to about -8.0 mm and the Y to about -4.0mm, then the leveling succeeds and the print begins. BUT I did notice that those nudge settings don’t stick, like you said, even though it does ask if you want to save them as defaults.

I have a Taz 6 and know little to nothing about the Taz Pro. FWIW, is it possible that the leveling sequence as seen in the video is for the dual nozzle extruder? Looks to me that it’s looking to clean and level with a left side nozzle.

@TigerMike when the Pro is set up with the single toolhead, it wipes on the right side before attempting to probe the front left corner. It’s missing the washer and pad by the same amount, so it’s simply off on the X axis.

@pneilson You may have a mismatch between your firmware and the slicer, or you are running the universal firmware and do not have the M175v2 toolhead selected. Plug the Taz into your computer with Cura running and update the firmware so they match. After updating, choose the correct toolhead from the printer’s menu.

If you experience the same missed wipe and probe after verifying firmware, check the position of your Y axis on the frame. Refer to step #16 here: OHAI: Open Hardware Assembly Instructions (

If you don’t have another printer to print the spacer, cut a similar shaped piece out of cardboard that’s 143mm long at the top, with a notch at the bottom to get around the corner of the frame.

After verifying/correcting the position of the y axis, if it’s still missing, you can change the position in the startup GCODE in the slicer software. There’s a couple places where the M206 command is used (prior to wiping, and after), with descriptive lines on how to adjust the nozzle after the comment (indicated by a semi-colon). You’d be adjusting the X print position to the left, so the command would be:

M206 X10 Y0 Z0 ; move X nozzle position 10mm to the left, do not adjust Y or Z.

Ensure you replace both instances of this command, or it will not correct both missed commands. You might want to do a quick check on the startup code to make sure there isn’t a 3rd (or 4th) M206 in there somewhere, but all the versions of Cura LE I’ve used only had it in there twice.

Good point. The amount of X offset seems just about right if there were another nozzle to the left of the single nozzle on my machine. So would that be an issue with the printer profile I have selected in Cura then? The strange thing is, this seemed to happen in between two prints without any changes to the profile I had loaded, which made me think it was an alignment/hardware issue.

The dual printhead is about 50mm apart, not the roughly 10mm you’re missing by. The only lulzbot toolhead that’s even close to that distance is the Dual v3.1.

@Wrathernaut Wow, thank you! I will try doing the firmware update and make sure I have the correct toolhead selected. I don’t recall even selecting a specific toolhead when I chose the printer profile upon initial install. I’m hoping that does it! But thanks for the additional steps to try with the y spacer and GCODE.

OK, that makes sense. Good to rule that out. Thanks!

@pneilson @Wrathernaut
The correct distance from the the vertical extrusion (that the control box is connected to) to the Y-axis mount (that is on the bottom frame) is 144mm. There was a change and the OHAI did not get updated.

What firmware are do you have installed?

What version of Cura are you also using?

@Wrathernaut You were right, I didn’t have the M175v2 toolhead selected…somehow I had M175v1. I removed that printer and added the correct one, then updated the firmware. Now it levels perfectly. I’m not sure how I missed that, I had tried several times before but was just missing getting the right toolhead.

Thanks so much for your help.


@bthoennes Thanks for the info! Thankfully it was a software issue and I didn’t have to tinker with those distances, although it’s good to know about that and the OHAI for future reference.


No problem, thanks for letting us know what the solution ended up being.

Good info. I have a MINI, not a Taz. I was wondering if the suggestion for inserting M206 will fix my problem which is the same as mentioned in this post of yours? My probe X , Y positions are off 6 to the right and 7 to the front of bed. So I guess I should try this line M206 x6 y7 z0 somewhere in my start gcode. Is that correct assumption?

I think you’re right about that, but I’m not an expert.

The other thing that I’d suggest to try before editing the gcode is that you have the exact printer and toolhead selected and the firmware update, because that made all the difference in my case. The Taz Pro had a v1 and a v2 for my toolhead, and I had the wrong version selected.