Octopi webcam settings

I have octopi setup and everything is operating except the webcam. We checking on the mjpg streamer webpage the JavaScript stream works, but the stream does not. It simply has a black box with an x in it. This is also what is shown on the octoprint control tab. The webcam I am using is a Creative Live Sync HD VF0770. Looking for advice on how and what settings to change.

What URL are you using to access the webcam? http://octopi.local/?action=stream?

I’ve never gotten the octopi.local to work on my network, but I always like to statically address servers. So I use the above, replacing octopi.local with the server IP address.

To get to octoprint I have been using http://octopi.local and to get to the webcam I go to http://octopi.local:8080. This loads the mjpg_streamer webpage where you can select static views, stream, and JavaScript stream of the webcam.

Does the “Test” button work in Octoprint Settings (Webcam & Timelapse)?

I went into settings and under webcam there is not a test button that I can see. Should there be?

Found the issue, it is IE11. Used chrome and it works correctly. Is there a fix for IE11 for this issue?

Ha! Use Chrome! :laughing:

I don’t have IE installed but the Octoprint camera view does work in Microsoft Edge browser.

Hmm… I don’t use IE11, usually Chrome.

Ask at the the Google community/forum pages for Octoprint:
https://groups.google.com/forum/#!forum/octoprint