OctoPrint With Cura Lulz Edition

I am looking to run Octoprint on a raspberry pi to add network availability to my machines. I know Octoprint has its own version of Cura Installed but I was wondering if that could be changed to the Cura Lulzbot Edition?

In theory you could create a Cura-LE engine plug-in but it takes a lot of work to do.

Same deal with upgrading to a newer version of Cura:
https://discourse.octoprint.org/t/newer-curaengine-some-day/54

I run Cura-LE on my desktop and use the print via Octoprint option in Cura to send my prints from Cura to Octoprint over the network.

I don’t know about updating Octoprint’s Cura version, but depending on what you want to accomplish, you might not need to.

I got a Taz 6 a few days ago, and connected it to a raspberry pi 3 running Octoprint. It printed just fine with the default settings.
Before connecting to octoprint, i did a few prints with the taz connected to my laptop, after letting it update cura and the printer’s firmware, I printed a few things and they all came out great. I then switched from the included ngen green/yellow filament to natural white PLA and printed some more. Everything printed great.
I then connected the printer to my raspberry pi running Octoprint, and manually copied the settings from the taz into octoprint, taking care to convert the units as needed. The taz displays some settings in mm/min. Octoprint wants mm/s.
After connecting Cura to Octoprint, I was able to use my laptop to tell octoprint to print my models as easily as printing from cura.

From what I can tell, printing this way generates g-code on my laptop, then sends it to octoprint, so the version of cura on octoprint seems to be irrelevant in this situation. I’m new to 3D printing, so there may be some nuances I am missing.

A Raspberry Pi lacks the necessary memory to effectively run Cura – if you want to do this, you’ll probably need to host Octoprint on something a bit faster and larger.

The biggest advantage of OctoPrint is that it removes the latency / bandwidth sensitive feeding of GCode from a desktop computer that may do “other things” and moves it to a dedicated computer that is (or should be) doing nothing else. Slicing is one of those “other things” that desktops are really good at (and the Raspberry Pi isn’t).

The OctoPrint community is active, strong, and knowledgeable. There are OctoPrint plugins that can enhance its capabilities.

I run multiple slicers on my desktop all of which output GCode which can be uploaded to OctoPrint using a browser on the desktop or in many cases, an interface with OctoPrint built into the slicer. Prints that take hours (or days) are easily done with OctoPrint and I don’t have to worry about my desktop being interrupted by things like Microsoft updates, etc.

I do the same thing - slice with the local cura, then upload gcode. Getting Cura to compile is a bit of a trick, and IMHO, not worth the effort.

And to echo the earlier comment, given Cura’s instance on slicing automatically (ode to the ‘slice now’ button), and the load put puts on my 6-core laptop, it’d probably fry a raspberry pi…and we know that burnt pie isn’t any good :slight_smile:

You can disable the automatic slicing. I personally like to keep automatic slicing disabled. This will put a prepare button where the print button is for you to use.