Printing upside down and shaking it all around

Hi all, I’m James from the UK. I own a Lulzbot AO-101. I noticed in the product description that Lulzbot tried printing upside down and also while driving off-road. I decided to test these claims (the fun starts at 4:10)

I’m using my printer for various projects including a bipedal 3/4 human sized android:

Oh hey, you’re the guy I saw drop that entire spool of plastic? How fun was that to respool? =)

Yes, it wasn’t too bad because it was mostly still roughly in a spool shape. Although I didn’t get it back on perfectly because about a week later the filament jammed whilst printing because it was still crossed over on the spool in a weird way as a result of being unspooled. Now one of my Android parts as a ‘filament starved’ few layers in it.

Not a question about printing upside down…but, what adjustments either to the model or to Slic3r settings do you need to do when making close fit parts.

Like gears or clam shell type items that need to fit together.

You mean like that gear bearing by Emmet on Thingiverse that I tried to print 3 times unsuccessfully? :stuck_out_tongue:

I’d be interested in tips too!!!

XRobots: I love the Iron Man movies, can’t wait for IM3 coming out soon. Your IM suit is awesome. :slight_smile:

Yes that sort of thing. I printed some gears on a Replicator 2 and the size was off to the point they wouldn’t mesh and the center to center distance was off.

Since then while waiting for delivery of my lulzbot, I’ve confirmed that the Blender model and the stl file are the correct dimensions. I then loaded the gcode into blender and it was definitely larger than the model.

So I then created the gcode with Slic3r and select perimeter = 0. Import this gcode into blender and it is the correct size.

Thing is, all the config files I see have the perimeter bumped up, the lulzbot file sets it to 150%. With that setting the gcode is larger than the model.

Since I don’t have the lulzbot yet to actually experiment, I don’t know what the ultimate implications of perimeter = 0 are.

AFAIK zero perimeter means all the printer will be doing is infill. There will be no exterior or interior walls. That’s not really what you want.

I thought that was only the first layer that was set to 150%. At least the few parts I’ve printed so far are correct in exterior dimensions, with some tolerance. The first layer is always fatter.

Larger for all layers?

Off topic, what version of Blender do you use?

I tried the Blender gcode reader addon in Blender 2.66 but it throws an error “Index out of range” when importing a gcode file.

How do you measure an object in Blender and make sure it’s the “right size”? Maybe I’m unfair in thinking this, but as a long time CAD user I don’t really trust a polygonal modeler for precise mechanical parts. I have to admit that even though Blender is installed on my PC, the only thing I can do in it is open files. The UI and modeling philosophy is too alien for me to grasp.

According to the docs 0 is the default for perimeter. With zero the gcode is nearly right on. I was writing from memory and you are correct about the 150% being first layer.

Apparently yes. But when I get my bot (it’s been in customs for 3 days now… :cry: ) I’ll fool with this some more.

Yes it takes a while to grok Blender. I’m by no means an expert, though I do have a rather extensive background in 3d graphics and CAD.

Blender is very accurate if you model accurately. People doing art and animation typically don’t bother. As for the modeler, the mathmatical representation of the object can be polygons, NURBS, whatever, it does make a difference what precision the coordinates are stored in. In Blenders case I believe it can go down to something near an Angstrom.

I didn’t use any measuring functions. I simply compared the x, y values for some representative points in the original dxf file, the resultant, stl after modeling, and the gcode representation. If the different representations are all the same size and all referenced to 0,0,0 the values should be nearly the same.

I am using Blender 2.66a and this version of the gcode importer:

Ok, so I got my printer and am now playing. :smiley:

I have now adjusted the filament diameter to match the filament that came with the machine and set extruson multiplier = .9 (the default is 1).

This produces parts that are about .1mm larger than the model. (Before changing the above settings I was .3mm large.)

You do realize that 0.1mm is very small? It’s 4 thousandths of an inch. And 0.3mm is 0.012", less than 1/64" which is still pretty good, considering this is a hobbyist machine, not a commercial one. This is not a CNC milling!

From the AO-101’s specifications:

Print Tolerance: > 0.2mm (0.008in) in X and Y axes> . Z axis is dependent on layer thickness

I just printed a 50x50x5mm plate with a 40mmØ hole in it. Not measuring from slightly bulging corners or the base layer which is very fat, I get between 49.92 and 50.0mm on sides which is pretty fantastic IMO (I made no change to the printer since I got it)! The hole is slightly smaller at 39.72-39.92mm. As for the thickness I got 4.63mm instead of 5. Maybe I should raise my Z endstop a little, I think the first layer widens and flattens too much. Also I printed at 0.40mm layer thickness which means 5mm amounts to 12.5 layers. Obviously 12 layers were made which partly explains the tolerance.

I used the 3mm_pt5-nzl_pt4-lyr.ini file from the AO-101 (available here) but changed the infill from 0.8 to 0.6. jebba on IRC (Jeff Moe) told me I could use the AO-101 Slic3r config on the AO-100.


Yes, of course, .1mm is pretty small.

And yes, it is a hobby machine, it is sitting next to my Bridgeport mill… so my lulzbot does have a size envy issue. :wink:

Since I intend to be making things that move and fit together, I want to understand the limits. The limits aren’t terribly important for making art or plastic cephalopods. But, making gears that mesh and have known center to center distances I want to know what adjustments need to made and where (in Slic3r settings, in the model, etc.)

With this 101, out of the box, with the ini file you mention, I was getting .3mm larger than results.

I’ve not had it long enough to have a feel for whether that is a slicing issue or a bot issue. (or not an issue at all, since even .3mm off on center to center of two gears is probably ok)

Hey I stumbled on an interesting post on this subject on the forum.

It seems you may be on the right track with the extrusion multiplier value. Look at GITRDUN replies, he explains how to set this exactly.,203510,203553#msg-203553

I intend to try this in the next few days. I also want to install a cooling fan in front of the extruder to help with small parts.