[SOLVED] Object centered in Slic3er, but not in pronterface

Hi guys, I have my 1st model ready to print (I hope). When I open in Slic3r it looks OK and it is supposedly located in the center of the printing bed.

I generate the G-code, but when I open the G-code file with Proterface, the model is in a corner instead of the center!!!

What am I doing wrong? :cry:

you can see the G-code here:
https://www.dropbox.com/s/kodggw254jxo0vf/Gcode_TOP_RG-Medium-TAZ_2.zip

and the STL:
https://www.dropbox.com/s/9zg01fch2ek9x9n/STL_TOP_RG.zip
Slic3r 1.0.0RC2
Pronterface: Printrun 2013.10.19

Does the object print offcenter? Are you referring to the gcode preview window in Pronterface? What are your bed dimensions in Pronterface (Settings > Options > Printer settings > (Width, Depth, Height)).

Thanks for your reply!

  1. Does the object print offcenter?
    I don’t know. In Pronterface: Printer (> Printer settings > General > Z offset ) is set to 0 mm, is that what you mean?

  2. Are you referring to the gcode preview window in Pronterface?
    Yes

  3. What are your bed dimensions in Pronterface (Settings > Options > Printer settings > (Width, Depth, Height)).
    298 x 275 mm

  1. What are your bed dimensions in Pronterface (Settings > Options > Printer settings > (Width, Depth, Height)).
    Bed size
    x: 298 y:275 mm

Print center
x:149 y:138

Z offset
0 mm

OK this is weird, I decided to print anyway and it is actually printing in the center of the bed :open_mouth:

It is a little confusing that I see it in a corner in Proterface…

What does this mean? That the “real” location is always the one in Slic3r and then I should not pay attention to the location shown by Proterface?

That’s just related to how Pronterface is interpreting the bed dimensions. After your print finishes, try setting the bed dimensions in Pronterface to 100mmx100mm save, close and reopen Pronterface. Then go back and set the bed dimensions back to what you had previously, save and reopen. Then reload the gcode file, it should display correctly.

Great, it works now!!

Actually Pronterface for some reason had a “built” (= bed, I assume) size of 200 x 200, so I put the same numbers I have in Slic3er:
x: 298 y:275 mm

And it did the trick, thanks!

I had the same issues. Pronterface always shows the gcode off the grid but infact it always prints centered.