Steps to print

Having a few problems with g-code set-up after changing from “basic” mode

My steps

  1. CAD program: Creating STL files in CAD program. Units are inches.

  2. NETFAB: Use NETFAB (basic) 6.0.0 159 to orient parts for printing. Save re-oriented part as .STL file. Part scale is OK.

  3. Slic3r: Load .STL files into Slic3r Ver. 1.2.9
    A. Parts show on tray as very, very small. I scale up by 2540 to get the size I want… ?
    B. Position parts:
    For single part - center part on platform
    For multiple parts - arrange different parts on platform to fill tray.
    Create G-Code
    Positioning looks good in tabs for the “2D” views and “layers”

  4. PRONTERFACE: Open Pronterface & load the G-code.
    Parts are positioned on the virtual plate so only the upper 20% is on the virtual plate.
    The text in the right side of the window (console) states the correct overall size (of part or parts),

How do I get the part (or parts) to be centered?
I didn’t see this problem with first prints, but after I changed from basic settings

What CAD program? You really need to change over to metric and mm measurements, it will make your life easier. Nearly all the 3D and laser stuff is metric. If your using FreeCAD, 123D or Fusion 360 they can all output a STL file and that’s all you need for Cura. Just make sure you design in metric, output the STL file in metric and Open Model in Cura. You can rotate and scale if needed in Cura. I have never tried to Print more than one Model file at a time. Quick print in Cura works fine and do some simple projects first. When you get that down, then you can worry about the Expert settings.

I tried this with an STL file part dimensioned in mm, made G-code in CURA, but had same offset problem in Pronterface.

I found a setting in Pronterface Settings / Options / Edit Settings / Default / Build dimensions.

The 3rd and 4th numbers were set to center the build (###x###x###,145,145,0) for X & Y offsets.
I tried setting the X and Y offsets to Zero, [295x275x250+0+0+0] and now (using g-codes from files in mm & inches) the parts appear centered on the build plate.

I have owned both a Mini and now the TAZ 5. My CAD programs are and have been set at MM for a long time. Never had any issues in Cura or Simplify 3D, no changes ever needed.

It sounds like maybe you should try using Cura to smooth out your workflow.

I have a TAZ 4 upgraded to a TAZ 5. My work flow is CAD in mm, save as STL, open STL in Simplify3D to orient model(s), add support, and slice, then send gcode to Raspberry Pi with AstroPrint to print the part.

I know I’m heavily dependent on closed source software here. I plan to try Cura again whenever I’m asked to pay for a Simplify3D upgrade (v2 to v3 was free) but in the meantime my process works very well for me.

Never mentioned what CAD tool you’re using.
I use Solid Edge in inches every day, have no scaling problem at all.
The “trick” (such as it is) is to change the settings when you export the STL file.
In Solid Edge, you “Save as Translated” and under an “options” button you can change the “Tolerance unit” to millimeters. The resulting STL files have imported to all the tools I’ve tried without problem. (CURA, Repetier Host/SLIC3R, and MatterControl at least)