Question - Issue with printing filament

Hi all,

I am new to the forum so hopefully I am in the right place. I have a question about a print on my Lulzbot Mini: As you can see from the photos, I am experiencing an issue where the print does not come out as shown in Cura. Specifically, the inner walls of this airfoil are not printing all the way to the outer walls and connecting. The outer wall is supposed to be one 0.5mm layer, and the inner walls are supposed to be two 0.5mm layers (1mm total.) The behavior of the outer wall is fine, but the inner walls aren’t reaching through.

My first thought is there is an issue with retraction, but when I turn it off the print is even worse.

Any thoughts? Thanks for taking the time to help.

It is supposed to look like this (can only post one image for some reason.)

I’m wondering if the area where the wall is incomplete is the beginning of the print direction vs. the end.

I also wondered about retraction & re-prime settings and/or if you are using “coasting” in Cura and/or if you’ve enabled “linear advance” in the printer firmware.

Hi Tim,

Thanks for your input. I looked into it and it appears it is at the beginning of each nozzle movement. That leads me to believe there is a semi-consistent extrusion lag after retraction. Any suggestions on how to address this?

Thanks again.

I can think of several things that might be happening… but can’t be sure what is happening.

One of the issues with 3D printing is that you are melting a solid filament into a melted state and in that melted state it takes on some gooey/elastic properties where it is a little compressible or stretchy. This creates a bit of a delayed response to when you tell it start printing vs. stop printing.

Several settings are meant to help you deal with this gooey state. These are settings such as retraction (& re-prime after the retraction) as well as “coasting” (in Cura) or “linear advance” (in firmware). Both settings tell the printer to stop pushing filament into the hot-end just a very short distance before the end of the printed segment.

Normally if I’m printing something like PLA … the retraction amount is set to either 1 or 1.5mm (and the re-prime amount matches that). Retraction isn’t so much intended to pull filament back into (reversing the flow) … it’s more meant to take the pressure off the melted filament so that it does not continue to ooze out.

If the retraction amount is too high then it’s possible to pull in an air-bubble … but considering the temperature of the hot-end, the air-bubble will expand and this can pop a break in the filament as you extrude.

On the other hand… if you don’t retract enough (before a move to a new start point) then the filament might ooze resulting in a thin string (like spider web silk).

I’m going to guess that this is your issue … but I may be wrong.

What filament type are you using?
What retraction & re-prime amounts and speeds are you using?

There is another setting in Cura called “print thin walls”. Suppose you own a printer that has a 0.5mm diameter on the extruder nozzle (Lulzbot makes other nozzles so I’m just using 0.5mm as an example) … and suppose you have a 3D part that calls for printing some detail at .4mm wall thickness. Since the wall thickness is THINNER than the filament thickness… Cura will not bother to print that section of wall … at all. This can result in a gap in your print. The “print thin walls” settings tells Cura to print the wall anyway… even though the filament width is thicker than the dimension intended for the wall. Basically you are telling it to just go ahead and print as thin as the extruder will permit (even if that thickness is more than the part calls for).

Hi Tim, thanks again for your help and interest.

I tried printing a few more times with a few tweaks. The retraction settings are:


The “thin wall setting” is a good suggestion, but I don’t think that’s the issue since I checked that the settings are correct. Also, the preview in Cura looks correct so there shouldn’t be any issues there.

One thing I am sure of is this is happening at the beginning of each segment rather than the end. I suspect it could be a mechanical issue rather than a software one. I tried tightening the hobbed bolt as much as it could go and made sure things are relatively clean, but still the issue persists.

I tried raising the temperature (printing PLA) from 205F to 220F which helped a little, but the problem still persists and the print quality is still horrible.

Clearly, the problem is that at the beginning of each segment, filament is not being extruded right away. Unfortunately, this renders the $1K printer completely useless which is frustrating.

Another thing worth noting is that even in a straight line, there are sometimes “gaps” where the printer stopped extruding, and the quality of the straight lines is sporadic.

Any other thoughts? The printer hasn’t seen much use although it is an older design. However, it should still be able to print basic shapes without an issue like this.

There are several possibilities. I might suspect a dirty feed-gear (hobbed gear); bad idler-arm tension (the springy arm that presses the filament against the hobbed gear); or bad e-steps calibration.


The printer uses stepper motors not just to move the X, Y, & Z axis… but also to advance filament. The filament is axis “E” (for Extruder). The printer was calibrated by factory testing how many “steps” it needs to send to the stepper motor to advance the printer by some given distance (on each axis).

If the printer isn’t correctly calibrated, it can result in either over-extrusion or under-extrusion. If you are getting gaps as it prints along a path, it may be caused by under-extrusion.

Under-extrusion isn’t necessarily caused only by not having correct e-steps… it can be caused by a dirty hobbed gear (the feed gear that has the “teeth” which pushes the filament into the print-head). A loose idler arm (the tension you set to press the filament against the teeth on the hob gear) can affect this setting. Sometimes different filaments can effect the setting. TPU are “flexible” filaments (they seem rubbery) and do not advance the same as more rigid filaments.

Before you tweak too much … it isn’t necessarily a requirement that you re-calibrate your e-steps frequently. This is something most people only do occasionally.

IF YOU REFLASH YOUR FIRMWARE … you should first note your current settings (write them down) because re-flashing usually wipes out previous settings. The printer would have been factory calibrated, but re-flashing can wipe that out.

Also… make sure the hobbed gear is clean of filament. If filament starts to chew up (common anytime a part has a lot of retractions in a short distance), the chewed filament will start to clog the teeth. I keep a can of compressed air next to my printer. A few puffs will blow the filament off the teeth (the filament was “cold” when it was being chewed … so it wont be stuck to the metal and is easily blown clean).

Set the idler arm tension to be moderately tight. You don’t want to under-tighten (which can result in slipping) or over-tighten the tension.

Next… in the Cura “Material” menu, you’ll see a setting for something called “Flow” (flow rate). This shows up on your printer as the “Fr” on the mini LCD panel. Normally the value is set to 100 (100% flow based on the e-steps calibration). If you think the printer is under-extruding, but you know you’ve calibrated e-steps, your idle arm tension is good, your hob-gear is clean, etc. … then it may just be that the filament you are using needs a tweak to the extrusion rate. This setting will let you do that. Make tiny adjustments … e.g. instead of 100% … maybe you try 102% (if you go too high then it can over-extrude and cause problems elsewhere in the part.)

How to calibrate:

See this page:

You can also find numerous YouTube videos that walk through the process. Basically the idea is to order the printer to extrude a known length of filament (this is the “cold” 2.85mm side … not the post-extruded side). You ultimately want to know how many steps are needed to extrude just 1mm. But that’s hard to measure accurately. So instead you extrude 100mm of filament, and measure how accurately the printer does this … then increase or decrease the e-step value accordingly. E.g. if I ordered it to extrude 100mm but it really only extruded 98mm … then it is under-extruding by 2%. 100 ÷ 98 = 1.0204 … so you’d multiply the current value of e-steps by 1.02 to arrive at the new value and program that as your new e-steps value.

Different materials might advance at a different rate depending on how far the teeth in the hobbed-gear can dig into the filament (the hardness and flex of the filament). But it isn’t usually necessary to re-calibrate e-steps for every new type of filament. Set it based on a filament you use most often (e.g. suppose that’s PLA) and if you decide to print something else you can tweak the flow rate if needed. But don’t tweak anything unless you are sure your feed gear is clean and your idler arm tension is good.