Remove autolevel from gcode

I’ve been having all kinds of trouble with really every part of the print procedure on my Lulzbot Mini 2 that comes before the actual extrusion starts.

I think I could get around 90% of my issues if I just ran a level X axis at the start then input a manual Z calibration level.

I tried stripping out the wipe and autolevel commands from the gcode but then the printer started the job about a centimeter above the bed.

Does anyone know how I can amend my gcode to be at the correct z-offset?

I’m curious to know if this works too. I’m guessing there’s some firmware tinkering that needs to be done too.

Take a look at this thread (via Wayback machine, live site appears to be gone):
https://web.archive.org/web/20191014153109/https://code.alephobjects.com/T1506

The last comment from Marcio, Lulzbot’s Marlin developer, says it can be done in later firmwares (i.e., complete a G29, save the results with M500, later restore them with M420 S1 instead of having to G29 again.

Unfortunately, the last comment in that thread is from a user who tried it on a Taz Pro and couldn’t get it to work. But you might still give it a try on the Mini, and paying attention to the firmware versions mentioned in the thread.

1 Like

There is a setting on the mini 2 screen for probe z offset. Is that set correctly? mine is like -1.4? (which is the distance from the top of the washer to the bed I think) Or are you saying that without the leveling operation it won’t get lower? I’ve never had a problem with my mini 2 start up g code with added x leveling.

Monty