Skirt doesn't start printing until most of the way round

Thanks to help yesterday on this forum, I’ve upgraded the Cura software and firmware to 2.6.64 (Windows 10) and made several satisfactory prints.

I have one small remaining and repeating problem.

The skirt doesn’t start printing (nothing comes out of the nozzle) until the printer has almost completed its first circuit (on a larger print) or the second circuit on a smaller one with two rows of skirt material.

And when it does start, it doesn’t adhere well, and leaves a loose strand which can catch (I try to pull it off before that can happen, so far successfully).

This has happened both when I start a new print without turning the printer off after finishing the previous print, and from a ‘cold’ start where the printer has been powered off before starting.

I’m using the settings for ABS (IC3D) with material from MG Chemicals, which says it has the same temperature range settings - Hot end 230-240C and bed 90-110C.

I’m using the defaults from IC3D: 240C and 105C. The printer gets up to temperature before starting. I’m using the medium speed Standard profile.

Is the start code not ‘priming the pump’ soon enough? Filament not hot enough to extrude?

Any advice for how to get the printer to start sooner?

That’s pretty normal at the start of the print. At the end of the print the filament retracts a bit. At the beginning of the next print the nozzle needs to prime itself, hence the use of a skirt or some other mechanism to ensure filament is ready to extrude at the beginning of the object. It takes 10-30mm before the extruder is ready to print… so if the object is small, it may not print the skirt or as in your case not print most of the way around.

Better to half print the skirt then lose a few mm of the beginning of a print…

There are other situations where this may happen often due to the bed not being level. Using a low layer height like .1 or .15 may also affect this. But in most cases its just priming the nozzle.

So nothing to worry about? Normal behaviour, it sounds like. Thank you for the reassurance.

The bed seems level - the first layer of prints is quite even.

What about the loose whisker - just keep picking it off?

I have the same issue. I see in the Start G-Code where it is says to retract it
"G1 E-30 F75 ; retract filament "

then it cleans the nozzle and does a few other things but never primes the head again but putting it back the 30 it removed.

“G1 Z2 E0 F75 ; prime tiny bit of filament into the nozzle”

I’ve tried to let the software update the firmware but it keeps saying 'not responding" . I’m going to try to update the firmware manually and then see what happens but it may be as simple as put some filament into the nozzle before printing…

Edit: So I figured out the problem with the firmware updating and I had it “connected”. I printed a 50% scale Octopus with skirt and it worked perfectly. Very excited with the outcome. Now off to learn how to model!

!f you’re worried, always print with brim. Brim also helps “clean out your nozzle.” the last thing you need is mini purple things randomly showing up on a whit lithopane. The skirt thing is normal.

Some smart person (I don’t recall who) told me the secret in Cura last year. Click the … button after the Platform adhesion type in the Support section (on the Basic tab), then set Line count to 2 so you spew more filament before starting the real print. I was having problems with my small parts missing sections of the first layer because the nozzle was not fully primed at the start. You could also try messing with the Minimal length (mm) to tune it up better as well.

So nothing to stress over? Ordinary conduct, it sounds like. Much thanks to you for the consolation.

The bed appears to be level - the primary layer of prints is very even.

Shouldn’t something be said about the free hair - simply continue picking it off?

I have found this to happen to me as well.

An interesting experiment is to draw a mark around the filament where it enters the extrude head. Then watch as the filament retracts and feeds during the nozzle clean and the start of the print.

Most of the time the filament does not feed back into the extruder as far as it retracted before the nozzle cleaning. Often the slack is taken up during the printing of the skirt. Other times it take well into the first layer before the filament is feed all the way back into the extruder.

As with my bed leveling issue this seems to work best after a fresh restart of both the printer and cura. The problem seems worse after subsequent restarts.


The default start gcode assumes the nozzle has been primed and the default end gcode retracts some filament to prevent oozing.

This means that between each print, the nozzle needs to be reprimed (i.e. manually extrude some filament).

In the start gcode for the Dual Extruder V3, LulzBot added a “Purging” section which I have adopted for all my start gcodes. I don’t have a Mini but I believe something similar will work (after adjusting the coordinates of the edge of the bed).

Replace at the end of the Mini start code:

M109 R{material_print_temperature} ; wait for extruder to reach printing temp
M190 S{material_bed_temperature_layer_0} ; wait for bed to reach printing temp
G1 Z2 E0 F75 ; prime tiny bit of filament into the nozzle
M117 Mini Printing... ; progress indicator message on LCD

With this (adjusting the X and Y as noted):

M109 R{material_print_temperature_layer_0} ; wait for extruder to reach printing temp
M190 R{material_bed_temperature_layer_0}  ; wait for bed to reach printing temp
G1 X100 Y-17 Z2 F3000    ; move to open space (adjust X and Y for a convenient place just off the edge of the bed) 
G1 E0 F100               ; extrude filament back into nozzle
M117 Purging...        ; LCD status message
G92 E-25                  ; set extruder negative amount to purge
G1 E0 F100               ; purge XXmm of filament
G1 Z0.5                    ; clear bed (barely)
G1 X100 Y0 F5000     ; move above bed to shear off filament (adjust X and Y to match above but just over the edge of bed)
G1 Z2 F100               ; move z up
M117 TAZ Printing...     ; LCD status message

The move to open space command can actually replace the move in front of the wiper pad.

I have increased the skirt line count to 3 and the minimum length to ensure that while my skirt may not start on time, it is for sure finishing at least one full trip around the part while properly extruding filament. Be aware that for very small parts, the minimum length may result in a lot more lines than 3.

Thanks that works perfectly.