Slic3r Problems

I have been experimenting with rafts attempting to improve the first layers appearance in my parts, but I am finding a strange problem in the Slic3r generated gcode when using a raft. There is a one layer gap appearing between the raft and the first layer of the part. It causes the first part layer to be printed in mid air, so its finish and adhesion is far from stellar to say the least. I have fiddled with all the settings in the support material section trying to get the gap closed, but to no avail. I have attached a screen shot of the gcode gap for reference. I am using a 4 layer raft with 1 layer of interface, 1.5mm spacing.

Has anyone seen this before from Slic3r? Is this a settings problem on my part, or is the software faulty?

Thanks for any insight anyone might offer.

Is there something wrong with the “bed” you’re printing on?

When you say “improve the appearance” what exactly do you mean? What’s wrong with the appearance?

What printer are you using and what material are you printing with? Taz4 and ABS? Heated bed? PET sheets on glass with lulzjuice (ABS/acetone mixture)?

My first layer, using ABS and a Taz4 printer always looks the best in regards to smoothness. As long as I don’t have any edges that lift off bed during the process. I’m also using Slic3r and Pronterface with the ABS profiles that lulzbot recommends.

In fact, my instruction book for the TAZ4 recommends NOT using rafts.

You’ll find that printing with a raft is un-needed these days. Mind posting a image of some of the prints you’ve been getting (and the first layers in question)?

Thanks for the responses, but being told I don’t need a raft is not exactly what I was looking for.

I was attempting to get a surface texture similar to that from our Stratasys system at work and experimenting with the raft for that purpose. I noticed an anomaly in the gcode that does not seem to allow the print to rest on the raft. This is causing the first part layer to string and not adhere very well to itself, the raft or the second layer. I am just trying to determine if there is a setting I’m missing, or if Slic3r has a problem. I have noticed the same gap in MatterControl, so I’m thinking now it is a setting, but which one?

I am using a TAZ 4 printing ABS on the PET surface 225°C/80°C without a raft too, but seem to have either a gap, temperature or extrusion problem as my first 4-5 layers are always overly melted and very sloppy. Layers after that look fine. My bed is at 80°C as the center of the bed reads about 10° hotter than where the sensor is located. I use the gluestick method (Elmer’s) to help adhesion, but find the parts stick so well that I’m tearing the PET trying to remove them. If I don’t use the stick they get knocked off after a dozen layers or so.

I am using the recommended Slic3r settings for medium extrusion, support off, with the temps and raft settings different. I also set 3 perimeters and infill at 60% (Structural part. Needs to be compression resistant.)

Haven’t tried the ABS glue method yet. Any info on the proper mix ABS:Acetone for that preparation?

I have ordered the PEI materials for the surface upgrade and am looking forward to trying that option for adhesion.

I am currently not located where I can get photos of the above issues, but I will upload some as soon as I can.

Thanks for your help.

Hmmm…so I assume you don’t want a smooth shiny finish on the first layer, and might be wanting something more textured?

I only print ABS using a TAZ4, Slic3r, and Pronterface. Plus, I only use the profiles for ABS that Lulzbot provides.

My bed temp is set to 95c and extruder at 230c. I don’t have the issues you seem to be having with melty sloppy stuff. I wonder if your extrusion speeds and/or feed rates of ABS are too fast or too slow?

I had some problems with gaps between layers but now that I’ve enclosed my printer to trap in some heat and prevent cooler air from blowing across parts those problems seem to have disappeared.

For my Lulzjuice I filled bottle I got from Lulzbot with acetone, then cut about 10 to 12 pieces of ABS just long enough to fit inside bottle with lid closed. Shook it. Let it sit over night. Use it like somebody else is paying for it. :smiley:

Pictures of what you’re looking to achieve, and what your getting now would be a big help. Probably not from me since I’m an ultra-newb, but surely somebody else could help.

Are you printing on a TAZ4? Are you using the Lulzbot provided profiles for ABS? Is your printer in a drafty cool area and open to drafts and cool breezes?

I added a few comments to my original response to the response, so I will refer to that for some of the answers.

Yes I have a new TAZ 4 I’m playing with. I have a heated room that I print in, so I don’t THINK I have a draft problem, but… I have only had one print split on me, so I think I’m OK. (That one I had a liquid discharge from a Dust-Off can. Think I cooled it a bit quick.)

Yes. I am looking for a somewhat cloth like texture to the first layer. Hoping the raft would accomplish that like it does on the Stratasys.

I use the recommended Slic3r ABS medium, no support settings except for the temps and raft settings and I also move to 3 perimeters and 60% infill. I need a very compression resistant part. May go even higher on infill.

Strangely, Sli3er makes rafts that I cannot remove with a jack hammer, while MatterControl with what appears to be the same settings makes rafts that look almost identical and peel right off. Same stringy first layer problem though.

If I set Slic3r so I can remove the raft easily, the first part layer looks like a Salvador Dali painting. It is only a little improved with MatterControl.

If anybody has a suggestion I would appreciate your comments.

Oh, thanks for the lulzjuice formula.

Can you flip the part over so the surface you want texture on is the last surface to be printed, and not the first surface printed?

Or, can you modify the model and add some desired “texture lines” before you bring it into Slic3r?

No, I can’t flip it. It has pockets in the top surface that would require support material, but need to be precise, and cleaning out the material would be extremely difficult. (Unless I had a dual extruder with HIPS support - hint, hint.)

I think if I could get the raft and first part layer to cooperate that would solve the whole problem. I just don’t know what slic3r settings to tweak to accomplish that.

I think the code for the gap is generated intentionally so as to make it easy to remove from the part from it after the print is finished. Without the gap, the raft becomes part of the print (sort of).

That being said, this is free hardware – if you don’t like the way it’s behaving, change it! I think you could insert the following code into your .gcode file immediately before the first layer of the part to remove the gap.

G1 Z-[gap-between-part-and-raft]

Where [gap-between-part-and-raft] would be replaced by the actual gap in mm.

Hope this helps,


My only other suggestion would be to modify the part file and add some sacrificial 1/4 inch standoff “feet” to the outside perimeter of the overall part, creating a gap under the area you want textured, then use the “auto-support” profile.

After part is printed you cut off the “feet” and remove the auto-support material and you should have some texture to that surface.

Thank you zero. I will give that a try. Do you know if there is a setting in slic3r or MatterControl that mimics that command? Would that be the Z offset, or is that something different?

Thanks edlink. I’ll see what I can work out. Still struggling with quality of print for first 4-5 layers as of last night. Not sure exactly what to fix there.

Does anyone have a good reference document for the gcodes? That would be a BIG help in interpreting what the printer is doing.

Thanks for the help guys.

Aside from the “texture” issue on the bed-side of the first layer, what’s happening on layers 2,3,4, and 5 that you don’t like? Pictures?

And do layers 6 and up seem to work out as you expect?

OK, so here are some pics of my raft attempts and my smooshed first several layers. I have been slowly raising my Z stop and this is improving a little, but I am about at the point where the first layer is not adhering to the bed and still seeing this way more than the parts used in constructing the printer. What do I try next?

Thanks for the help.

From those pictures you have a couple things going on. For starters, it almost looks like the plastic you are trying to print is PLA, not ABS. It could just be an unusual color for ABS or the lighting, but you may want to check that what you have matches your printing settings.

Next, I’d be concerned about your belt tension in one of the X or Y axis. the holes there seem to be a bit out of round, which can sometimes indicate a loose belt.

Your next issue seems to be your extruder calibration. It looks a bit to me like you are under extruding slightly. I’d check the diameter of your filliament, and adjust the filliament value inside slic3r accordingly, and then maybe run through some of the extruder calibration routines.

Hmmm… It’s supposed to be White ABS. How do you tell if the label is wrong? Smells like ABS when it’s extruding. I’ve never used PLA, but am told it smells like warm sweet corn.

The belts seem tight. How does one measure them for correct adjustment? I have noticed a significant amount of wobble in my print bed however. It is quite sloppy on the guide rods. I will try some repositioning of the bearing blocks to reduce the wobble and see if that helps.

Thank you for the extruder calibration suggestions. I will try those too.

If it smells like ABS, it probably is ABS then. It’s just a rare-ish color to see.

Belt tension can be measured a variety of ways. I personally think that you can’t have too much belt tension unless it is snapping the belt or bending machine parts. If you pluck it like a guitar string, it should make a snappy twang sound rather than a dull thud. If you hang a small weight from the middle of the belt, it should not deflect much.

The guide rod movement is not normal. the bed carriage should have almost no wobble in it at all, and that might be part of the issue. There have been a few isolated reports of overly loose fitting bearings. You may want to check that as well.