[SOLVED] Done Goofed and now my printer won't turn on


So I’ve been having a bad time with my TAZ 5 which I bought last year - My prints have been looking horrible due to ineffective part cooling which I have tried to rectify but haven’t had success. My solution was then to double up the fans but I only had 12V fans and a little buck converter but, like a fool, I installed the converter backwards and then when I turned the fan on, everything shut down.

I am still getting 24V in at the blue connector that comes out of the power supply but the LCD isn’t coming on and if I move the bed, it doesn’t flash either. I’ve opened the electronics control box and the big blue 15A fuse is still fine and nothing smells of smoke but no LEDs on the board go on. Have I fried my RAMBo?

Any ideas?

You have probably blown one of the other two rice grain fuses near the big blue bed fuse. The other is near the power connector going to the RAMBo.

Yep, looks like it you’re probably correct. Fuse F3 is reading what appears to be open circuit which is a positive sign I guess.
Further retardation is that while I unplugged the power, I forgot to unplug the USB cable when I first tried to remove the fuse and so there was a spark. I hope that I didn’t kill the board with that dumbass maneuver.

I can’t get hold of the 0488005 fuses where I am but it seems that the 0451005 should do fine so I’ll order some of those and hopefully I’ll get them by Wednesday at which point, I will be able to give some feedback

I got hold of “Conquer” 5A fuse which was a good enough match for the “Littlefuse” which he RAMBo comes with as standard.

Everything seems to be working now. Good call kmanley57, thanks.

What a relief - now back to figuring the cooling :stuck_out_tongue: