[SOLVED] Lulzbot mini stopped connecting

SOLVED - setting the Baudrate to AUTO brought everything good. I thought I had it at 115200 before, but it’s fine now with AUTO. I do get this message from Cura:
[‘ValueError’, " ‘Failed to set custom baud rate: 250000’ @ machineCom.py:_setBaudrate:555"]

but I can live with that.


Hi
I got my lulzbot mini today, and managed the first Rocktopus print. I switched the printer off, removed the USB cable, and left it for half an hour. I came back, plugged the USB back in (I’m using a powered hub), powered up the printer, and tried to print something else. But now, when I open the control window, it says “Connecting”, the mini goes silent, then the fans on the mini spin up as if it’s turning on, then they spin down and about ten seconds later the control window says “Closed”.

I’m using Debian Jessie - dmesg notes the first power on of the mini, but doesn’t have disconnect/connect messages for the connection attempts, so I don’t think it’s resetting. But that’s what it feels like. When the mini goes silent, the light by the USB port inside goes orange, flashes twice, then goes green when the fans spin up again.

Like I say, the initial print of the rocktopus worked fine, so the USB hub is ok, but now nothing connects.

Edit: Just tried another USB hub, same problem.