TAZ 4.1 extruder motor problems

My TAZ 4 (stock, no modifications) has been having extruder problems for some time now. The first few layers of a print are fine, but as the print proceeds it has more and more problems feeding filament. While feeding, it frequently makes a loud “buzzing” noise and you can see the large gear stop turning and backlash a small amount. The stop/backlash is also visible on the smaller gear and the shaft of the motor. The problem gets worse as the print goes on.

When the problems first started, support suggested performing some cold pulls, but that did not help. I’ve since taken apart the extruder twice and thoroughly cleaned it. After cleaning, the tube, heater, and nozzle have no obstructions, and with tension removed from the hobbed bolt I can easily extrude material by pushing filament into the hot extruder.

I’ve bought a new roll of PLA filament (eSun PLA+) to replace my old roll of Gizmo Dorks PLA, and that did not help.

After running some more experiments, I’m beginning to think either there is a problem with the extruder motor or the drivers on the rambo board.

What I’ve observed is:

  • Towards the end of a print, the temperature of the extruder motor is as high as 190F. That seems excessive. That was with the extruder set to 210 (recommended print temp for the eSun PLA+)
  • When not printing, extruder heater off, cold extruder lockout disabled, no filament installed, I can continuously run the extruder motor and no amount of pressure I apply to the large gear will stop the motor. It has gobs of torque, as expected.
  • If I let it sit with the extruder hot (210) and perform the same test, I still can’t stop the motor.
  • If I run a real print, once the noises start happening and the motor is hot, I can press my thumb on the large gear and stop the extruder motor or sometimes rotate it backwards. At some point it seems the torque of the motor drops dramatically.

I’ve now zip tied a 40mm heatsink and fan to the side of the extruder motor. The motor temperature has dropped to about 100F, so that’s an improvement, but the problem still remains. There appears to be a significant loss of torque mid-print.

What can I do to diagnose this further? Does it sound like the motor needs to be replaced? Or could this be a problem with a bad driver on the Rambo board (it’s a 1.3L version I think).

Looking at this thread, a failed driver isn’t unheard of: https://forum.lulzbot.com/t/weak-slipping-extruder-motor-w-temp-fix/1311/1

I have not tried rebuilding the firmware to use the second extruder port yet, but I can.


When I encountered the issue you are encountering, it was a short in my wire harness to the extrude. Whenever the harness flexed at full x max, it would lose one of the magnet pairs and most of its force. I replaced the motor and the wire back to the board and it was fine. I don’t know if the short was in the main harness for sure, trying different motors didn’t seem to help at the time but I later discovered one of the test motors I tried also had a short in its small harness. You are most likely encountering something similar.

Well, I’ve disconnected the cables at the controller and checked for shorts and breaks (both flexing the cable a lot and moving the X axis) and found no problems.

Also checked for shorts and breaks on the stepper motor, first when it was cold, and then when it was hot and failing, no problems there either. 2.8 ohms on the coils when cold, about 3.4 when hot (~140F on the top surface of the motor).

I did discover then when I powered it back up and re-engaged the motors (still reasonably hot), I could no longer rotate the large gear by hand. Motor had full torque.

I normally print with Simplify3D, but just for fun I’m trying a print with the latest Cura just to rule out software as a culprit. If that fails, I guess I’ll try moving the motor to the other extruder port on the controller and see what happens.

I rebuilt my firmware to swap the extruder motor to E1 on the controller and I got a flawless print. I guess that means there is an issue with the driver on the controller.

I’m glad I can print again, but I was hoping the problem would be the inexpensive motor. I guess I’ll need to replace the controller or learn to do SMD rework before upgrading to a dual extruder…

swap that cable to the other board header and try it again?