Freezing/stops mid print [SOLVED]

Hi,

Had my RAMBo repaired (Taz 4) for a blown extruder mosfet last year (out of warranty now). Looks like I’m having the same issue, extruder motor completely stops mid print (manual jogs don’t work as well). Seems to work again after power cycling the printer.

Lulzbot support previously told me I can use the 2nd connector on the electronics case (the one for the duel extruder). I just have to upload a certain firmware.

Does anyone happen to have a link for that or know what to change in the firmware code?

Thanks!

EDIT: Swapped out the Rambo and upgraded the extruder to the hex extruder. Still have the same issues. It may be the power supply fan that went out. Read several posts with the same issue and it was resolved with a new power supply.

EDIT: Replaced the power supply with the new version Lulzbot sent. Working fine so far. Looks like that was the issue :smiley:

I have not done this, so please take this at the value you paid for it. :slight_smile:

I would start with the pins.h file. search through the file for the Rambo pin assignments.

I believe that you will need to swap the E0* assignments with the E1* assignments. You will also need to swap the HEATER_0_PIN and TEMP_0_PIN assignments with the HEATER_1_PIN and TEMP_1_PIN assignments.

The naming (and comments) on the fans is a little funky. I believe that you will want to swap the values for FAN_PIN and FAN1_PIN

Save your original pins.h file so that you have a fall back and good luck.

Thanks for the info!

I’ll look into it and report back.

Agree with the prior post about tweaking your firmware, as going to a dual extruder firmware will also (I think) require adding a 100k resistor across the thermistor pins for the unconnected extruder to give the board a dummy input for the second thermistor, otherwise it won’t heat.

To answer your original question though- Based on your warranty comment, I’m guessing you have a TAZ 4 with Budaschnozzle?
If you have Cura 17.10 or newer- Machine> Add New Machine. Choose the appropriate printer and dual extruder hotend to match you current hotend (V1 for TAZ 4/Buda, V2 for TAZ 5/ Hexagon), then flash the firmware when prompted.
Or there’s the manual Cura method https://www.lulzbot.com/learn/tutorials/firmware-flashing-through-cura

So I got it working with the second extruder header on the rambo but still ran into the same issue (extruder motor stops moving eventually). I guess we can rule out the mosfets. I also noticed a weird stuttering with the extruder motor randomly during print. The gears are meshing fine and I can manually rotate the gears with little force. Tugged on the wire harness a bit as well. I already ordered the V2 hotend (been wanting to upgrade anyways).

Any other ideas?

Thanks

Wierd stuttering is often an indicator of a short or a reversed wire. Basically you have 4 wires going to a stepper, 2 per magnet. If one of the magnets failes, or if one of them shorts to where the magnet is actually in polar oposition to the other magnet, you get effects like that, Or if one pin falls out of the motor and the other 3 are still attached, etc. It can also be an indication that the motor controller on the rambo board is getting too hot or failing.

Oh I see, makes sense. Now that you mention it, if I restart the printer I can jog the extruder stepper. It runs for a while too.

Is there some kind a resettable fuse in the motor driver/controller circuit that trips at a certain temperature or current? Which then resets when it’s powered off? Anyways if the new extruder head has the same issue, new rambo it is I guess :astonished:

Anything I can do to isolate the problem in the mean time?

Thanks for the info

There is a thermal protection circuit inside the driver chips. So if they get too hot it stops driving the motor, and has to cool to a certain point before it allows the stepper to be used again. You may need to place cooling fins on the driver chips, or improve the flow of cool air into/out of the control box.

that or your control box fan may not be working.

That must be it then.The case fan is running fine. It still may be my extruder because the same issue is happening even after switching extruder headers on the rambo. It must be drawing too much current or causing a short somewhere. I’ll pick up a rambo and try it out with the new extruder. I don’t see the point in adding a heatsink if lulzbot didn’t put one there to begin with. Then again, I just ordered some vibration dampers for the motors that weren’t put there by lulzbot :smiley:

Thanks again.

I print long duration prints on the stock Taz 3 enclosure and fan, which is actually smaller than the Taz 5, with no ill effects. They should be fine unless you are in an unusually warm space, or have the electronics in an enclosure without venting. Heat syncs can help if it is a heat issue, but they shouldn’t normally be required. They also don’t hurt anything either.

We just got mosfet coolers in http://i-t-w.com/parts/heatsink-for-mosfets-9x9x5mm

Replaced the rambo and upgraded the extruder. It’s printing like a champ now. It printed 18 hours straight with no issues and started more prints.

Those heatsinks seem like a good idea but then again “Piercet” has been using a taz 3 with no rambo issues so far.

Do you just use heat transfer tape to mount them?

Quick question. Is the electronics case fan supposed to be pulling air out or in?

Pushing cool air in. The bracket side should be towards the Rambo blowing air directly on to it.

That or permanent thermal transfer epoxy. Article silver makes a good one.

Thanks!

So I spoke too soon, doing the same thing again. Tried both usb and Sd card. With the sd card it just freezes, and nothing is responsive (brand new lcd btw)

With USB it continues the print but the extruder stepper stops.

All I can think of is the wiring now…

I’m trying another SD card with a different stl file.

So I tried a different file to print, different slicer and SD card. The print still freezes about 4-5 hours in with the LCD controls being non-responsive. Works again after turning the printer off / on or plugging in the USB and connecting. Noticed the power supply fan doesn’t power on anymore. Lulzbot support is awesome (as always) and are sending me a replacement even though I’m outside the warranty.

Besides that I’m all out of ideas…

Any other suggestions?