TAZ 4 e3d - v6 and EXTRUDER_FAN_SETUP 4

Here is my setup
TAZ 4
e3d -v6 Hotend
and wired the hotend fan to extruder fan 2
and set EXTRUDER_FAN_SETUP 4
and left default settings for the extruder fan

Here is what I am experiencing, the hotend fan is now coming on at random for variable periods of time when below 50c, and it turns on when the extruder heats up to 50c

Now I have observed that when I unplug the temp sensor for the heat bed the random spin ups of the extruder fan when below 50c stop.

Any ideas on what is going on and how to stop the random spin ups?
Does it have anything to do with EXTRUDER_1_AUTO_FAN_PIN EX_FAN_1:

   // Extruder cooling fans
    // Configure fan pin outputs to automatically turn on/off when the associated
    // extruder temperature is above/below EXTRUDER_AUTO_FAN_TEMPERATURE.
    // Multiple extruders can be assigned to the same pin in which case 
    // the fan will turn on when any selected extruder is above the threshold.
    #define EXTRUDER_0_AUTO_FAN_PIN   EX_FAN_1
    #define EXTRUDER_1_AUTO_FAN_PIN   EX_FAN_1
    #define EXTRUDER_2_AUTO_FAN_PIN   -1

and that there are times that the temp for the heatbed sometimes appears to be registered as an extruder in different menu settings in the TAZ…

Update

So I updated the firmware and setting
#define EXTRUDER_1_AUTO_FAN_PIN EX_FAN_1
to
#define EXTRUDER_1_AUTO_FAN_PIN -1

Helped with random extruder fan starting.

I still don’t know why… but it works.

New odd behavior…

After re-flahsing I was going to run the PID autotune…

However after running the autotune command, it didn’t autostart the extruder fan…

New questions, is there a command that you can run to manually start the extruder fan?

For the utmost in reliability, I plug my hotend fan into a wall wart! It never turns off unexpectedly. :smiley: