Turning Second Extruder fan ON_TAZ 5

I am running STOCK Taz 5 Firmware. I have a 24V Fan setup directly to my second extruder fan port on my RAMBO as per: http://www.thingiverse.com/thing:945714.

Im trying to use M106 P1 S255 to turn on the fan, but it instead turns on the 2 side fans.

This command works properly with the TAZ 4.1 firmware.

Any help?

Ok i found this in the firmware under configuration.adv tab

// Extruder Fan Setup 
// If set to -1 all Extruder fans will be disabled
// If set to  1 only EX_FAN_0 will be used as a nozzle cooling fan for Extruder0
// If set to  2 EX_FAN_0 and EX_FAN_1 will be used as nozzle cooling fan and will switch between active nozzles
// If set to  3 EX_FAN_0 will be Contorled by M106 S255 and EX_FAN_1 will be controled by M106 P1 S255
// If set to  4 EX_FAN_0 will be used as a nozzle cooling fan and EX_FAN_1 will be used as a heat sink fan
#define EX_FAN_0 FAN_PIN
#define EX_FAN_1 FAN1_PIN

    // Extruder cooling fans
    // Configure fan pin outputs to automatically turn on/off when the associated
    // extruder temperature is above/below EXTRUDER_AUTO_FAN_TEMPERATURE.
    // Multiple extruders can be assigned to the same pin in which case 
    // the fan will turn on when any selected extruder is above the threshold.
    #define EXTRUDER_0_AUTO_FAN_PIN   EX_FAN_0
    #define EXTRUDER_1_AUTO_FAN_PIN   EX_FAN_1
    #define EXTRUDER_2_AUTO_FAN_PIN   -1
    #define EXTRUDER_AUTO_FAN_SPEED   255  // == full speed

This line was changed from:




Now I can use M106 P1 S255 at the start of every print so the filament cooling fan turns on and not on always.
Problem now is, when M106 is in my GCODE, the fan starts, the print start, but then the filament cooling fan turns off right before first line.

something is turning it off even though im using it in my startup GCODE… any ideas?

Im sorry to post so much.

After all this work, Im just trying to avoid listening to my new 24V super powered fan EVERY time i turn on my machine… But i’m starting to wonder if this fan being on ALL (even when idling) the time is crucial to the hot-end performance.

Is controlling it via gcode stupid idea? Should i just connect the fan to the AUX 24v port?

It might be the extruder temp. is not up to the 50 C threshold. SWAG!

I most definitely tried heating the extruder past 50… lol.

PLEASE do not apologize! I was glad to find this thread and I hope someone will still respond to it. (It’s 02/2020) I have been switching out my RamBo 1.3L board for a new 1.4A (Ultimachine does not make a 1.4L) and cannot get the fans to work. In fact that is the main reason I switched out but I think I will be glad I did as the TAZ 6 and I believe TAZ workhorse use the same board. I am not sure where to plug in the extruder fan and the 5.5 volt hot end fan. The color code on the wiring is different on my printer than on the pics of the RamBo connections. The boards are mostly identical so can anyone show me where those connections are? https://www.google.com/search?q=RamBo+Mosfet+connections&rlz=1C1ZCEB_enUS807US807&sxsrf=ALeKk03Sv8GMBwE0iFHmPmo8DLp-KFXKIw:1582150556623&tbm=isch&source=iu&ictx=1&fir=9sg522AOevTU6M%3A%2CM9Ng5xbe6tuuMM%2C_&vet=1&usg=AI4_-kSv80qovROHthmeGfW3aIfigomk4g&sa=X&ved=2ahUKEwipgKKP0t7nAhXRGTQIHQs2AMMQ9QEwAXoECAoQBw#imgrc=9sg522AOevTU6M