Taz 4 not reading SD card

I recently setup up taz 4 and got it to work for the most part, i’m having problems with the LCD reading the SD card. on the main info screen, it says that the taz is ready, but when i click to the menu, it says there is no card. and when i try to read it there isn’t anything there. I’ve checked the card on my computer and its fine, i’ve also tried a different card and had the same results. I’ve just replaced the screen, thinking that it might be a problem with the reader itself, but no change.

Normally, i’m thinking that it wouldn’t be much of a problem, since don’t really plan on printing from the card much, if at all. but octoprint won’t connect, it keeps saying SD init fail. and disconnects. prontrface gets the same error, but ignores it. so i’m able to print through that. not too sure what else to check for a solution.

The SD card reader has a physical pin/terminal that reads the insertion of the SD card in addition to a read/write connection. If that pin is damaged (during card insertion) or if the wiring has a break/loose connection it won’t be able to read. If you don’t mind, with the printer powered down, unplug and reseat the two connectors on the back, and into the electronics enclosure. You’ll also want to reseat the connectors in the middle of the electronics enclosure (2 black connectors on a flat grey ribbon cable).

If you have any questions, or would like further assitance please send in an email to Support@LulzBot.com with the following information:

  • Order number

  • 3D printer serial number

  • Contact information

  • Shipping information



that was it, thank you. i reseated the connectors inside the enclosure and it started reading just fine.