SD Init Fail on TAZ 6

I get an “SD Init Fail” error whenever I insert an SD card into my TAZ 6. Printing works well with USB, but I need to switch to printing from an SD card now that computers in the makerspace are set to auto logout after a short period of inactivity and to generally free up the computers.


  • 7 different SD cards (that work in other devices) formatted using FAT32 w/ MBR from 2 GB to 16 GB capacity. Also tried making an 8 GB partition on a 16 GB card. I even tried inserting SD cards not 100% of the way pushed in as was mentioned a few places.
  • Bought a new RepRapDiscount Full Graphic Smart Controller and plugged it in but get the same result. So I don’t think the card reader itself is faulty.
  • Tested the continuity of the cabling that goes from the controller to the RAMBo and re-seated the connectors.
  • The TAZ 6 does recognize when the media is removed.


  • CuraLE 3.6.37 on an iMac MacOS 12.2.1
  • Firmware Marlin installed via CuraLE.

I couldn’t read an SD card when the firmware was at its previous version (1.19.34??) either. Using the old firmware, the main screen showed “Card Inserted”, but the the card couldn’t be read and when I scrolled down in the menus the last menu option said “No SD Card”. This 3D printer predates me in this makerspace so I don’t know when the last time the SD card reader worked, if ever.


SD Init fails when there’s also no card inserted. Is it a physical problem that’s preventing the card from being properly seated?

I’d still blame the cards. See if you can find the original card that came with the Taz to verify. I’ve got two cards that work for me, and quite a few that don’t work at all.

I’ve had the same issue on my 6. I found I could get it to work by pulling the SD card out slightly, then it was able to read it. If I fully insert the SD card it doesn’t work.

I had heard about the issue where some people had to pull the SD card out slightly to get it to read, but this didn’t work for me. I tried multiple times with different distances.

The SD card seems to seat well in the reader that was originally in the TAZ 6 and also in the reader on the new controller that I bought. The original SD card that came with the machine is long gone, but I ordered a new card to test and will update if this post if it works.

The new SD card didn’t work.

Pinpointing the exact place where the printer is unable to read the SD card is not always an easy task.
The issue you are experiencing could be one of four things.

  1. Bad SD card
  2. Bad LCD cables
  3. Bad LCD
  4. Bad control board

It looks like you have tested basically everything that could be the issue besides the actual RAMBo itself. Unfortunately, it looks like that may be the cause of the issue.

Something you may want to look into if you want to print without a computer is something like OctoPrint. You can print remotely without having your main computer connected to the printer.

Do you think that it would be worth it for me to change firmware configuration settings? On various forums, I see people try changing settings like SD_SPI_SPEED, SDCARD_CONNECTION, and SPI pin settings like SDSS. I’d assume that the Lulzbot official firmware has these settings correct, but then again, my SD card isn’t working, so it might be worth a try.

Solved. The 8-pin connector on the cable from the Full Graphic Smart Controller was plugged into the wrong header on the RAMBo. I moved it to the SPI Header and printing from the SD card works.

1 Like

I’m having this same issue. Is it possible for you to take a picture of what you moved around? Maybe that will help me fix mine as well

One connector was mistakenly plugged into the header marked “Analog”. That connector should have been connected to the headers marked SPI.