Taz 5 ABS over extruding issues

I have a Taz 4 upgraded to Taz 5 with Aerostruder, PEI bed, and enclosure (~93-105F inside). I have been printing exclusively ABS for years quite successfully but fairly recently updated the firmware and Cura.
I reuploaded the E-steps/mm cal, and recal’d and verified it (within 0.7mm of measured).
I am getting severe overextrusion. I have tried a few things.
It also seems that the acceleration in the latest Cura settings are using is audibly and visually much higher than previous settings.

I have tried a few things to resolve it but does anyone have suggestion for steps to take to get this back under control.
thanks in advance

It may be the Z motion is not what it should be? The test roctopus was about 13.5mm high when the full one should be ~18.5 from memory. L & R Z-stepper motor positions were leveled after that but weren’t much off.

Measured the Z movement over 100mm and it is close (within a few percent), so I don’t think it’s a significant z calibration error.