Taz 5, Aerostruder 1.75mm tool head, no filaments showing up in Cura

We upgraded our Taz 4 to a Taz 5 and installed an Aerostruder v1 tool head for 1.75mm filament.

Unfortunately, setting up the printer and specifying that this particular tool head uses 1.75mm filament causes Cura LE 3.2.32 to hide all materials.

Trying to create a new filament profile crashes Cura completely.

I’ve tried importing some profiles from https://github.com/Ultimaker/fdm_materials/ and Cura says they import successfully but they’re still not showing up because something specific about the machine profile names for whatever Cura LE is looking for don’t exist in the github profiles.

I changed my printer settings to 2.85mm filament, went into the filament manager and was able to export the Verbatim PLA profile, then, in a text editor, changed the filament diameter in the file to 1.75mm and THAT imported just fine and shows up when I changed my printer profile back to 1.75mm filament.

But what a freakin’ hassle to have to do that…

Where are we supposed to get Lulzbot-perfect .fdm_material files for 1.75mm filament?


I was able to run a ‘sed’ command on my own Macbook to get filament profiles to show up working by replacing all instances of “2.85” with “1.75”… but there’s no way we can scale this for our students trying to slice models to print on our printer, so we need something WAY more user-friendly than opening a terminal and modifying files like this.

We currently recommend using 1.75 mm filament when a rigid material like PLA is being used by an advanced user.

While 1.75 mm filament will work in your LulzBot 3D Printer, it’s not going to be as reliable as using the 3 mm filament your printer was designed around. If your advanced students prefer to use 1.75 mm filament, they can start with our existing profiles and change the filament diameter through the custom settings interface: https://www.lulzbot.com/learn/tutorials/tips-and-tricks-printing-175mm-filament.

If you’d like to request more supported materials, like specific types of 1.75 mm filament, open a feature request here: https://code.alephobjects.com/w/cura-lulzbot/bug_report/

Are you using a tool head with a filament path (~2 mm) designed around 1.75 mm filament? If so, include that information in your feature request.

As we design the printers for 3mm filament, and use 3mm filament internally, we will not have a “LulzBot-Perfect” 1.75mm profile available for a direct download. However you make a good point, and the process of updating each profile through the profile itself can be a little time consuming.

We will look into getting an update into the hot end filament diameter settings to get that all taken care of automatically. Thank you for the report!

Hi everyone, thanks for the replies.

Considering that the filament diameter is handled when you set up the ‘hot end’ tab when adding a printer in Cura LE, could that not override the filament diameter setting on the per-filament configurations maybe?

Granted there’s more to configuring filament than just the diameter size, but those other settings could generally be handled per filament than in a more global space, I’d think.