Taz 5 FlexyDually esteps calibration problems on E1

I’m having a lot of trouble getting my FlexyDually E1 tool to do repeatable estep calibration runs. I do get some repeatable runs, but many are quite different.

Here’s why I’m doing it… I switched out the flexy for the original wade(?) extruder body only. This retains the hotend, fan and stepper from the flexy. I’ve left the same flexydually firmware on the Taz 5.

I’m using the LCD and dial to enter new “E1teps” and then the computer to start the extrusion… <<< G1 F50 E100

What else can cause the extrude to vary how much filament is pulled into the extruder? The idler bolts are a touch under 5mm between washers, and feels reasonably firm.

I’m using 3mm HIPS filament at 250*C and a 0.35mm nozzle which seems to be extruding fine at “F50” rate. I have a jig that provides 20mm clearance from the extruder body, and 100mm measurement tube for marking the filament.

Here’s the full list of esteps and over/under results.

steps @Feed => mm

920.1 @F75 => +12
920.1 @F75 => +12; good pair of equal extrudes with identical settings
910.1 @F75 => -2.5; guess I should have ignored this one, because the delta esteps shouldn’t have resulted in under extrude!
913.7 @F75 => +16.5; another wonky result
913.7 @F75 => +12
913.7 @F75 => +12
913.7 @F50 => +12; slowed the feed rate down
911.7 @F50 => +12
910.7 @F50 => +10
908.7 @F50 => +7.5
906.7 @F50 => +7.5
900.1 @F50 => -5
902.1 @F50 => +17
902.1 @F50 => +11
; weird that this pair of 902.1 estep runs vary so much!
900.0 @F50 => +10.5; again, the previous ~900 estep run was nothing like this one :frowning:
900.0 @F50 => +10.5; however this run matched exactly

I’m obviously wasting a lot of time and filament for something that should only take a few runs to dial in… what should I look at next?

Is F50 reasonable feed rate for 3mm HIPS filament through a 0.35mm nozzle @250*C?

Could there possibly be something funky with the FlexyDually Taz5 firmware that makes this adjustment process unreliable? (I tried to use the host computer to issue the new esteps, but I could never get it to change E1… only E0 esteps would ever change; “G91 E1” then “M92 E920” didn’t work).

After updating through the LCD screen, be sure to go to configuration > store settings.

Within the Cura control box interface, you can switch between extruders using “T0” and “T1”. T0 will activate the rear extruder, T1 will activate the front extruder. You can than extrude and update those specific tool head settings through Cura.

If you are still having issues feel free to reach out to our 24/7 support staff at support@lulzbot.com

We hope this helps!