TAZ 6 Bed Calibration

Is there someway to adjust the bed calibration of the TAZ 6?

Currently, the upper left hand corner of the bed produces a fantastic 1st layer (filament nicely adhered to the bed). By the time I get to the lower right hand corner, I’m almost printing in air. It seems to be a fairly linear progression from the upper left (x,y) coordinate down to the lower right (x,y) coordinate (with less and less adhesion as you move along x and y).

Is this something I can adjust?

I don’t think there is a way to adjust the bed calibration as it is based on math that should work every time.

Once I had a bit of plastic under one of the bed calibration washers which makes the printer think the bed is higher than it is. I just unscrewed it and blew away the plastic. Another thing worth checking is that your nozzle is properly cleaned before bed levelling starts. If you notice that the bed is pressed down during calibration, the nozzle is not clean enough to make proper electrical contact.

Yes, please see step 6:
Print Octopus & check z-offset


Be careful and double check my steps before doing the following, possibly contact Lulzbot support first.

It would be even better if you could use a feeler gauge (EDIT paper, feeler gauge is metal and and short the hotend) and measure after bed leveling routine. Ideally your nozzle height should be 1/2 to 1/3 of your layer height. I say this because for the MOARStruder for example prints at massive layer heights and paper tolerance won’t work as you’d need 0.4-0.6mm layer heights.
G1 X0 Y-10 (Move nozzle)
G0 Z0 (Move to where machine thinks is zero)
Then jog in 0.1mm increments until the nozzle is in spec
M306 Z0 (Save current Z height as Z offset in firmware)
M500 (Save current offset to EPROM) - you could also just record the value M306 Z0 gives you and put it in Advanced Settings->Z-Offset (Not down your existing offset as it’s calibrated from factory, in case you need to revert).

Does it rewipe when doing the bed level? Mine did this and I found this guide


Start at step 23, only takes a minute and it might get you leved out.

I came here to ask the exact same question! I have two corners (top right and bottom left) that are noticeably lower in the z-axis than the other corners or middle.

Here is the top-right corner’s first layer (I flipped it over) along with the skirt (note the two skirt lines don’t even meet):

Here is the center one:

Makes it very frustrating to try and dial in my settings for a perfect first layer.

I’m slicing with Simplify3D, what are you using? Is there a chance the auto-leveling doesn’t “stick” when using S3D? I wouldn’t think so - I even copied over the start/end gcode from the latest Cura. I’m stumped - that’s the whole point of the auto-leveling and it doesn’t seem to be doing its job. :\

Edit: this looks like it might be the issue: https://forum.lulzbot.com/t/leveling-the-y-axis-getting-rid-of-high-low-spots/3706/1

Long time since I looked at this issue, should consider the link regardless…

I solved my problem via a couple of changes to my workflow:

First, I installed a PRINTinZ build plate on my Taz 6 (see here:http://www.plantation-productions.com/FunProjects/3DPrinting/PrintInZAdapter4Taz6/PrintInZAdapterTaz6.html).

Second, I set the first layer height (in Simplify 3D) to 220 and the width to 200. Yeah, this is killing a fly with a cannonball, but it worked.

Though the PRINTinZ board (zebra board) isn’t as smooth as the normal PEI surface, the fact that it is removable and flexible (meaning I can bend it to loosen parts) has been a big plus for me. I’ve already ruined two PEI surfaces (one only two months old) by prying parts off of them that adhered too strongly. The PRINTinZ plate solved that problem.

Thanks for the link, I’ll follow up on that as well.

I had similar problems with my taz6. Using a dial indicator mounted as a printhead, I found more than a 1mm difference between the back right and front left corners (after calibration). This was using the cura (not cura2) firmware. With the cura2 beta firmware it was sometimes better and sometimes worse because this firmware was only using a 3 point calibration to create a plane whereas the cura firmware was using all 4 calibration points and averaging the planes that are generated from those 4 points.

After going back and forth with support, I was sent a new aluminum plate. Using the cura2 firmware, this made things a lot better but not great. I could print a full bed calibration print using PLA if I applied glue stick to the bed (but not without the glue stick) because of the lowest corner.

Updating to the latest firmware (which may or may not have been released yet, I was building it from source), it is now generally okay. The newest firmware uses a different calibration algorithm that takes all 4 points into consideration and produces a better calibration (for me). With this version and the new plate I successfully printed a full bed calibration print without a glue stick. While it succeeded, it just barely succeeded having some minor issues in the corners (too close / too far from the bed). I doubt I would be able to get 3 calibration prints in a row to succeed but it’s close enough that I believe I could print a very large print using a glue stick to buffer the slightly too low points and it would work fine.

My take-aways for someone finding this topic are:

  • don’t rule out the plate being warped, but I’d suggest trying to verify that (I used a certified straight edge to check it).
  • older firmware may be better than more recent firmware but worse than the very latest firmware

and, frankly, just calibrating off the 4 corners has some limits in how well you can automatically level the bed. After trying to understand what was wrong with my printer I understand that it is unlikely to ever be 100.0% perfect. Calibration from the corners cannot capture a more complex problem like concavity or convexity in the build plate or non-planar deformations in the corners.

See Possible to display the four auto-leveling values? and SOLVED: Taz 6 auto leveling is >0.5mm off (NOW PERFECT TO 0.01mm!) for some tips on how to determine (and fix) the “levelness” of your bed.

my first step of my print the extruder and the bed are way out of alignment. How can i fix this???

I have this same problem too. It’s firmware related. It happens when I print two objects in a row without reseting the machine. Power down, power back up, then print seems to fix the issue.

Lulzbot needs to fix the firmware.

Randall Hyde