Taz 6 changes Z direction mid print

Just updated to the latest firmware ( and now i am having issues with my z movements. Sometimes the prints are fine. Sometimes when doing the bed leveling it will move up instead of down towards the pads. Other times it will switch z direction mid print. anyone else having any issues like this?

I ran for months on my Taz 6 with none of those issues.

Are you using old sliced GCODE with the new firmware? There’s a lot of startup that needs to be synchronized properly with firmware and startup GCODE.

Also, don’t rule out something mechanical, like your Z stepper driver motor going out. This would require a new board, or using modified firmware to use the rarely-used second extruder’s stepper driver to drive your Z axis.

I have a TAZ 6 legacy. Using the new CURA LE version (4.13.4) as well as the older Cura 3.6.37 with firmware prints are great. Of course, gcode was run separately for each. Upgrading firmware to (Zoffset and Esteps are entered as previous firmware values). Using CURA LE 4.13.4 with that gcode run on the firmware provides evidence that bed leveling is off. The octoprint is OK (small area in center). The system goes through wiping and leveling but over the bed area, it goes from too close to the bed to higher than desired. Any thoughts.

My Taz 6 is having issues with the new firmware too. And the new Cura LE Start G code is causing me some issues (separate thread posted in here “beeps at start”)

Any video of what you are describing? Printing from SD card?

Yes, I have some photos on PETg flat plates covering the bed and the octoprint. I will post those today. I should mention I am using a iWorks E3D Aero Titan Pro X toolhead.

Here is a link for using Cura 3.6.37 or Cura LE 4.13.4 with firmware. The prints are uniform on the bed and of height 2mm in PETg.

Here is a link for using Cura LE 4.13.4 with firmware. The skirt is horrible and the first plate shows the non-uniformity. Note the small area octo, printed at the center was fine.

I believe I may have found the issue. The bed leveling goes through the motions but the contacts to the continuity plate and each washer is off by 1mm in both x and y. One washer is just contacted on the edge of the washer. I am pretty sure it throws off the calculation. I should mention the wiping is just back and forth and not in a z pattern. I looked carefully for any debris on the nozzle throughout the homing and leveling and did not see any issues.
If someone has a way to adjust the leveling coordinates, it would help me. I would rather not mechanically adjust to avoid issues with my dual extruder.

Make sure you have set your toolhead in the menu on the printer, then re-enter your offset and esteps.

With those set, you can tweak it in the startup gcode with the M206 command - Set Home Offsets | Marlin Firmware - so if you put this command in your startup, it would shift the nozzle’s zero position. There is likely the M206 command commented out by putting a semicolon at the start in your startup GCODE.

If your wipe is in the right spot, but not the washer touches, put it after the wipe. If the wipe and washer touches are a little off, put it before the wipe. Change these numbers to what you need to make the taps hit the proper quadrant of all four of the washers.

M206 Y5 X5 ;Shift the nozzle's 0 position area 5mm to the left and 5mm to the front

And since it’s a good practice to remove the offset, put the reset command in your end GCODE:

M206 Y0 X0 ; reset nozzle 0 position

Thank you! Very clear. I will work on the code with your suggestions. Should solve all the issues.

I tried the M206 commands and successfully got all washers probed. However, the results were better but no where near the bed leveling with cura 3.6.37 and fw I did prints with the new fw and Cura 4.13.4 and fw and immediately followed with the older cura and fw. I get a -Z across the bed of at least 0.4mm in X, it is fine in the Y direction. In both, the nozzle is clean. Now I will get rid of the washers and go to BL touch as using Cura 3.6.37 constantly crashes loading a new file. I am also going to an Archim 2 board. Thanks again.