Trouble with Z axis on TAZ 6

Hi there,

I’m having trouble getting my TAZ 6 to behave. It seems to put down a layer or two successfully, but then starts mashing the print head into the existing layer.

As part of my troubleshooting I’ve tried the following:

  • Placing the printer on a large tile to ensure it is 100% flat
  • Following Squaring TAZ 6 Frame Workflow
  • Moving the Z axis up to 270 and back down again
  • Replaced the controller board with an Archim2 (including using the heatsink, heatsink compound and heatsink retainer from a TAZ Pro) and Drunken Octopus firmware
  • Increased the current of the Z axis driver up to the point where it will buzz

I’m not sure what I should look at next. Stepper motors, power supply?

The stepper motors and driver both stay very cool, so I don’t think this is the issue.

Has anyone else had this issue? I was really surprised when the controller didn’t fix the issue.

Thank you!

Just to add to this, I am using Cura LE 3.6.37 and I’m printing from the SD card. I’ve also tried SuperSlicer with the same result.

Photos of what results from this behavior would help.

What print head? What firmware? Is this new behavior on an old machine that was working, or an inherited problem on a new/used machine?

Thanks Wrathernaut,

It’s a bit difficult to capture with it all in focus, but here’s a try of a few failed prints:

I’m using the Aerostruder v2 with this release of Drunken Octopus firmware.

I was getting the exact same issue with the Rambo board running whatever version shipped with Cura LE 3.6.37, I would have to rig up a bench power supply to double check.

This is on an old machine that was working fine previously.


Could be overextrusion, confirm your esteps.

Z offset could be compensating and making first couple layers okay by printing higher so the overextrusion results in thicker layers, but after that, extra material had nowhere to go but up and into the path of the extruder.

Thank you Wrathernaut!!

It was the extruder steps set for the wrong print head, the problem was manifesting itself in the same way as before I changed boards, so I jumped to conclusions.

Now we’re printing better than ever!