TAZ Pro Filament Error

Recently my TAZ Pro has started chewing off the filament from the gear and generating a filament error. What purpose does the knob on the side of the extruder have? And are there any solutions to this issue? I have changed filament and the same thing keeps happening.

The knob on the side of each extruder adjust the tension on the filament “idler arm”. The filament feeds via a hobbed-gear … but the filament is pressed snugly against that gear with the “idler arm” (an arm with a wheel). The knob adjusts the spring-tension. If too loose, the filament can slip. If too tight, the teeth of the hobbed gear will dig in too hard and this can tear up the filament.

Ideally it should be maybe 1/3rd to perhaps 1/2 of the travel.

But another setting to check is your retractions…

The slicer software (e.g. Cura LulzBot Edition) has a few settings such as:

  • Retraction Distance
  • Maximum Retraction Count
  • Minimum Extrusion Distance Window
  • Minimum Retraction Travel

If you have a job where the slicer generates a lot of retractions without feeding much filament (lots of short segments of filament), then the printer ends up feeding, retracting, feeding, retracting, over and over the same little bit of filament. The sharp teeth in the hobbed gear end up tearing into the side of the filament until it digs a bit of a hole and just spins without the filament moving anymore (and then you have a jam).

So these settings let you tune the slicer behavior to avoid excessive retractions that would result in a jam. Here’s how they work.

  • Retraction Minimum Travel:

Suppose you set this to 2mm… this means that if the printer needs to end one segment of extrusion move LESS than 2mm before beginning another segment, then it wont even bother to retract (but this means you would likely get some stringing). I often set this to a value of about 1mm. This can result in a massive reduction in the number of retractions but you really need to inspect the slicer (switch Cura to ‘Layer View’ after slicing) to see where it does these retractions. Moving without retracting can result in a lot of ‘stringing’ in the print. But I find that often the retractions will happen in areas that wont be visible (infill, support, etc.) and not in the ‘skin’ if the part. So if that’s where the retractions are happening then I don’t care about the stringing.

  • Retraction Distance:

This is how much filament will be retracted when a retraction occurs. For PLA on a direct-drive printer (such as ours) these are usually low values … say around 1mm … maybe as high as 1.5mm but seldom more than 2mm. If you under-retract you can get stringing. If you over-retract you can pull in air-bubbles (that heat and ‘pop’ … causing poor print quality as the gas expands). But using a short retraction amount also means that it wont tear up much filament on each retraction.

  • Maximum Retraction Count:
  • Minimum Extrusion Distance Window:

These two settings work together. Say you set the Minimum Extrusion Distance Window to 3mm and you set the Maximum Retraction Count to 5. This would meant that the slicer will count the number of retractions needed WHILE also monitoring how much filament is advanced. If it needs to retract MORE than 5 times BEFORE it manages to push 3mm of fresh filament through … then it will ignore any additional retractions (beyond the 5) UNTIL it pushes through 3mm of filament. The idea is that it wont chew up the same short bit of filament over and over (resulting in a jam) … but once it advances enough filament to get to a clean piece that hasn’t been torn up by the hobbed gear … it will resume retracting again.

In other words, these two settings let you allow retractions to occur as normal… unless the quantity of retractions in a short distance starts to get ridiculous … and then ignore them until you get back to clean filament where it will resume normal retractions again.

I used values that are reasonable for stuff like PLA… some other filaments need different values. I use PVA support material and that stuff is just stringy. It needs big retraction values and it tears up very easily. When I print with TPU (e.g. NinjaFlex) that stuff is also stringy and doesn’t respond well to retractions (so I do things like set the slicer software to ‘wipe’ along the infill to hide the strings.

I just purchased 2 new Pro’s, have one setup and am consistently getting extruder 1 filament errors. It appears to be feeding just fine and I can ‘resume’ the project and most of the time it doesn’t have a problem after that but sometimes it’s error after error. Any ideas?

@JRE there is a wheel and encode that monitors filament movement (on the right side of the frame where you feed the filament into the teflon tube).

If, for example, the g-code calls for advancing 5mm of filament, the encoder also expects to see 5mm of filament. If it does not, it assumes the filament is slipping.

I did a filament change … as per usually removing the teflon tube from the print head so I could pull out the old filament and insert the new filament, but after the change I didn’t push the teflon tube back in place … after a few moments of printing it generated a filament jam error (because without that teflon tube in place on both ends you don’t get a 1 for 1 movement of filament (each millimeter of filament pulled through the extruder is matched by the same amount going through the jam sensor).

If your teflon tube is in place … check the encoder to make sure it is clean and rolling as the filament advances.

I seem to recall there is a menu to disable the jam sensor – if you aren’t able to resolve the issue. But I presume you’d rather resolve the issue. I have had a few jams … but they were either legit jams or my fault for not properly connecting the teflon tubes on both ends.

Thanks for the quick response! I disabled the sensor and now I’m fine, I ran 2 TAZ 6’s for almost 2 years without a sensor and was fine with it so I figure I’ll do the same with my Pro’s. I just need to figure out how to disable extruder #2 with single filament prints, seems like wasted time for extruder #2 to go through a wipe and other things when it doesn’t get used.

@JRE to disable extruder #2 there are two choices that come to mind.

  • You can set the filament type to “No Material” on extruder #2 … but it will still perform the nozzle cleaning (and since the nozzle clean warms the filament to back out a little before doing the wipe, it means you are slowly unloading the filament and after a few of those jobs in a row the filament would push itself out of the hobbed gear.)

  • The other option to create a new printer profile … basically a duplicate TAZ Pro printer… but manually edit the ‘Start’ g-code to disable all the steps that perform the wiping of nozzle #2.

There may be other choices that just don’t come to mind.