Taz Pro won't extrude


New to maintaining the Taz Pro for a publicly available machine at my job. After a patron used the machine, the machine won’t extrude any filament. I’ve tried both heads, neither will go. PLA filament is used 99.9% of the time, except this patron who likes to bring in his own Nylon. Steps I’ve taken so far are:

Tried different filament
Different Temps (Higher)
Manually push filament through
Tried to unclog (Was able to push through any previously left filament, but still couldn’t feed through from a fresh spool
Disassemble (both) extruder and check for clogs as well as clean
Clean Nozzle setting

No matter what I do, I just can’t get it to go all the way through. It will get past the gear and then start stripping the filament, a few mm above the end of the filament. It feels like it’s stuck on just the last bit. The nozzle itself gets hot (as tells my burnt finger) but when I unload the filament (so I don’t just keep stripping it) it looks like it wasn’t heated at all.

I’m probably missing something, so any help is appreciated!