Taz4 with Simplify3D

Any Taz4 and Simplify 3D owners here? If so, did Simplify 3D work “just out of the box” or did you need to tweak it? I just bought Simplify 3D but am running into an issue. I’ve posted this issue to them but haven’t heard back yet so I thought I’d post the issue here in case anyone here has also run into this issue.

This issue I’m running into is that when I print in Simplify 3D, printing endlessly waits for the bed to heat up, even though the bed has reached the desired bed temperature.

I own a Taz4 with firmware v4.1 (Marlin 2014Q3)
(I checked the Lulzbot website and that’s also the latest firmware, and I haven’t made any hardware or firmware modifications)

When I print, Simplify3D isn’t able to get past the “waiting for bed to heat up” phase.

Here are the repo steps:

  1. Open Simplify 3D
  2. Import a model
  3. Click the “Prepare to print” button
  4. Select the Process1 profile (Taz4 ABS medium quality profile, which Simplify3D auto-created)
  5. Click the “begin printing over USB” button

The Taz starts up, in the sense that the fan on the CPU (not the fan on the nozzle) starts running, and the bed starts heating up.

(don’t know if this is the issue or not, but while although the bed heats up, the nozzle doesn’t heat up)

After a while, the bed gets to 90 degrees (the target bed temperature) but Simplify3D just waits, saying “Preheating Bed…” even though the bed heats up to the desired temperature of 90 degrees.

Incase this was an issue with Simplify 3D waiting for the nozzle to heat up (and not giving the correct status message), I pre-heated my Taz, then started to print in Simplify 3D, but the same thing happen (simplify 3D stalls and the progress window says, “waiting for bed to heat up”



I have had the same problem with V3. Just add the following lines to the top of your start gcode and set your temps manually before the print.


This also solves the problem of temperature controllers being added back into the profiles after you delete them.

The problem is even though you set your bed temp to 90 and the LCD shows that it has reached 90. it is more like 90.142 so the gcode thinks it hasn’t reached it. By removing the start GCODE that waits for your printer to heat up you won’t have this problem. Simply preheat your printer before printing using the LCD.

There is a check-box on the Temperature tab of the Process settings that allows you to disable the wait for temp to stabilize. That is what I did for the most part, until I built an enclosure that solved the issue.

Thanks everyone!

I did some digging, and what’s going on is that even though the display on the Taz4 says the nozzle temp is 90, what it is communicating back is 89.9. I’m very new to Simplify3D, so I’ve got a lot to still learn, but this is what I’m doing now and it seems to work:

  1. Modify my process setting in Simplify3D, and in the temperature tab page, uncheck “wait for temperature…”
  2. Before I print, open the machine control panel, manually set the nozzle to 235, and the bed to 95 (both values more than the desired amount), and wait for the temp to get above 230/90
  3. Then print. When the print starts, even if the nozzle and bed have been set to a higher temp, the get set back to 230/90.

Thanks again everyone!